Bug 431969 - gnome-volume-control vs. Intel HDA (Alsa mixer): left/right channels spontaneously unlock
gnome-volume-control vs. Intel HDA (Alsa mixer): left/right channels spontane...
Status: CLOSED DUPLICATE of bug 431968
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 460058 (view as bug list)
Depends On: 431968
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 23:31 EST by Charles R. Anderson
Modified: 2009-01-19 11:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 11:07:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2008-02-07 23:31:54 EST
gnome-volume-control from gnome-media gets messed up by mixer_applet2, and
possibly by itself too.  Sometimes the left/right lock on gnome-volume-control
separates.  Then if you try to drag one of the left or right sliders on
gnome-volume-control, it only changes one of the channels until
you click the chain-link icon to lock the left/right channels together again. 

This seems to be very intermittent, so it may take much dragging around to get
it to happen.  I say below in the original mixer_applet2 bug that this only
happens if you just use gnome-volume-control alone and never touch the
mixer_applet2 slider, but that may not be the case.

+++ This bug was initially created as a clone of Bug #431968 +++

Description of problem:

Dragging the volume changes the volume, except there are certain points along
the slider where the volume is just entirely muted, including show the little
red 'x' icon next to the speaker icon.  Continuing to drag past these points
returns the volume to the "correct" level for that part of the slider.

Version-Release number of selected component (if applicable):
2.21.4-5.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. start playing music in e.g. Rhythmbox
2. play with dragging the volume slider in the panel
3. watch the red 'x' icon appear/disappear occasionally, along with the actual
sound being muted.
4. continue dragging, notice that the volume returns to the previous level.

Additional info:

Lenovo ThinkPad T61 with Intel HDA, snd-hda-intel driver:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 03)
        Subsystem: Lenovo ThinkPad T61
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin B routed to IRQ 17
        Region 0: Memory at fe020000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA
PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1
<1us
                        ExtTag- RBE- FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
                LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency
L0 <64ns, L1 <1us
                        ClockPM- Suprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk-
DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

-- Additional comment from cra@wpi.edu on 2008-02-07 23:27 EST --
Additional detail--this seems to only happen while actually playing music/sound.
 If you aren't playing anything, the muting doesn't happen no matter how much
you drag the slider.

Other interesting effect of this--gnome-volume-control from gnome-media gets
messed up by mixer_applet2.  If you start dragging the mixer_applet2 slider
while gnome-volume-control is open, sometimes the left/right lock on
gnome-volume-control separates.  Then if you try to drag one of the left or
right sliders on gnome-volume-control, it only changes one of the channels until
you click the chain-link icon to lock the left/right channels together again. 
This seems to be very intermittent, so it may take much dragging around to get
it to happen.  None of these problems happen if you just use
gnome-volume-control alone and never touch the mixer_applet2 slider.  I verified
that both applications are set to use the "Intel HDA (Alsa mixer)".  Actually
this effect, might be a gnome-volume-control bug, so I'll clone this bugzilla to
gnome-media.
Comment 1 Bastien Nocera 2008-04-18 09:52:52 EDT
Please test with the new gstreamer-plugins-base:
http://koji.fedoraproject.org/koji/buildinfo?buildID=46563
Comment 2 Charles R. Anderson 2008-04-21 16:52:14 EDT
This problem still happens with gstreamer-plugins-base-0.10.19-2.fc9.i386. 
Wildly dragging either the gnome-volume-control "Master" or the mixer_applet2
slider sometimes causes the left/right lock to separate.  It is somewhat hard to
reproduce.  Just keep rapidly dragging the slider up and down and eventually it
will happen.
Comment 3 Bug Zapper 2008-05-14 01:04:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Zdenek Kabelac 2008-06-19 07:39:39 EDT
I'm experiencing this problem as well - using  PCM/PCM2 volume control is
extremely unpleasant - I'm even running upstream kernel.

Using aumix seems to work very well in this case.

And what is also noticeable - while aumix lowers the PCM volume to approximately
half of the bar - g-v-c PCM volume level gets stack there (I'd guess in 3/5 of
the slide bar) and no longer moves. 

Why is this bug unfixed for a few months?
Comment 5 Charles R. Anderson 2008-12-21 13:53:50 EST
*** Bug 460058 has been marked as a duplicate of this bug. ***
Comment 6 Volans 2008-12-22 14:57:10 EST
I didn't notice the "mute" problem, but it happens the same with me about the two sliders, for the left and the right channels to unlock, and stop moving together. It's a really annoying bug, that happens all the time...
Comment 7 Bastien Nocera 2009-01-19 11:07:36 EST

*** This bug has been marked as a duplicate of bug 431968 ***

Note You need to log in before you can comment on or make changes to this bug.