Bug 437522

Summary: runs chkconfig on service start
Product: [Fedora] Fedora Reporter: Bill Nottingham <notting>
Component: iscsi-initiator-utilsAssignee: Mike Christie <mchristi>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: agrover, berrange, dcantrell, jonstanley, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 511271 (view as bug list) Environment:
Last Closed: 2008-04-29 10:01:45 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235706, 246960, 511271    

Description Bill Nottingham 2008-03-14 13:52:50 EDT
Description of problem:

iscsi-initiator-utils runs chkconfig on service start to enable/disable
services.

1) This is horribly broken on a read-only root system
2) This will cause chkconfig to recalculate dependencies on the network service...
3) ... causing the ordering to change out from under /etc/rc *while it's
running*. That's not good.
4) I'm somewhat surprised SELinux actually lets you do this

Version-Release number of selected component (if applicable):

iscsi-initiator-utils-6.2.0.868-0.3.fc9.x86_64
Comment 1 Jesse Keating 2008-04-03 15:25:21 EDT
Mike, any update on this?  Please please please fix this for Fedora 9.  Freeze
is 5~ days away.
Comment 2 Mike Christie 2008-04-04 12:20:04 EDT
Sorry I did not know this was a blocker. I was working on my RHEL5 excpetions
and blockers instead. I just need to do some real testing for my patches for
this and 436341 and I will get them checked in today or Sat.
Comment 3 Mike Christie 2008-04-04 15:11:19 EDT
Fixed in iscsi-initiator-utils-6.2.0.868-0.6
Comment 4 Mike Christie 2008-04-09 00:19:07 EDT
*** Bug 436341 has been marked as a duplicate of this bug. ***
Comment 5 Jon Stanley 2008-04-14 10:56:28 EDT
Huh?  This is still there (in /etc/init.d/iscsid):

        echo -n $"Turning off network shutdown. "
        # we do not want iscsi or network to run during system shutdown
        # incase there are RAID or multipath devices using
        # iscsi disks
        chkconfig --level 06 network off
        rm /etc/rc0.d/*network
        rm /etc/rc6.d/*network
Comment 6 Jon Stanley 2008-04-14 10:59:31 EDT
well, I take that back - you mentioned it's fixed in a later version than what's
in F9, but I can't find this version in koji:

[jstanley@rugrat ~]$ koji latest-pkg f9-final iscsi-initiator-utils
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
iscsi-initiator-utils-6.2.0.868-0.3.fc9   f9-final              michaelc
[jstanley@rugrat ~]$ koji latest-pkg dist-f9 iscsi-initiator-utils
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
iscsi-initiator-utils-6.2.0.868-0.3.fc9   dist-f9               michaelc
Comment 7 Jon Stanley 2008-04-18 01:11:12 EDT
This is fixed in CVS, but not tagged in CVS nor built in koji.

PLEASE take the 10 seconds to do this :)
Comment 8 Jeremy Katz 2008-04-18 13:47:21 EDT
Changing the status back to ASSIGNED so that it doesn't get lost.
Comment 9 Jeremy Katz 2008-04-24 17:27:47 EDT
Mike?
Comment 10 Mike Christie 2008-04-25 12:51:59 EDT
Sorry, I thought I could not could not add it yet, because it was not a critical
bug fix? Can I build it so it goes out in the F9 release or just build it into 
koji and then release and push it after F9 is out?
Comment 11 Bill Nottingham 2008-04-25 13:12:46 EDT
It's on the blocker list, so building in F9 and following 
http://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy would be
appreciated.
Comment 12 Mike Christie 2008-04-25 14:45:58 EDT
Thanks Bill.

The final release is iscsi-initiator-utils-6.2.0.868-0.7.fc9. It is built in and
I sent a request to rel-eng for it to be included in f9.
Comment 13 Adam Jackson 2008-04-29 10:01:45 EDT
% koji latest-pkg --quiet f9-final iscsi-initiator-utils
iscsi-initiator-utils-6.2.0.868-0.7.fc9   f9-final              michaelc

Calling this one fixed.