Bug 246960 - Initscript Review
Summary: Initscript Review
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iscsi-initiator-utils   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Mike Christie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 436175 436341 437522
Blocks: InitscriptStatus
TreeView+ depends on / blocked
 
Reported: 2007-07-05 13:52 UTC by Harald Hoyer
Modified: 2018-04-11 10:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 18:26:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Harald Hoyer 2007-07-05 13:52:30 UTC
Please have a look at the wikipage 
http://fedoraproject.org/wiki/FCNewInit/Initscripts
and change your initscripts to comply with the LSB standard.
Especially check the exit status and add a LSB Header.
E.g. starting a service should return with 0, if the service is already running and stopping a stopped service should also return with 0.

Also check, if your service has to be _on_ per default, and turn it off in the old chkconfig line, if not.

Thank you.

Comment 1 Lubomir Kundrak 2008-02-05 19:39:32 UTC
Mike: What's the status of this? Could you please roll an updated package?

Comment 2 Mike Christie 2008-02-06 22:38:04 UTC
I checked in the changes for this and rolled a new package. I ran rpmlint and
still have these errors:


iscsi-initiator-utils.x86_64: E: non-readable /etc/iscsi/iscsid.conf 0600
iscsi-initiator-utils.x86_64: W: summary-not-capitalized iSCSI daemon and
utility programs

iSCSI is the name of the protocol.

iscsi-initiator-utils.x86_64: E: statically-linked-binary /sbin/iscsistart

We are working on this.

iscsi-initiator-utils.x86_64: W: service-default-enabled /etc/rc.d/init.d/iscsi
iscsi-initiator-utils.x86_64: W: no-reload-entry /etc/rc.d/init.d/iscsi
iscsi-initiator-utils.x86_64: W: service-default-enabled /etc/rc.d/init.d/iscsid
iscsi-initiator-utils.x86_64: W: no-reload-entry /etc/rc.d/init.d/iscsid


There is no reload, because we do not fully support it yet (it is a dangerous,
so we are working on code to make it more user friendly).

And it is enabled, because I thought it was before and was not sure what to do.


Comment 3 Matěj Cepl 2008-03-08 08:06:13 UTC
(In reply to comment #2)
> And it is enabled, because I thought it was before and was not sure what to do.

I don't know how to deal with backwards compatibility, but it should certainly
NOT be on when newly installed (because some package, ehm libvirt, decides that
it needs iscsi-*utils -- bug 436600), moreover when it is broken (bug 436341 and
bug 436175).



Comment 4 Matěj Cepl 2008-03-08 08:12:04 UTC
About defaulting of the init scripts read
http://fedoraproject.org/wiki/PackagingDrafts/ScriptletSnippets#head-c29cf3af4233d5fcfeba2d7a50f63587eca13db1
(yes, it is a packaging draft, but it reflects commonly viewed opinion -- see
the discussion of this issue on fedora-devel (e.g.,
http://thread.gmane.org/gmane.linux.redhat.fedora.devel/26750/focus=26754)

Comment 5 Bug Zapper 2008-05-14 03:02:40 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Hans de Goede 2008-10-13 18:26:20 UTC
Short intro: I've recently begun as an iscsi-initiator-utils co-maintainer and as such I'm looking into all open bugs.

The iscsi services are *vital* for systems using iscsi, so they must be enabled bu default.

iscsi-initiator-utils-6.2.0.870-0.1.rc1.fc10 which will be in tomorrows rawhide has rewritten initscripts, which will silently exit with a 0 status ASAP when iscsi is not needed. This should migate any complaints as a user no longer sees any messages (when not using iscsi) and the actual time spend in the scripts is negligible (all the detection code does is 1 grep)

These new scripts have been written using the template from:
http://fedoraproject.org/wiki/Packaging/SysVInitScript

And meet all initscript guidelines, this I'm closing this.


Note You need to log in before you can comment on or make changes to this bug.