This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 442567

Summary: No way to set system locale to en_GB
Product: [Fedora] Fedora Reporter: Tim Waugh <twaugh>
Component: pungiAssignee: David Cantrell <dcantrell>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: austin, dcantrell, katzj, mefoster, piotrdrag, psatpute, rodd
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: NeedsRetesting
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-14 14:27:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 442901    
Bug Blocks: 235706    

Description Tim Waugh 2008-04-15 11:28:25 EDT
Description of problem:
Installing Fedora 9 Beta, I selected 'English (English)' as the language to use
while installing; I selected a United Kingdom layout keyboard; I chose
'Europe/London' for my time zone.

When the installation has completed, /etc/sysconfig/i18n sets the locale to
'en_US.UTF-8'.

This is bad because it means that system daemons will start in the wrong locale.
 In particular, cupsd will be in a Letter paper size locale instead of an A4
paper size locale.

The end result: plugging in a USB printer will configure it with the wrong paper
size.

How reproducible:
100%

Steps to Reproduce:
1. Install in United Kingdom.
2. Plug in USB printer.
3. Print test page.
  
Actual results:
Page doesn't fit on paper.

Expected results:
Page fits paper perfectly.

Additional info:
This is going to hit every single English-speaking A4 user who prints.

Apologies for the late report; hardware constraints have prevented me from
testing rawhide since November.
Comment 1 Jeremy Katz 2008-04-15 12:14:30 EDT
This has always been the case.  We probably should revisit the way we do locale
selection in Fedora 10.
Comment 2 Tim Waugh 2008-04-16 04:29:58 EDT
What makes this worse for Fedora 9 is that system-config-language is no longer
installed by default.  I just tried a DVD install of Fedora 9 Beta and can
confirm this is the case.
Comment 3 Chris Lumens 2008-04-18 10:37:11 EDT
*** Bug 433895 has been marked as a duplicate of this bug. ***
Comment 4 Tim Waugh 2008-04-25 08:05:48 EDT
So in fact this is quite disastrous:

1. Install Fedora 9, selecting 'United Kingdom', 'English', 'London', etc
2. Locale is incorrect, so try to change language
3. System->Administration->Language not in menu, so select 'Add/Remove Software'
4. Install system-config-language
5. Use it to set language to "English (Great Britain)".
6. "British language support is not installed, do you want to install it?": yes
7. Silent traceback due to bug #442901.

Even after all this, my locale is still en_US!
Comment 5 Jeremy Katz 2008-04-25 11:21:18 EDT
We could add system-config-language back to being installed by default, although
with the state that its in, I'm not sure how much that helps.

anaconda's definitely not going to grow entirely new UI at this point
Comment 6 Tim Waugh 2008-04-25 13:12:35 EDT
I don't think it would take very much to get system-config-language working
again: seems to me that it's just a case of adding yumhelpers.glade from pirut
into system-config-language and adjusting the path it uses to look for it (I've
added a comment to bug #442901 about that).  Granted, this would be a short-term
solution until system-config-language grows PackageKit support, but I think that
the most important thing is to be able to change the language post-install,
especially considering the situation with English.

Perhaps we could even consider removing the "install language group" feature
from system-config-language until it is fixed properly?
Comment 7 Bill Nottingham 2008-04-25 13:15:19 EDT
Might be simplest, yes.
Comment 8 Tim Waugh 2008-04-28 12:57:02 EDT
system-config-language-1.2.15-3.fc9 contains this fix.  Not sure if Pravin has
sent email to rel-eng.
Comment 9 Pravin Satpute 2008-04-29 03:24:14 EDT
sent mail to releng :)
i will try to see if system-config-language can use PackageKit in some way so it
can do install language group.
talked with PackageKit developers they says there are some libraries. Just
initial discussion exploring on this.
Comment 10 Bill Nottingham 2008-04-29 15:54:25 EDT
This is now included.
Comment 11 Tim Waugh 2008-04-29 18:05:14 EDT
Included in the default package set?
Comment 12 Bill Nottingham 2008-04-29 20:20:26 EDT
It's a default package in Admin Tools.
Comment 13 Linus Walleij 2008-05-04 18:02:27 EDT
Would you say this is related to bug 432887?
Comment 14 Bill Nottingham 2008-05-05 11:57:35 EDT
Somewhat, but this is that there was no way at all in the system to do so ...
there is with system-config-language. (There's also the language chooser on GDM
login.)
Comment 15 Tim Waugh 2008-05-14 04:04:01 EDT
(In reply to comment #12)
> It's a default package in Admin Tools.

But it is not installed by default.  This means that on a default install (i.e.
just clicking Next except where indicated in comment #0) you have to *install
extra packages* in order to get the correct system locale.
Comment 16 Tim Waugh 2008-05-14 04:05:22 EDT
(In reply to comment #1)
> This has always been the case.  We probably should revisit the way we do locale
> selection in Fedora 10.

It has not always been the case, just for a long time -- Red Hat Enterprise
Linux 4 sets the correct system locale, for example.
Comment 17 Bill Nottingham 2008-05-14 13:24:34 EDT
(In reply to comment #15)
> (In reply to comment #12)
> > It's a default package in Admin Tools.
> 
> But it is not installed by default.  This means that on a default install (i.e.
> just clicking Next except where indicated in comment #0) you have to *install
> extra packages* in order to get the correct system locale.

How so? It's default (on by default) in Admin tools, which is selected by
default. It's also there on the LiveCD.

What appears to have happened is that admin tools wasn't used for the Fedora
compose. Assigning to pungi.

Comment 18 Jesse Keating 2008-05-14 14:27:59 EDT
Well that's neat.  I could have sworn there were on the manifest.  Wonder how
long it's been missing....

I've fixed this upstream.  Will be fixed next release.