Bug 443700

Summary: shell on VT2 doesn't work in text-mode installs
Product: [Fedora] Fedora Reporter: Will Woods <wwoods>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: ma
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: NeedsRetesting
Fixed In Version: anaconda-11.4.0.80 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-01 11:25:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235706    

Description Will Woods 2008-04-22 17:59:02 EDT
If you do a text-mode install with anaconda-11.4.0.73 (F9Preview), there's a
nice '#' prompt on VT2. In graphical installs it's a root shell, but that says
'sh-3.2#'.

Anyway. You can type something at the prompt and hit Enter, but nothing will happen.

I'm not sure how to debug this further without actually having a shell.
Comment 1 Jeremy Katz 2008-04-22 18:09:52 EDT
Pretty sure it was working for me earlier today with a rawhide install -- the
difference in prompts is because in one case, you're getting minstg2.img and the
busybox shell and in the other case, it's bash.  What install method was this with?
Comment 2 Will Woods 2008-04-22 18:22:44 EDT
Figured it was busybox or something. This is with a minstg2.img preupgrade,
using http:// as the fallback method.
Comment 3 Jeremy Katz 2008-04-22 18:51:43 EDT
*** Bug 443265 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2008-04-22 18:54:21 EDT
Reproduced.  Although, ugh, going to be a pain to track down
Comment 5 Jeremy Katz 2008-04-29 17:15:20 EDT
Should be fixed (switched minstg2.img to just use bash and I've tested that bash
is working in minstg2.img)
Comment 6 Bill Nottingham 2008-04-30 14:35:42 EDT
Will, can you test this with today's tree?
Comment 7 Will Woods 2008-04-30 16:23:17 EDT
No good - I'm still getting the plain '#' prompt, which probably indicates
busybox instead of bash. And it doesn't work.
Comment 8 Jeremy Katz 2008-04-30 21:41:30 EDT
This is because I'm a moron and didn't add the binary to the file list.  Fixed
Comment 9 Will Woods 2008-05-01 11:25:57 EDT
Works fine with anaconda-11.4.0.80 (rawhide-20080501).