Bug 443700 - shell on VT2 doesn't work in text-mode installs
Summary: shell on VT2 doesn't work in text-mode installs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: NeedsRetesting
Keywords:
: 443265 (view as bug list)
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2008-04-22 21:59 UTC by Will Woods
Modified: 2008-05-01 15:25 UTC (History)
1 user (show)

Fixed In Version: anaconda-11.4.0.80
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-01 15:25:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Will Woods 2008-04-22 21:59:02 UTC
If you do a text-mode install with anaconda-11.4.0.73 (F9Preview), there's a
nice '#' prompt on VT2. In graphical installs it's a root shell, but that says
'sh-3.2#'.

Anyway. You can type something at the prompt and hit Enter, but nothing will happen.

I'm not sure how to debug this further without actually having a shell.

Comment 1 Jeremy Katz 2008-04-22 22:09:52 UTC
Pretty sure it was working for me earlier today with a rawhide install -- the
difference in prompts is because in one case, you're getting minstg2.img and the
busybox shell and in the other case, it's bash.  What install method was this with?

Comment 2 Will Woods 2008-04-22 22:22:44 UTC
Figured it was busybox or something. This is with a minstg2.img preupgrade,
using http:// as the fallback method.

Comment 3 Jeremy Katz 2008-04-22 22:51:43 UTC
*** Bug 443265 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2008-04-22 22:54:21 UTC
Reproduced.  Although, ugh, going to be a pain to track down

Comment 5 Jeremy Katz 2008-04-29 21:15:20 UTC
Should be fixed (switched minstg2.img to just use bash and I've tested that bash
is working in minstg2.img)

Comment 6 Bill Nottingham 2008-04-30 18:35:42 UTC
Will, can you test this with today's tree?

Comment 7 Will Woods 2008-04-30 20:23:17 UTC
No good - I'm still getting the plain '#' prompt, which probably indicates
busybox instead of bash. And it doesn't work.

Comment 8 Jeremy Katz 2008-05-01 01:41:30 UTC
This is because I'm a moron and didn't add the binary to the file list.  Fixed

Comment 9 Will Woods 2008-05-01 15:25:57 UTC
Works fine with anaconda-11.4.0.80 (rawhide-20080501).


Note You need to log in before you can comment on or make changes to this bug.