Bug 445553

Summary: DMAR (intel_iommu) broken on yet another machine
Product: [Fedora] Fedora Reporter: Enrique V. Bonet Esteban <enrique.bonet>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8CC: hantsy, i.mortimer, jcm, red.ostrava, scott.ryan
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.25.4-10.fc8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-06 03:45:17 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Enrique V. Bonet Esteban 2008-05-07 11:27:32 EDT
Description of problem:

In two Intel S3200SH server motherboards, one with the 33 version of the BIOS 
and Xeon processor 3075, and another with the 39 version of the BIOS and Xeon
processor 3085, the 2.6.24 fedora 8 kernels generated the following boot error:

DMAR:DRHD (flags: 0x0000001c) base: 0x0000feb010000000

This error is written repeatedly on the screen and the system does not boot.

When trying to boot with argument "acpi = off", the systems boots, but the 
kernel detects the Xeon 3075 or 3085 processor as single core.

The systems boot correctly with 2.6.23 kernels.

Version-Release number of selected component (if applicable):

All 2.6.24 kernels.

How reproducible:

Update or install any 2.6.24 kernel in an Intel S3200SH server motherboard.

Steps to Reproduce:
1. Install the 2.6.24 kernel in an Intel server S3200SH motherboard.
2. Boot the system, the boot failed.
3. Put the acpi = off argument in the boot options, the system boot, but
cat /proc/cpuinfo report only one processor (processor 0).
  
Actual results:

cat /proc/cpuinfo

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Xeon(R) CPU            3075  @ 2.66GHz
stepping        : 11
cpu MHz         : 2660.039
cache size      : 4096 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm const
ant_tsc up arch_perfmon pebs bts rep_good pni monitor ds_cpl vmx smx est tm2
ssse3 cx16 xtpr lahf_lm
bogomips        : 5322.08
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

Additional info:
Comment 1 Dave Jones 2008-05-07 11:55:07 EDT
probably yet another case of buggy firmware.  I think we're just going to have
to turn this off for now.   The code needs to become a lot more tolerant of crap
BIOSes.
Comment 2 Chuck Ebbert 2008-05-07 13:10:01 EDT
It should boot with this option:

  intel_iommu=off
Comment 3 Dave Jones 2008-05-07 13:18:08 EDT
I sent a pointer to this bug to the upstream developers. hopefully they'll be
able to make their code handle cases like this automatically, but I really think
this code isn't ready for primetime just yet.
Comment 4 Chuck Ebbert 2008-05-23 03:48:15 EDT
DMAR has been disabled in the 2.6.25 kernels for Fedora 8.
Comment 5 Fedora Update System 2008-05-23 03:52:35 EDT
kernel-2.6.25.4-10.fc8 has been submitted as an update for Fedora 8
Comment 6 Chuck Ebbert 2008-05-23 03:57:07 EDT
*** Bug 444420 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-05-28 22:41:32 EDT
kernel-2.6.25.4-10.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-4484
Comment 8 Enrique V. Bonet Esteban 2008-05-30 07:05:03 EDT
The update fixes the bug. The kernel boots properly without the option
intel_iommu = off
Comment 9 Fedora Update System 2008-06-06 03:45:11 EDT
kernel-2.6.25.4-10.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Chuck Ebbert 2008-06-11 21:25:49 EDT
*** Bug 436899 has been marked as a duplicate of this bug. ***
Comment 11 Scott Ryan 2009-11-21 08:55:04 EST
I have this problem with Fedora 12 on Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz

kernel panic - not syncing: DMAR hardware is malfunctioning
Comment 12 Ian Mortimer 2009-11-22 20:03:41 EST
Just a guess but I think you're more likely to get a response to this if you open a new bug report for Fedora 12.   This bug was for Fedora 8 which is no longer supported.
Comment 13 George 2009-11-26 01:22:27 EST
"Just a guess but I think you're more likely to get a response to this if you
open a new bug report for Fedora 12"

bug #540082 opened for FC12 on this issue
Comment 14 Hantsy Bai 2009-12-31 06:02:43 EST
The "intel_iommu = off" resovle the kernelpanic, but it stop installation at startup installer here..
My notebook is hp compaq cq40 609tx.