This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 446051

Summary: Elisa doesn't start
Product: [Fedora] Fedora Reporter: Carlo Raudino <karlpiuemeno>
Component: elisaAssignee: Matthias Saou <matthias>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: farrellj, patrick, redhat, thub
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-08-26 10:42:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Automatic backtrace from elisa
none
Elisa error info
none
elisa tmp file
none
elisa tmp none

Description Carlo Raudino 2008-05-12 08:21:32 EDT
Description of problem:
Starting elisa, results in:
[carlo@karlpc ~]$ elisa
WARN  MainThread      plugin_registry             mag 12 14:11:57  Un-met
dependency for classic: pgm (elisa/core/plugin_registry.py:195)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Un-met
dependency for flickr_media: twill (elisa/core/plugin_registry.py:198)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Un-met
dependency for bluetooth_input: bluetooth (elisa/core/plugin_registry.py:198)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Un-met
dependency for poblenou: pgm (elisa/core/plugin_registry.py:195)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Un-met
dependency for stage6: BeautifulSoup (elisa/core/plugin_registry.py:195)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Un-met
dependency for weather_pgm_view: pgm (elisa/core/plugin_registry.py:198)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Component
fspot_media failed to initialize: FSpot DB not found at
'/home/carlo/.gnome2/f-spot/photos.db' (elisa/core/plugin_registry.py:618)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Component
'flickr:flickr_media' not found (elisa/core/plugin_registry.py:618)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Plugin
'stage6' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Component
'stage6:stage_media' not found (elisa/core/plugin_registry.py:618)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Plugin
'poblenou' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      comp_theme_switcher_activity mag 12 14:11:58  Component
'poblenou:tango_theme' not found
(elisa/plugins/good/theme_switcher/theme_switcher_activity.py:56)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Plugin
'poblenou' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      comp_theme_switcher_activity mag 12 14:11:58  Component
'poblenou:poblenou_theme' not found
(elisa/plugins/good/theme_switcher/theme_switcher_activity.py:56)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Plugin
'poblenou' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      comp_theme_switcher_activity mag 12 14:11:58  Component
'poblenou:chris_theme' not found
(elisa/plugins/good/theme_switcher/theme_switcher_activity.py:56)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Plugin
'poblenou' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      comp_theme_switcher_activity mag 12 14:11:58  Component
'poblenou:tango_theme' not found
(elisa/plugins/good/theme_switcher/theme_switcher_activity.py:56)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Plugin
'poblenou' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      comp_theme_switcher_activity mag 12 14:11:58  Component
'poblenou:poblenou_theme' not found
(elisa/plugins/good/theme_switcher/theme_switcher_activity.py:56)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Plugin
'poblenou' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      comp_theme_switcher_activity mag 12 14:11:58  Component
'poblenou:chris_theme' not found
(elisa/plugins/good/theme_switcher/theme_switcher_activity.py:56)
WARN  MainThread      plugin_registry             mag 12 14:11:58  Plugin
'poblenou' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      interface_controller        mag 12 14:11:58  Cannot create
controller 'poblenou:elisa_controller' for backend 'backend1'
(elisa/core/interface_controller.py:130)
WARN  MainThread      interface_controller        mag 12 14:11:58  An error
occured causing backend 'backend1' creation to fail
(elisa/core/interface_controller.py:75)
A problem occurred in Elisa.
/tmp/elisa_vVq6xO.txt contains the description of this error.
WARN  MainThread      interface_controller        mag 12 14:11:58  Backend
'backend1' not existing for frontend 'frontend1'
(elisa/core/interface_controller.py:165)
WARN  MainThread      interface_controller        mag 12 14:11:58  An error
occured causing frontend 'frontend1' creation to fail
(elisa/core/interface_controller.py:90)
A problem occurred in Elisa.
/tmp/elisa_-Q610h.txt contains the description of this error.

---------------------------------------------------------------
Additional info: Content of /tmp/elisa_-Q610h.txt

<class 'elisa.core.plugin_registry.ComponentNotFound'>
Python 2.5.1: /usr/bin/python
Mon May 12 14:11:58 2008

A problem occurred in a Python script.  Here is the sequence of
function calls leading up to the error, in the order they occurred.

 /usr/lib/python2.5/site-packages/elisa/core/interface_controller.py in
initialize(self=<elisa.core.interface_controller.InterfaceController object at
0x97f9f4c>)
   85         for frontend_path in frontend_paths:
   86             try:
   87                 self._create_frontend(frontend_path)
   88             except Exception, e:
   89                 self.warning("An error occured causing frontend '%s'
creation " \
self = <elisa.core.interface_controller.InterfaceController object at 0x97f9f4c>
self._create_frontend = <bound method
InterfaceController._create_fronte...troller.InterfaceController object at
0x97f9f4c>>
frontend_path = 'frontend1'

 /usr/lib/python2.5/site-packages/elisa/core/interface_controller.py in
initialize(self=<elisa.core.interface_controller.InterfaceController object at
0x97f9f4c>)
   70         for backend_path in backend_paths:
   71             try:
   72                 self._create_backend(backend_path)
   73             except Exception, e:
   74                 self.warning("An error occured causing backend '%s'
creation " \
self = <elisa.core.interface_controller.InterfaceController object at 0x97f9f4c>
self._create_backend = <bound method
InterfaceController._create_backen...troller.InterfaceController object at
0x97f9f4c>>
backend_path = 'backend1'

 /usr/lib/python2.5/site-packages/elisa/core/interface_controller.py in
_create_backend(self=<elisa.core.interface_controller.InterfaceController object
at 0x97f9f4c>, backend_name='backend1')
  125                                                         default=[])
  126         try:
  127             root_controller =
plugin_registry.create_component(controller_path)
  128         except:
  129             self.warning("Cannot create controller %r for backend %r",
root_controller undefined
plugin_registry = <elisa.core.plugin_registry.PluginRegistry object at 0x93876ac>
plugin_registry.create_component = <bound method PluginRegistry.create_component
of...gin_registry.PluginRegistry object at 0x93876ac>>
controller_path = 'poblenou:elisa_controller'

 /usr/lib/python2.5/site-packages/elisa/core/plugin_registry.py in
create_component(self=<elisa.core.plugin_registry.PluginRegistry object at
0x93876ac>, component_path='poblenou:elisa_controller')
  454         except PluginNotFound, error:
  455             self.warning(error)
  456             raise ComponentNotFound(component_path)
  457 
  458         ComponentClass, plugin, component_path_tuple = infos
global ComponentNotFound = <class 'elisa.core.plugin_registry.ComponentNotFound'>
component_path = 'poblenou:elisa_controller'
<class 'elisa.core.plugin_registry.ComponentNotFound'>: Component
'poblenou:elisa_controller' not found

The above is a description of an error in a Python program.  Here is
the original traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/elisa/core/interface_controller.py",
line 87, in initialize
    self._create_frontend(frontend_path)
  File "/usr/lib/python2.5/site-packages/elisa/core/interface_controller.py",
line 72, in initialize
    self._create_backend(backend_path)
  File "/usr/lib/python2.5/site-packages/elisa/core/interface_controller.py",
line 127, in _create_backend
    root_controller = plugin_registry.create_component(controller_path)
  File "/usr/lib/python2.5/site-packages/elisa/core/plugin_registry.py", line
456, in create_component
    raise ComponentNotFound(component_path)
ComponentNotFound: Component 'poblenou:elisa_controller' not found
Comment 1 Bug Zapper 2008-05-14 07:02:13 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Ira Malinich 2008-05-16 23:57:04 EDT
I'm also experiencing this.  My /tmp/elisa_??????.txt looks similar, but I'll
attach mine too.
Comment 3 Ira Malinich 2008-05-16 23:58:12 EDT
Created attachment 305782 [details]
Automatic backtrace from elisa
Comment 4 Jonathan Roberts 2008-05-18 11:56:08 EDT
Also seeing a similar problem. Attaching my output from /tmp/elisa_ ...

Let me know if you need any other information to help solve this :)
Comment 5 Jonathan Roberts 2008-05-18 11:56:45 EDT
Created attachment 305856 [details]
Elisa error info
Comment 6 Patrick Steiner 2008-06-08 12:50:31 EDT
Created attachment 308658 [details]
elisa tmp file

i have got a similar problem

attached my tmp file
Comment 7 Valent Turkovic 2008-07-01 04:57:44 EDT
Created attachment 310645 [details]
elisa tmp

I have the same error, here is my log file.
Comment 8 Carlo Raudino 2008-07-01 05:57:17 EDT
It looks like no one is interested in fixing this issue........ I filed this bug
on may, but the problem was already in fedora 8........I don't understand why we
have an unusable software in our repository.

What's wrong with elisa? fix it or delete from repository...
Comment 9 Matthias Saou 2008-07-01 06:35:07 EDT
The fix is to update Elisa. But Elisa can't be updated before the new split out
packages are reviewed in order to be included in Fedora. So things have been
stalled for months, waiting for someone to help review the packages...

See bug #429590 for tracking the update.

See bug #438608 for the elisa-plugins-good review.
See bug #438609 for the elisa-plugins-bad review.
Comment 10 Matthias Saou 2008-08-26 10:42:37 EDT
(same message as for bug #407631)

Sorry folks, but the 0.3 elisa codebase probably won't ever be updated again, and the 0.5 packages are still pending review of the new separate plugins packages as well as the Twisted web2 package.

So I'll close this bug report... Please check out bug #429590 to track the elisa update, there are links in there to some testing 0.5 packages.

If the problem is still present in 0.5, it obviously can't yet be fixed in Fedora itself, so please do also file a bug report upstream for the developers to take care of it, thanks.
Comment 11 Matthias Saou 2008-09-15 07:51:06 EDT
*** Bug 462115 has been marked as a duplicate of this bug. ***