Bug 470367

Summary: plymouth blows assertion when trying to mount /
Product: [Fedora] Fedora Reporter: Brandon Thomas <brandon>
Component: plymouthAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: atodorov, brandon, dcantrell, fnaumann, gnafu_the_great, greg.martyn, jlaska, krh, plastikman, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-10 17:13:49 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 457945    
Attachments:
Description Flags
initrd .img file none

Description Brandon Thomas 2008-11-06 16:26:46 EST
Created attachment 322789 [details]
initrd .img file

Description of problem:
System freezes at boot with the following message:
plymouthd: ply-boot-splash.c:283: ply_boot_splash_root_mounted: Assertion 'splash != ((void *)0)' failed.

Version-Release number of selected component (if applicable):
plymouth: .i386 0.6.0-0.2008.10.30.4.fc10
kernel: .i686 2.6.27.4-79.fc10

How reproducible:
100% of the time

Steps to Reproduce:
1.Update Plymouth to this version via yum
2.reboot
3.pull hair out
  
Actual results:


Expected results:


Additional info:
Before error occurs: pressing ESC will display "Could not detect stabilization, waiting 10 seconds."
Comment 1 Alexander Todorov 2008-11-07 04:53:15 EST
I'm also seeing this on a machine that is attached to serial console:

plymouthd: ply-boot-splash.c:283: ply_boot_splash_root_mounted: Assertion `splash != ((void *)0)' failed.
sd 2:2:0:0: [sda] Asking for cache data failed
sd 2:2:0:0: [sda] Assuming drive cache: write through
sd 2:2:0:0: [sda] Asking for cache data failed
sd 2:2:0:0: [sda] Assuming drive cache: write through
Comment 2 Gideon Mayhak 2008-11-07 21:09:29 EST
I receive the same "Could not detect stabilization, waiting 10 seconds.
" message when booting.  It is before "Welcome to Fedora" and everything else, but after Plymouth starts.  My system boots without any other errors after waiting 10 seconds.  Let me know and I'll gladly post any system logs you might need.  I have all the latest updates installed as of today (including today's Plymouth updates, though I also received the message when first booting with the previous update).
Comment 3 Gideon Mayhak 2008-11-07 21:10:01 EST
And this is on an x86_64 system, by the way.
Comment 4 Zak Peirce 2008-11-10 10:24:52 EST
I have the same issue, this is a fresh install from the FC10 Preview i386 net install media.

below are my system specs.

[root@localhost ~]# lshw -short
H/W path            Device     Class          Description
=========================================================
                               system         To Be Filled By O.E.M.
/0                             bus            K8VSEDX
/0/0                           memory         64KiB BIOS
/0/4                           processor      AMD Athlon(tm) 64 Processor 3200+
/0/4/5                         memory         128KiB L1 cache
/0/4/6                         memory         512KiB L2 cache
/0/3a                          memory         3GiB System Memory
/0/3a/0                        memory         1GiB DIMM DDR Synchronous 266 MHz (3.8 ns)
/0/3a/1                        memory         1GiB DIMM DDR Synchronous 266 MHz (3.8 ns)
/0/3a/2                        memory         1GiB DIMM DDR Synchronous 266 MHz (3.8 ns)
/0/100                         bridge         VT8385 [K8T800 AGP] Host Bridge
/0/100/1                       bridge         VT8237 PCI bridge [K8T800/K8T890 South]
/0/100/1/0                     display        Radeon R350 [Radeon 9800 Pro]
/0/100/1/0.1                   display        Radeon R350 [Radeon 9800 Pro] (Secondary)
/0/100/7                       bus            IEEE 1394 Host Controller
/0/100/9                       multimedia     SB Live! EMU10k1
/0/100/9.1                     input          SB Live! Game Port
/0/100/a            eth0       network        88E8001 Gigabit Ethernet Controller
/0/100/d            scsi0      storage        9xxx-series SATA-RAID
/0/100/d/0.0.0      /dev/sda   disk           499GB SCSI Disk
/0/100/d/0.0.0/1    /dev/sda1  volume         196MiB EXT3 volume
/0/100/d/0.0.0/2    /dev/sda2  volume         4094MiB Linux swap volume
/0/100/d/0.0.0/3    /dev/sda3  volume         461GiB EXT3 volume
/0/100/d/0.1.0      /dev/sdb   disk           999GB SCSI Disk
/0/100/d/0.1.0/1    /dev/sdb1  volume         931GiB EXT3 volume
/0/100/f                       storage        VIA VT6420 SATA RAID Controller
/0/100/f.1          scsi4      storage        VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
/0/100/f.1/0.0.0    /dev/scd0  disk           DVD-ROM DVD-115
/0/100/f.1/0.1.0    /dev/scd1  disk           DX162D-A
/0/100/f.1/0.1.0/0  /dev/scd1  disk           
/0/100/10                      bus            VT82xxxxx UHCI USB 1.1 Controller
/0/100/10.1                    bus            VT82xxxxx UHCI USB 1.1 Controller
/0/100/10.2                    bus            VT82xxxxx UHCI USB 1.1 Controller
/0/100/10.3                    bus            VT82xxxxx UHCI USB 1.1 Controller
/0/100/10.4                    bus            USB 2.0
/0/100/11                      bridge         VT8237 ISA bridge [KT600/K8T800/K8T890 South]
/0/100/11.5                    multimedia     VT8233/A/8235/8237 AC97 Audio Controller
/0/100/11.6                    communication  AC'97 Modem Controller
/0/101                         bridge         K8 [Athlon64/Opteron] HyperTransport Technology Configuration
/0/102                         bridge         K8 [Athlon64/Opteron] Address Map
/0/103                         bridge         K8 [Athlon64/Opteron] DRAM Controller
/0/104                         bridge         K8 [Athlon64/Opteron] Miscellaneous Control
[root@localhost ~]# 

I also receive the plymouthd error.  

plymouthd: ply-boot-splash.c:283: ply_boot_splash_root_mounted: Assertion 'splash != ((void *)0)' failed.

I can only assume that this is an issue with plymouth.  i removed the solar plugin thiking that that might be the issue.

here are the RPM's that i have installed for plymouth

[root@localhost ~]# rpm -qa | grep plymouth
plymouth-libs-0.6.0-0.2008.10.30.4.fc10.i386
plymouth-scripts-0.6.0-0.2008.10.30.4.fc10.i386
plymouth-utils-0.6.0-0.2008.10.30.4.fc10.i386
plymouth-0.6.0-0.2008.10.30.4.fc10.i386
plymouth-gdm-hooks-0.6.0-0.2008.10.30.4.fc10.i386
plymouth-text-and-details-only-0.6.0-0.2008.10.30.4.fc10.i386
[root@localhost ~]#
Comment 5 Greg Martyn 2008-11-10 11:41:11 EST
*** Bug 470670 has been marked as a duplicate of this bug. ***
Comment 6 Ray Strode [halfline] 2008-11-10 15:09:52 EST
i think this issue should be addressed in latest version of plymouth-0.6.0-0.2008.11.10.4.fc10
Comment 7 Zak Peirce 2008-11-10 15:17:28 EST
Thanks Ray,

any idea when that will show up on the mirrors?
Comment 8 Ray Strode [halfline] 2008-11-10 15:27:21 EST
*** Bug 470856 has been marked as a duplicate of this bug. ***
Comment 9 Ray Strode [halfline] 2008-11-10 16:17:15 EST
I put a tag request in for rel-eng today, so i expect tomorrow.
Comment 10 Jesse Keating 2008-11-10 17:13:49 EST
It was tagged, closing.
Comment 11 Gideon Mayhak 2008-11-13 00:10:53 EST
I currently have 0.6.0-0.2008.11.10.5.fc10 installed and I still receive the stabilization error.
Comment 12 Greg Martyn 2008-11-13 01:24:17 EST
After installing plymouth-0.6.0-0.2008.11.10.5.fc10.x86_64.rpm, my system no longer experiences the "plymouthd: ply-boot-splash.c:283: ply_boot_splash_root_mounted: Assertion 'splash != ((void *)0)' failed" assertion failure.
Comment 13 Ray Strode [halfline] 2008-11-13 09:49:15 EST
Gideon, you have to rebuild your initrd or install a new kernel after updating plymouth for the new plymouth to get used.

You can rebuild your initrd with /usr/libexec/plymouth/plymouth-update-initrd
Comment 14 Gideon Mayhak 2008-11-13 23:34:22 EST
Is there a particular reason that wasn't done with the latest update?  I'm also running the latest kernel.  Anyway, thanks!
Comment 15 Gideon Mayhak 2008-11-13 23:38:47 EST
Actually, I ran that command, rebooted, and I still receive the stabilization error.  Thoughts?
Comment 16 Gideon Mayhak 2008-11-14 21:38:23 EST
I updated to the latest plymouth and kernel packages today, reran that initrd command, and I still get the stabilization message and a 10-second pause.  What information do you need so we can get this resolved?

[root@gidux-laptop-rawhide ~]# lspci
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation MCP51 PCI-X GeForce Go 6100 (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
03:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 02)

[root@gidux-laptop-rawhide ~]# yum list installed | grep -E "kernel|plymouth"
kernel.x86_64                               2.6.27.5-94.fc10           installed
kernel.x86_64                               2.6.27.5-101.fc10          installed
kernel.x86_64                               2.6.27.5-109.fc10          installed
kernel-devel.x86_64                         2.6.27.5-94.fc10           installed
kernel-devel.x86_64                         2.6.27.5-101.fc10          installed
kernel-devel.x86_64                         2.6.27.5-109.fc10          installed
kernel-doc.noarch                           2.6.27.5-109.fc10          installed
kernel-firmware.noarch                      2.6.27.5-109.fc10          installed
kernel-headers.x86_64                       2.6.27.5-109.fc10          installed
kerneloops.x86_64                           0.12-1.fc10                installed
plymouth.x86_64                             0.6.0-0.2008.11.12.4.fc10  installed
plymouth-gdm-hooks.x86_64                   0.6.0-0.2008.11.12.4.fc10  installed
plymouth-libs.x86_64                        0.6.0-0.2008.11.12.4.fc10  installed
plymouth-plugin-label.x86_64                0.6.0-0.2008.11.12.4.fc10  installed
plymouth-plugin-solar.x86_64                0.6.0-0.2008.11.12.4.fc10  installed
plymouth-scripts.x86_64                     0.6.0-0.2008.11.12.4.fc10  installed
plymouth-utils.x86_64                       0.6.0-0.2008.11.12.4.fc10  installed
Comment 17 Jesse Keating 2008-11-15 11:38:14 EST
the stabilization is likely related to the "scsi" disks (all disks are now basically scsi to the kernel) and not related to plymouth.  The problem reported in this bug has been taken care of, please stop the traffic here.  If you have a different bug, please file it anew.  The stabilization thing isn't necessarily a bug, as it doesn't prevent the system from working, it just delays the bootup for a short period.