This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 491838

Summary: imsettings-applet crash
Product: [Fedora] Fedora Reporter: Clayton Bonser <clay>
Component: imsettingsAssignee: Akira TAGOH <tagoh>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 10CC: bugzilla, i18n-bugs, orcalon, phj556, redhat, schifest, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 0.105.1-4.fc10 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-27 10:53:58 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
bug report auto-generated
none
imsettings-applet bug report
none
imsettings-applet crashes at Netbeans 6.1 startup
none
Auto generated bug report
none
Bugbuddy backtrace of /usr/bin/imsettings-applet. none

Description Clayton Bonser 2009-03-24 07:40:11 EDT
Created attachment 336448 [details]
bug report auto-generated

Description of problem:
imsettings-applet crashes when trying to run an .exe file in wine

Version-Release number of selected component (if applicable):
0.5.105

How reproducible:
Crashes on every attempt. After a crash, there is no response until the system is rebooted. i.e. after opening the C.D. directory in conquerer, right clicking and selecting "open in wine" nothing happens until after a reboot

Steps to Reproduce:
1. Open C.D. directory in conquerer (Autocad R14 lite), 
2.right click over autostart.exe icon
3.choose "open in wine"
  
Actual results:
A bug report message appears saying that imsettings-applet has crashed and a report can be saved for submission.

Expected results:
install window opening in wine console.

Additional info: Welcome to request further information, although I am not all that able in this area.
Comment 1 pete johnson 2009-03-24 12:55:01 EDT
Created attachment 336497 [details]
imsettings-applet bug report
Comment 2 pete johnson 2009-03-24 17:54:39 EDT
Long story short: this morning when I started the machine, as soon as gnome
had initialized itself, imsettings-applet crashed.  I attached a copy of the
bug report created by that crash as id=336497 to this bug (see above).  I
tried a few fixes, read some other bug reports and found bug 488675 mentions
that newer imsettings RPMs are available.

I installed those newer imsettings RPMs, following directions in bug 488675,
rebooted, and the bugs exhibited earlier today (mouse clicks and key presses
ignored; when emacs was the current window, alt-tab took aprox. 30 seconds to
give focus to the next window; starting emacs crashed imsettings-applet) have
magically disappeared.  Thanks Akira.
Comment 3 Akira TAGOH 2009-03-24 20:53:28 EDT
I'm not sure which bugs you faced so that the report generated from bug-buddy doesn't contain any backtraces. to clarify, install the debuginfo package and try it again with the old imsettings package you saw this issue. you'll get the backtrace from gdb then..
Comment 4 Clayton Bonser 2009-03-24 22:10:21 EDT
My appologies. The Version Release Number should be:

0.105.1

Dyscalcula strikes again.
Comment 5 Akira TAGOH 2009-03-24 22:18:05 EDT
(In reply to comment #3)
> I'm not sure which bugs you faced so that the report generated from bug-buddy
> doesn't contain any backtraces. to clarify, install the debuginfo package and
> try it again with the old imsettings package you saw this issue. you'll get the
> backtrace from gdb then..  

To be clear, newer package in testing repo now has some fixes though, I'm not 100% sure if one of them is same to what you saw. so I need a backtrace to make sure.
Comment 6 Esteban Schifman 2009-03-25 10:47:41 EDT
Created attachment 336653 [details]
imsettings-applet crashes at Netbeans 6.1 startup

We had never had a problem with netbeans (6.1-10.fc10).
After yesterdays software update, it just stopped working.
The symptom is that the window that shows up in at netbeans start time freezes, and a bug window pops up reporting the imsettings-applet crash.
(bug report generated by it has been attached)

Some problem in that latest update may be ?
Comment 7 Robert Kochis 2009-03-25 11:30:32 EDT
I had the identical problem with Sun Virtualbox.  I loaded the 'testing' updates as noted in bug 488675:
imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 testing repository. 
If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update imsettings'.

This solved my problem with vbox crashing upon startup.  Errors in imsettings-applet-bugreport.txt were IDENTICAL to errors noted at beginning of this page.
Comment 8 Esteban Schifman 2009-03-25 11:55:59 EDT
Thanks Robert.  Your suggestion did the trick.
Tried starting up Sun Virtualbox, and it also works...

Your help is greately appreciated.   IOU  :)
Comment 9 Dale Stimson 2009-03-25 15:33:01 EDT
I believe I had the same problem, which manifested itself (besides the sometimes(?) imsettings crash) as some X programs (e.g, xterm) launched from a terminal window hanging with no window displayed.  The hang went away if environment variable XMODIFIERS was unset before the attempted launch.

I confirm that the updated imsettings-0.105.1-4.fc10 from updates-testing resolved my problem also.
Comment 10 Q 2009-03-25 17:05:51 EDT
Created attachment 336704 [details]
Auto generated bug report

Occurs when opening TeXmaker, but after I open Kile once TeXmaker works fine but the file browser that shows up it KDE instead of Gnome.
Comment 11 Akira TAGOH 2009-03-25 22:00:53 EDT
(In reply to comment #7)
> I had the identical problem with Sun Virtualbox.  I loaded the 'testing'
> updates as noted in bug 488675:
> imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 testing repository. 
> If problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update imsettings'.
> 
> This solved my problem with vbox crashing upon startup.  Errors in
> imsettings-applet-bugreport.txt were IDENTICAL to errors noted at beginning of
> this page.  

Not exactly. no one didn't report any crashes there.
I just want to make sure what's the trigger of this crash and which fixes resolves this with the package in testing repo. it might just disappears or you don't face it again so far.

Can anyone give me a backtrace please? since this doesn't always happens, I can't give you somewhat peace without it.

(In reply to comment #9)
> I believe I had the same problem, which manifested itself (besides the
> sometimes(?) imsettings crash) as some X programs (e.g, xterm) launched from a
> terminal window hanging with no window displayed.  The hang went away if
> environment variable XMODIFIERS was unset before the attempted launch.

Well, someone has already filed a freeze issue at Bug #488976 and fixed in the package at the testing repo as you also confirmed.
Comment 12 Clayton Bonser 2009-03-26 02:03:59 EDT
(In reply to comment #7)
> I had the identical problem with Sun Virtualbox.  I loaded the 'testing'
> updates as noted in bug 488675:
> imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 testing repository. 
> If problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update imsettings'.
> 
> This solved my problem with vbox crashing upon startup.  Errors in
> imsettings-applet-bugreport.txt were IDENTICAL to errors noted at beginning of
> this page.  

OK, did the update using the updates-testing as suggested in comment #7. This appears to have made the imsettings crash go away, but I still can't install a windoze program in wine.
I mention this because no error message is generated, and I can't say that the problem is not imsettings related.
I would welcome someone contacting me with advice on how to make that determination.
Comment 13 Michael Burford 2009-03-26 07:05:15 EDT
Regarding comment #2...

I had the same problem - imsettings-applet crashed on Gnome startup. Bug-Buddy claims it knows nothing about the application so it cannot send a bug report or trace. This problem began at the beginning of this week.

The crashes caused me no other problems. I do not run wine or emacs, so I cannot make any remarks on those related comments.

But, while investigating another startup issue with Skype, I checked the "sessions preferences" and found that the "IMSettings Applet" startup entry was duplicated. Also, the "Automatically remember running applcations on logout" tickbox was selected and active. This setting may have caused the duplicated entry(?)

I deleted the duplicated entry, unticked the "Automatically remember running applcations on logout" tickbox and then rebooted.

The imsettings-applet crash has not occurred again since, so I've not investigated any further.
Comment 14 Clayton Bonser 2009-03-26 07:41:13 EDT
(In reply to comment #12)
> (In reply to comment #7)
> > I had the identical problem with Sun Virtualbox.  I loaded the 'testing'
> > updates as noted in bug 488675:
> > imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 testing repository. 
> > If problems still persist, please make note of it in this bug report.
> >  If you want to test the update, you can install it with 
> >  su -c 'yum --enablerepo=updates-testing update imsettings'.
> > 
> > This solved my problem with vbox crashing upon startup.  Errors in
> > imsettings-applet-bugreport.txt were IDENTICAL to errors noted at beginning of
> > this page.  
> 
> OK, did the update using the updates-testing as suggested in comment #7. This
> appears to have made the imsettings crash go away, but I still can't install a
> windoze program in wine.
> I mention this because no error message is generated, and I can't say that the
> problem is not imsettings related.
> I would welcome someone contacting me with advice on how to make that
> determination.  

I found that setting wine to emulate Win98 instead of XP allowed autocad to be loaded successfully. Seems that everything is OK now. 
Thanks all for the advice.
Comment 15 Luke Suchocki 2009-03-26 10:53:53 EDT
Yesterday I was encountering the crashing imsettings-applet while starting xterm.

Last night after rebooting my machine, I could not start xterm or xmms from gnome.
The process would sit there indefinitely on a select() on the /tmp/.X11-unix/X0 socket.

Other applications started fine (firefox/vncviewer)

I was able to run a "xhosts +" and start xterm it from a console shell, but not from the alt-f2 or applications->system tools->xterm

After performing the update from the updates-testing today, these issues appeared to have gone away.
Comment 16 pete johnson 2009-03-26 15:43:20 EDT
Currently installed:                                                            

im-chooser-debuginfo-1.2.5-1.fc10.i386
imlib2-1.4.2-2.fc10.i386
imsettings-debuginfo-0.105.1-2.fc10.i386
imsettings-libs-0.105.1-2.fc10.i386
scim-debuginfo-1.4.7-35.fc10.i386
scim-libs-1.4.7-35.fc10.i386

but when the machine starts, imsettings-applet doesn't crash now.
imsettings-applet doesn't crash after starting emacs.  When I press
alt-tab when emacs has focus, however, about 30 seconds elapse before the next
window takes focus.  Any suggestions?
Comment 17 pete johnson 2009-03-26 15:45:26 EDT
Should have prefaced my previous comment with: Trying to create a backtrace that Akira will fine useful.
Comment 18 pete johnson 2009-03-26 16:44:23 EDT
Created attachment 336892 [details]
Bugbuddy backtrace of /usr/bin/imsettings-applet.
Comment 19 pete johnson 2009-03-26 16:47:59 EDT
Yet another part of this continuing conversation...

Now have imsettings-debuginfo-0.105.1-2.fc10.i386.rpm installed.  Rebooted;
imsettings-applet did not crash.  Started "Service Configuration";
imsettings-applet did not crash.  Started emacs; imsettings-applet crashed and
bugbuddy saved a report and no emacs window appeared, although an emacs
process started.  Started emacs again and an emacs window did appear.
Attached the bugbuddy report above (id=336892), which does include backtrace
info.

Let me know if you need more info.
Comment 20 Akira TAGOH 2009-03-26 21:12:24 EDT
(In reply to comment #19)
> Yet another part of this continuing conversation...
> 
> Now have imsettings-debuginfo-0.105.1-2.fc10.i386.rpm installed.  Rebooted;
> imsettings-applet did not crash.  Started "Service Configuration";
> imsettings-applet did not crash.  Started emacs; imsettings-applet crashed and
> bugbuddy saved a report and no emacs window appeared, although an emacs
> process started.  Started emacs again and an emacs window did appear.
> Attached the bugbuddy report above (id=336892), which does include backtrace
> info.
> 
> Let me know if you need more info.  

Great. Thank you for taking your time to gather a backtrace. fair enough. that surely has been fixed in the update.
Comment 21 Fedora Update System 2009-03-27 10:53:25 EDT
imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Akira TAGOH 2009-03-29 21:43:30 EDT
*** Bug 492679 has been marked as a duplicate of this bug. ***