Bug 492491

Summary: Booting with nouveau.modeset=1 hangs after boot screen
Product: [Fedora] Fedora Reporter: James Evans <milamber>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: airlied, ajax, awilliam, bskeggs
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-10 19:10:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description James Evans 2009-03-26 19:21:13 EDT
Description of problem:

Kernel mode setting using the Nouveau Test Day Live CD causes hang when switching to gdm. Plymouth runs, then the screen goes blank and no input works.

Version-Release number of selected component (if applicable):

2.6.29-0.279.rc8.git6.fc11.x86_64
xorg-x11-drv-nouveau-0.0.12-15.20090323git4067ab4.fc11.x86_64

How reproducible:

everytime

Steps to Reproduce:
1. Add nouveau.modeset=1 to kernel command line
2.
3.
  
Actual results:

Computer hangs between Plymouth and GDM

Expected results:

GDM screen appears

Additional info:

Bug looks like https://bugzilla.redhat.com/show_bug.cgi?id=492461 but my screen is completely black rather than showing junk
Comment 1 Ben Skeggs 2009-03-27 04:09:16 EDT
Do you have any way of collecting /var/log/messages and /var/log/Xorg.0.log from after the hang?  They'd be very useful if you can get them.

Also, what's the exact chipset you're using, and the monitors do you have plugged in (VGA, DVI etc)?
Comment 2 Adam Williamson 2009-03-27 17:26:58 EDT
From the Test Day page, he's using: GeForce 9500 GT (rev a1)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 James Evans 2009-03-27 19:10:42 EDT
I was using the LiveCD and nothing was responding after the hang. I'll install rawhide to a spare partition and boot that to get the log files. 

As Adam pointed out I'm using a GeFOrce 9500 GT. Do you need more information about it?

I'm using one DVI port with a 22" LCD.
Comment 4 James Evans 2009-03-28 00:09:44 EDT
I was using the LiveCD and nothing was responding after the hang. I'll install rawhide to a spare partition and boot that to get the log files. 

As Adam pointed out I'm using a GeFOrce 9500 GT. Do you need more information about it?

I'm using one DVI port with a 22" LCD.
Comment 5 Ben Skeggs 2009-04-01 19:41:08 EDT
Thank you.  I'll mark as needinfo for the moment then :)
Comment 6 Ben Skeggs 2009-04-09 01:18:00 EDT
Any update here?  There's been quite a few fixes since the test day, it'd be useful to know if you still see this issues.  If so, logs would be great!
Comment 7 James Evans 2009-04-09 08:01:26 EDT
I've been having trouble getting the alpha or beta installed to my system. I'm hoping to be able to sit down this weekend and get that working so I can provide the logs.

Sorry for the delay
Comment 8 Adam Williamson 2009-04-09 13:36:52 EDT
Please don't remove the needinfo flag until you're actually providing the requested information - thanks :) We need the state to be accurate for tracking.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 James Evans 2009-04-10 13:01:14 EDT
I've installed the beta and updated with the latest packages. Everything works fine now, it boots to GDM with nouveau.modeset=1 and no visual artefacts. I'd say the bug can be closed.

Thanks!

james
Comment 10 Ben Skeggs 2009-04-10 19:10:44 EDT
Excellent!  Thank you :)