Bug 492491 - Booting with nouveau.modeset=1 hangs after boot screen
Summary: Booting with nouveau.modeset=1 hangs after boot screen
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-26 23:21 UTC by James Evans
Modified: 2009-04-10 23:10 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-04-10 23:10:44 UTC


Attachments (Terms of Use)

Description James Evans 2009-03-26 23:21:13 UTC
Description of problem:

Kernel mode setting using the Nouveau Test Day Live CD causes hang when switching to gdm. Plymouth runs, then the screen goes blank and no input works.

Version-Release number of selected component (if applicable):

2.6.29-0.279.rc8.git6.fc11.x86_64
xorg-x11-drv-nouveau-0.0.12-15.20090323git4067ab4.fc11.x86_64

How reproducible:

everytime

Steps to Reproduce:
1. Add nouveau.modeset=1 to kernel command line
2.
3.
  
Actual results:

Computer hangs between Plymouth and GDM

Expected results:

GDM screen appears

Additional info:

Bug looks like https://bugzilla.redhat.com/show_bug.cgi?id=492461 but my screen is completely black rather than showing junk

Comment 1 Ben Skeggs 2009-03-27 08:09:16 UTC
Do you have any way of collecting /var/log/messages and /var/log/Xorg.0.log from after the hang?  They'd be very useful if you can get them.

Also, what's the exact chipset you're using, and the monitors do you have plugged in (VGA, DVI etc)?

Comment 2 Adam Williamson 2009-03-27 21:26:58 UTC
From the Test Day page, he's using: GeForce 9500 GT (rev a1)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 James Evans 2009-03-27 23:10:42 UTC
I was using the LiveCD and nothing was responding after the hang. I'll install rawhide to a spare partition and boot that to get the log files. 

As Adam pointed out I'm using a GeFOrce 9500 GT. Do you need more information about it?

I'm using one DVI port with a 22" LCD.

Comment 4 James Evans 2009-03-28 04:09:44 UTC
I was using the LiveCD and nothing was responding after the hang. I'll install rawhide to a spare partition and boot that to get the log files. 

As Adam pointed out I'm using a GeFOrce 9500 GT. Do you need more information about it?

I'm using one DVI port with a 22" LCD.

Comment 5 Ben Skeggs 2009-04-01 23:41:08 UTC
Thank you.  I'll mark as needinfo for the moment then :)

Comment 6 Ben Skeggs 2009-04-09 05:18:00 UTC
Any update here?  There's been quite a few fixes since the test day, it'd be useful to know if you still see this issues.  If so, logs would be great!

Comment 7 James Evans 2009-04-09 12:01:26 UTC
I've been having trouble getting the alpha or beta installed to my system. I'm hoping to be able to sit down this weekend and get that working so I can provide the logs.

Sorry for the delay

Comment 8 Adam Williamson 2009-04-09 17:36:52 UTC
Please don't remove the needinfo flag until you're actually providing the requested information - thanks :) We need the state to be accurate for tracking.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 9 James Evans 2009-04-10 17:01:14 UTC
I've installed the beta and updated with the latest packages. Everything works fine now, it boots to GDM with nouveau.modeset=1 and no visual artefacts. I'd say the bug can be closed.

Thanks!

james

Comment 10 Ben Skeggs 2009-04-10 23:10:44 UTC
Excellent!  Thank you :)


Note You need to log in before you can comment on or make changes to this bug.