Bug 497745

Summary: fails to install boot loader on ppc
Product: [Fedora] Fedora Reporter: Dave Jones <davej>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: anaconda-maint-list, dcantrell, nman64, pfrields, pjones, rmaximo, tgl, vanmeeuwen+fedora, wwoods
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard: NEEDSRETESTING
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-05-21 16:41:34 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 495965    
Attachments:
Description Flags
anaconda log none

Description Dave Jones 2009-04-26 15:52:00 EDT
on an old imac g3, I managed to get all the way through the install successfully, but when it rebooted, it cycles between displaying a picture of a folder with a question mark in it, then a picture of the smiling mac icon.

not installing the bootloader correctly perhaps?
I don't know enough about the ppc boot process to diagnose further.
Comment 1 Dave Jones 2009-04-26 16:14:19 EDT
maybe related?

I booted the installer again, and took a look at the partition table with fdisk.
It looks like this..

hda1 start=1 end=1
hda2 start=1 end=26
hda3 start=26 end=9729

aren't those start's off by one?

It also prints "partition does not end on a cylinder boundary" which may mean something?
Comment 2 Chris Lumens 2009-05-08 10:44:08 EDT
Is this still a problem?  I did a test with the latest build and it boots up fine.  Unfortunately, I didn't test before fixing the partition map bug in anaconda so I don't know that I was ever able to reproduce it.  Still, it's worth you giving it another try.  You'll need a tree with anaconda .51 in it.
Comment 3 Tom Lane 2009-05-08 18:01:23 EDT
FWIW, it seems to work okay for me with today's rawhide (anaconda 11.5.0.51).  I had previously seen a crash while trying to install the bootloader on this same machine; it looked to me like this might be another manifestation of the partition map confusion.
Comment 4 Chris Lumens 2009-05-11 10:08:41 EDT
Thanks for confirming.
Comment 5 Dave Jones 2009-05-13 11:14:05 EDT
Still a problem for me. Logs to follow.
Comment 6 Dave Jones 2009-05-13 11:15:28 EDT
Created attachment 343788 [details]
anaconda log
Comment 7 Chris Lumens 2009-05-14 13:33:49 EDT
This is a consequence of bug 499724.  I bet if you look in /mnt/sysimage/dev, you'll see that there's not really anything there - certainly nothing of help when writing out bootloaders.  So, this should be fixed in anaconda-11.5.0.52-1.
Comment 8 Chris Lumens 2009-05-14 13:56:58 EDT
That should be bug 499742, sorry.
Comment 9 Dave Jones 2009-05-18 20:24:02 EDT
still no joy. symptoms exactly the same.
Comment 10 Patrick Barnes 2009-05-20 06:16:14 EDT
What color is the G3?  Might this be #162046 still causing problems?
Comment 11 Patrick Barnes 2009-05-20 06:32:50 EDT
To elaborate, I know that bug 162046 was still a problem in Fedora 10, and the fix described in that bug did get the system booting after the install.  I have not had the opportunity to test F11.

At bootup, hit Cmd-Opt-O-F (Mac keyboard) to boot OpenFirmware.  Once you reach the OpenFirmware prompt, enter the following:

 boot hd:2,\\yaboot

If that successfully boots the system, then (1) this is the same issue and (2) you can run the following as root to get a semi-permanent fix (until you update the kernel):

 ybin -o hd:2

I do not have a fix for the bug, but hopefully this workaround is enough to point somebody in the right direction.
Comment 12 Chris Lumens 2009-05-21 14:04:30 EDT
As we discovered, the problem here is that the disk contains an msdos disklabel due to being initialized with fdisk, which the imac firmware is unable to boot from.  I'll handle this report as anaconda should be checking things like this and erroring out on them, rather than silently continuing leaving you to wonder what happened.
Comment 13 Chris Lumens 2009-05-21 16:41:34 EDT
Pushed a fix to HEAD.  This will be in rawhide, but not F11.