This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 499724 - incompatibility between compat-gcc-34 and compat-libstdc++-33
incompatibility between compat-gcc-34 and compat-libstdc++-33
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compat-gcc-34 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 15:32 EDT by kakashizilla
Modified: 2009-05-13 09:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 10:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kakashizilla 2009-05-07 15:32:37 EDT
Description of problem:
When compiling a program using gcc34, errors of this kind appear at the end :
  /usr/lib64/libtag.so: undefined reference to `std::basic_ostream<char,
  std::char_traits<char>>& std::__ostream_insert<char, std::char_traits<char> 
  >(std::basic_ostream<char, std::char_traits<char> >&, char const*, 
  long)@GLIBCXX_3.4.9'
It seems to be an incompatibility between the compilator given by 
"compat-gcc-34" and the libraries given by "compat-libstdc++-33"


Version-Release number of selected component (if applicable):


How reproducible:
Try to compile and link a program with gcc34

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2009-05-11 09:52:33 EDT
*** Bug 500032 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2009-05-11 10:04:56 EDT
gcc34 doesn't ever use compat-libstdc++-33, that makes no sense at all.
From the above I'm just guessing you are linking against C++ libraries that were compiled/linked with g++ rather than g++34, in that case obviously the link phase has to be done using g++ rather than g++34, because you can't limit to the subset of libstdc++ exported functions that were provided by 3.4.x.
Comment 3 Chris Lumens 2009-05-13 09:17:19 EDT
*** Bug 500427 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.