Bug 499742 - 'Update existing bootloader' option disabled when upgrading from F-10
'Update existing bootloader' option disabled when upgrading from F-10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 500032 500427 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 16:51 EDT by James Laska
Modified: 2013-09-02 02:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 12:58:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
upgrade - step#1.png (43.25 KB, image/png)
2009-05-07 16:51 EDT, James Laska
no flags Details
upgrade - step#2.png (44.79 KB, image/png)
2009-05-07 16:52 EDT, James Laska
no flags Details
anaconda-logs.tgz (anaconda.log, syslog, vncserver.log, program.log etc...) (17.17 KB, application/octet-stream)
2009-05-07 16:52 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-05-07 16:51:36 EDT
Created attachment 342937 [details]
upgrade - step#1.png

Description of problem:

Install Fedora 10 using autopart partitioning.  Attempt an upgrade with Fedora 11 (anaconda-11.5.0.50).  Anaconda sees that F-10 is installed and offers the option to upgrade (see screenshot#1), but the option to upgrade the existing bootloader config is disabled (see screenshot#2).

Version-Release number of selected component (if applicable):

 * anaconda-11.5.0.50

How reproducible:
 * 4 out of 4 attempts with x86_65 and i386 KVM guests

Steps to Reproduce:
1. Install F-10 (autopart)
2. Boot F-11 installer
3. Select upgrade of existing F-10 system
  
Actual results:

See screenshot#2 - upgrade existing bootloader option not present

Expected results:

Option#1 not disabled.

Additional info:

 * see attached anaconda-logs.tgz
Comment 1 James Laska 2009-05-07 16:52:16 EDT
Created attachment 342938 [details]
upgrade - step#2.png
Comment 2 James Laska 2009-05-07 16:52:42 EDT
Created attachment 342939 [details]
anaconda-logs.tgz (anaconda.log, syslog, vncserver.log, program.log etc...)
Comment 3 Chris Lumens 2009-05-08 15:13:28 EDT
This should be fixed in the next build of anaconda.
Comment 4 Chris Lumens 2009-05-11 10:04:29 EDT
*** Bug 500032 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2009-05-13 10:03:58 EDT
*** Bug 500427 has been marked as a duplicate of this bug. ***
Comment 6 James Laska 2009-05-15 12:58:46 EDT
Confirmed fix in anaconda-11.5.0.52.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.