Bug 499968

Summary: port PackageKit-qt to PolicyKit 1.0
Product: [Fedora] Fedora Reporter: Matthias Clasen <mclasen>
Component: PackageKitAssignee: Steven M. Parrish <smparrish>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: balajig81, jreznik, kevin, lists.kho, lmacken, ltinkl, rdieter, rhughes, richard, smparrish
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-25 10:59:27 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 473303, 509136    

Description Matthias Clasen 2009-05-09 12:53:43 EDT
We are going to land polkit 1.0 in F12 soon. This is going to require changes
to polkit using applications. Thankfully, mostly simplifications.

See http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 Kevin Kofler 2009-05-14 18:35:16 EDT
Is there any actual PolicyKit-using code in kpackagekit 0.4.x at all? AFAICT it's all handled within PackageKit (or maybe PackageKit-qt) now, a case-insensitive search for "policykit" turns up nothing, neither does "polkit".
Comment 2 Steven M. Parrish 2009-05-29 21:04:21 EDT
From the upstream devs,  via IRC

well kpackagekit does not (yet) use polkit, but packagekit-qt does, and it does the old way (ie not using polkit-qt)
we were planning to make packagekit-qt use it, but as pk1.0 is comming i decided to worry about the polkit-qt por
Comment 3 Bug Zapper 2009-06-09 11:32:53 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matthias Clasen 2009-07-08 17:43:18 EDT
Any update on this ?
Comment 5 Kevin Kofler 2009-07-08 18:19:27 EDT
So the news is that KPackageKit itself doesn't contain any PolicyKit-using code at all. That said, PackageKit-qt does. Upstream is working on porting that.
Comment 6 Kevin Kofler 2009-07-08 18:24:21 EDT
The current PackageKit-qt code can be viewed here:
http://cgit.freedesktop.org/packagekit/tree/lib/packagekit-qt/src

As you can see, PolicyKit support is commented out. :-(
Comment 7 Richard Hughes 2009-07-09 15:35:10 EDT
(In reply to comment #6)
> As you can see, PolicyKit support is commented out. :-(  

Right, all the PolicyKit stuff is now done in the daemon, so the proper fix would be to just remove this commented out code IMO.
Comment 8 Kevin Kofler 2009-07-09 17:34:36 EDT
So PackageKit-qt doesn't need any PolicyKit code anymore? Should we just close this as NOTABUG then?
Comment 9 Matthias Clasen 2009-07-09 20:47:49 EDT
You want to make sure that you make your mechanism calls async, since they may block in PolicyKit while an auth dialog is shown. But maybe you already do everything async, anyway ?
Comment 10 Richard Hughes 2009-07-10 03:14:22 EDT
(In reply to comment #9)
> You want to make sure that you make your mechanism calls async, since they may
> block in PolicyKit while an auth dialog is shown. But maybe you already do
> everything async, anyway ?  

This is my concern too.
Comment 11 Steven M. Parrish 2009-07-20 21:01:32 EDT
I'll ping upstream and see where we stand on this.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Kevin Kofler 2009-07-21 08:20:53 EDT
> Right, all the PolicyKit stuff is now done in the daemon, so the proper fix
> would be to just remove this commented out code IMO.

Unfortunately, it doesn't seem to be that simple, see Bug 512925.
Comment 13 Matthias Clasen 2009-08-06 11:15:30 EDT
What is the status of this ? My 

repoquery -q --whatrequires "libpolkit.so.2()(64bit)"

Doesn't list any PackageKit packages anymore, so it seems we are good ? 
Does PackageKit-qt actually work with polkit, or are there still issues that we need to sort out ?
Comment 14 Richard Hughes 2009-08-10 07:02:24 EDT
Well, there's no KDE version of an authentication agent for polkit1 (yet)... so any kde applications using PolicyKit1 will not work unless the gnome authenitcation agent is running in the session. The PackageKit-qt bindings do not need to check anything with PolicyKit anymore (all done in the engine with PolicyKit1) and so should be good to go.
Comment 15 Martin Kho 2009-08-12 08:02:30 EDT
Running the gnome authentication agent is not enough to authenticate in
kpackagekit in KDE 4.3.0 (rawhide), see bug[1]. So it seems KDE needs it's own autentication agent in this case?


Martin

Bug 1: https://bugzilla.redhat.com/show_bug.cgi?id=509136
Comment 16 Jaroslav Reznik 2009-08-18 07:24:48 EDT
Yes, Gnome Authentication Agent is not enough for KPackageKit. The question is why it's not enough, why it's not called as from comments above all PK related code is in PackageKit.
Comment 17 Kevin Kofler 2009-08-25 10:59:27 EDT
This should be fixed by the current PackageKit and kpackagekit builds in Rawhide.