Bug 528347

Summary: Publican fails to build
Product: [Community] Publican Reporter: Jeroen van Meeuwen <vanmeeuwen+fedora>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 1.6CC: jfearn, mmcallis, nb, publican-list, r.landmann
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-03 19:35:32 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 521569, 521723, 521724, 531969, 532258, 532259, 532278    
Bug Blocks:    
Attachments:
Description Flags
Mock log none

Description Jeroen van Meeuwen 2009-10-11 09:35:50 EDT
Description of problem:

Publican fails to build from SVN.

Version-Release number of selected component (if applicable):

Publican-0.99-0.BETA1.fc12.t86

How reproducible:

Every time

Steps to Reproduce:
1. svn co the publican trunk
2. install all build requirements listed in publican.spec
3. perl ./Build.PL

Output:

$ perl ./Build.PL 
Deleting _build
Creating custom builder _build/lib/My/Builder.pm in _build/lib/My
Can't locate Makefile/Parser.pm in @INC (@INC contains: lib /home/jmeeuwen/devel/src/publican/publican/_build/lib /usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl .) at lib/Publican.pm line 14, <DATA> line 1662.
BEGIN failed--compilation aborted at lib/Publican.pm line 14, <DATA> line 1662.
Compilation failed in require at /home/jmeeuwen/devel/src/publican/publican/_build/lib/My/Builder.pm line 58, <DATA> line 1662.
BEGIN failed--compilation aborted at /home/jmeeuwen/devel/src/publican/publican/_build/lib/My/Builder.pm line 58, <DATA> line 1662.
Compilation failed in require at (eval 21) line 2, <DATA> line 1662.
BEGIN failed--compilation aborted at (eval 21) line 2, <DATA> line 1662.

4. Outcomment line #14 in publican/lib/Publican.pm
5. perl ./Build.PL

Output:

$ perl ./Build.PL 
Deleting _build
Creating custom builder _build/lib/My/Builder.pm in _build/lib/My
Checking whether your kit is complete...
Looks good

Checking prerequisites...
 - ERROR: Makefile::Parser is not installed
 - ERROR: Makefile::Parser is not installed

ERRORS/WARNINGS FOUND IN PREREQUISITES.  You may wish to install the versions
of the modules indicated above before proceeding with this installation

Deleting Build
Removed previous script 'Build'

Creating new 'Build' script for 'Publican' version '0.99'

6. ./Build rpm

Output:

$ ./Build rpm
Deleting tmp
Deleting Publican-0.99.tar.gz
Deleting META.yml
Creating META.yml
Creating Publican-0.99
Creating Publican-0.99.tar.gz
tar cf Publican-0.99.tar Publican-0.99
gzip Publican-0.99.tar
Deleting Publican-0.99
mkdir -p /home/jmeeuwen/devel/src/publican/publican/tmp/rpm
cp Publican*.tar.gz /home/jmeeuwen/devel/src/publican/publican/tmp/rpm/.
rpmbuild --define _sourcedir /home/jmeeuwen/devel/src/publican/publican/tmp/rpm --define _builddir /home/jmeeuwen/devel/src/publican/publican/tmp/rpm --define _srcrpmdir /home/jmeeuwen/devel/src/publican/publican/tmp/rpm --define _rpmdir /home/jmeeuwen/devel/src/publican/publican/tmp/rpm -bs --nodeps publican.spec
Wrote: /home/jmeeuwen/devel/src/publican/publican/tmp/rpm/Publican-0.99-0.BETA1.fc12.t86.src.rpm
rpmbuild --define _sourcedir /home/jmeeuwen/devel/src/publican/publican/tmp/rpm --define _builddir /home/jmeeuwen/devel/src/publican/publican/tmp/rpm --define _srcrpmdir /home/jmeeuwen/devel/src/publican/publican/tmp/rpm --define _rpmdir /home/jmeeuwen/devel/src/publican/publican/tmp/rpm --rebuild /home/jmeeuwen/devel/src/publican/publican/tmp/rpm/Publican-0.99-0.BETA1.fc12.t86.src.rpm
Installing /home/jmeeuwen/devel/src/publican/publican/tmp/rpm/Publican-0.99-0.BETA1.fc12.t86.src.rpm
error: Failed build dependencies:
	perl(Makefile::Parser) is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-bengali is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-gujarati is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-hindi is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-kannada is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-malayalam is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-oriya is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-punjabi is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-tamil is needed by Publican-0.99-0.BETA1.fc12.t86.src
	lohit-fonts-telugu is needed by Publican-0.99-0.BETA1.fc12.t86.src

7. yum --enablerepo=fedora-11-development -y install lohit-fonts-bengali lohit-fonts-gujarati lohit-fonts-hindi lohit-fonts-kannada lohit-fonts-malayalam lohit-fonts-oriya lohit-fonts-punjabi lohit-fonts-tamil lohit-fonts-telugu "perl(Makefile::Parser)"

Output:

$ yum --enablerepo=fedora-11-development -y install lohit-fonts-bengali lohit-fonts-gujarati lohit-fonts-hindi lohit-fonts-kannada lohit-fonts-malayalam lohit-fonts-oriya lohit-fonts-punjabi lohit-fonts-tamil lohit-fonts-telugu "perl(Makefile::Parser)"
Loaded plugins: dellsysidplugin2, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora-11: www.kanarip.com
 * fedora-11-development: www.kanarip.com
 * fedora-11-rpmfusion-free: www.kanarip.com
 * fedora-11-rpmfusion-free-updates: www.kanarip.com
 * fedora-11-rpmfusion-nonfree-updates: www.kanarip.com
 * fedora-11-updates: www.kanarip.com
fedora-11                                                                                                                                                                          | 3.8 kB     00:00     
fedora-11-custom                                                                                                                                                                   | 1.9 kB     00:00     
fedora-11-development                                                                                                                                                              | 4.2 kB     00:00     
fedora-11-gdbm                                                                                                                                                                     | 1.9 kB     00:00     
fedora-11-rpmfusion-free                                                                                                                                                           | 3.3 kB     00:00     
fedora-11-rpmfusion-free-updates                                                                                                                                                   | 3.8 kB     00:00     
fedora-11-rpmfusion-nonfree                                                                                                                                                        | 3.3 kB     00:00     
fedora-11-rpmfusion-nonfree-updates                                                                                                                                                | 3.8 kB     00:00     
fedora-11-ruby                                                                                                                                                                     | 2.3 kB     00:00     
fedora-11-updates                                                                                                                                                                  | 4.4 kB     00:00     
Setting up Install Process
Package matching lohit-bengali-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
Package matching lohit-gujarati-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
Package matching lohit-hindi-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
Package matching lohit-kannada-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
Package matching lohit-malayalam-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
Package matching lohit-oriya-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
Package matching lohit-punjabi-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
Package matching lohit-tamil-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
Package matching lohit-telugu-fonts-2.4.0-1.fc11.noarch already installed. Checking for update.
No package perl(Makefile::Parser) available.
Nothing to do

  
Actual results:

Failure all over.

Expected results:

A publican build that would support tables in PDF files.
Comment 1 Jeroen van Meeuwen 2009-10-11 09:40:42 EDT
Created attachment 364383 [details]
Mock log

Additional failed requirement for lohit-fonts-bengali.
Comment 2 Ruediger Landmann 2009-10-11 16:34:39 EDT
Publican 0.99 is the Beta version for the forthcoming Publican 1.0. It depends on a number of packages that are not yet available in Fedora. 

If you would like to try out the Beta software, packages for Publican itself plus its dependencies are available for F11 and Rawhide here: https://fedorahosted.org/publican/wiki/PublicanBetaAnnounce

Cheers

Ruediger
Comment 3 Nick Bebout 2009-11-03 19:35:32 EST
Publican 1.1 is now built for F-10, F-11, F-12 and should be showing up in updates shortly.