This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 535538 (RHQ-2222)

Summary: Installer: db "Test Connection" button clears password field
Product: [Other] RHQ Project Reporter: Jeff Weiss <jweiss>
Component: InstallerAssignee: Jay Shaughnessy <jshaughn>
Status: CLOSED CURRENTRELEASE QA Contact: Jeff Weiss <jweiss>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.2CC: ccrouch, cwelton, dajohnso, hrupp, jshaughn, jtyrrell, mfoley, skondkar, theute
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
URL: http://jira.rhq-project.org/browse/RHQ-2222
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
rev4268
Last Closed: 2013-09-04 03:30:36 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752488, 760116    

Description Jeff Weiss 2009-07-08 15:15:00 EDT
To repeat:

bring up installer page, fill out db connection info (including password).  Click "Test Connection".  The connection test passes (green icon), but the password field has been cleared and the user is forced to re-enter their password.  This is a regression in the latest qa build, in all previous builds the field would remain intact.

Comment 1 Charles Crouch 2009-07-28 19:47:00 EDT
If this is easy and quick to do then lets do it, otherwise push.
Comment 2 Joseph Marques 2009-09-03 08:17:24 EDT
this button actually performs a full-page form submit, an action, then redirects back to itself.  to fix this, we'd have to move to an ajax-y button whose action handler updated some element on the page.  pretty simple, but i vote to push given the time left in this release.  
Comment 3 Charles Crouch 2009-09-03 11:56:50 EDT
+1 on pushing. This is annoying but not a showstopper.
Comment 4 Jeff Weiss 2009-09-03 12:20:40 EDT
This is a regression, it used to work fine.  How is ajax required now, but not before?
Comment 5 Red Hat Bugzilla 2009-11-10 16:00:16 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2222
Comment 6 Charles Crouch 2010-05-17 17:41:21 EDT
IIRC currently the user is not required to re-enter their password after testing the DB connection
Comment 7 Ian Springer 2011-11-21 11:41:24 EST
This is still an issue in JON 3.0.CR2. 

The password field gets blanked out after the Test Connection button is clicked, and then the installer allows the user to click the Install button even though the password is blank (password should be a required field so validation fails if it is blank..), and then the install fails and causes the rhq oracle user to be locked due to too many failed attempts trying to login with a blank password.
Comment 9 Jay Shaughnessy 2011-12-16 11:25:14 EST
Maintaining the password value is actually not easy given the installer
impl.  This should probably be fixed as a result of building a new
installer implemented in SmartGWT, as part of our move away from JSF.

In the interim, I'll see if I can just ensure that we have a value
filled in prior to exiting the page.
Comment 10 Jay Shaughnessy 2011-12-16 17:10:08 EST
commit 14256b6e778bbb02703dd82e1804f69d2b639f64

An attempt to improve the situation by alerting the user, and not processing
"Test Connection" or "Install Server!" buttons,  if the password field
is empty.
- Note, the message displayed is in English since I'm not proficient enough
  to figure out how to get javascript to interact with the resource bundle.


Test Notes
Would need to test this on the supported browsers I guess.
Comment 11 Sunil Kondkar 2011-12-19 07:13:30 EST
Verified in master build#848

Verified on browsers Firefox 3.x , IE 8 and chrome. If password field is empty and user clicks on the "Test Connection" button on the installer page, it displays a message "Please enter database password".
Comment 12 Charles Crouch 2012-01-11 22:11:49 EST
*** Bug 772226 has been marked as a duplicate of this bug. ***
Comment 13 Charles Crouch 2012-01-11 22:16:40 EST
Setting this back to ONQA to make sure that "Install Server!" button doesn't trigger an install attempt if the database password field is empty. This should prevent the issue which Ian mentioned.
Comment 14 Mike Foley 2012-01-16 10:23:42 EST
additionally verified the testpoint in comment #13
Comment 15 mark yarborough 2012-11-29 15:13:45 EST
*** Bug 881400 has been marked as a duplicate of this bug. ***
Comment 16 Heiko W. Rupp 2013-09-04 03:30:36 EDT
Done in a very old release, closing now.