Bug 549404

Summary: RFE handle downgrade dependencies better
Product: [Fedora] Fedora Reporter: Bruno Wolff III <bruno>
Component: yumAssignee: packaging-team-maint
Status: NEW --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: daniel.helgenberger, ffesti, james.antill, maxamillion, ohudlick, opensource, tla, vonbrand
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Bruno Wolff III 2009-12-21 11:04:17 EST
Description of problem:

When I downgrade a package that has related packages from the same src rpm, it would be nice if yum tried harder to do a consistent downgrade by downgrading the related packages rather than by starting to erase things, which can cascade into removing most of one's system.

The work around for this is to find the related packages and explicitly downgrade them all, so it isn't a very important feature. But I think it would be a nice touch if someone eventually has time to include it.

For example today I needed to downgrade glibc to work around a sound problem and after getting the old version (all of the rpms generated from the glibc srpm) into a local repo, I tried:
yum downgrade glibc
despite knowing better. glibc-common was downgraded, but then things starting showing up on the erase list. I killed this off before seeing the entire list of packages proposed for removal as I knew I wasn't going to want to do that.
Then I did what I should have done in the first place:
yum downgrade glibc glibc-common glibc-devel glibc-headers glibc-static glibc-utils nscd
And that only downgraded the packages in that list.

My request is that the shortcut I tried should really work like the more expanded version.


Version-Release number of selected component (if applicable):
Currently yum-3.2.25-7.fc13.noarch doesn't do this.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Antill 2009-12-21 12:04:55 EST
 Yeh, we know about it ... but we don't think it's easy to fix. A couple of workarounds to make it more bearable are:

1. You can run: yum downgrade 'glibc*'.

2. Try to do smaller transactions, and then you can use "yum history undo" to downgrade (we're also looking at ways we can make it easier to do N small transactions instead of a large one).

...but, as always, patches are welcome ;).
Comment 2 James Antill 2010-09-14 12:47:33 EDT
*** Bug 631291 has been marked as a duplicate of this bug. ***
Comment 3 James Antill 2011-01-20 15:28:10 EST
*** Bug 669810 has been marked as a duplicate of this bug. ***