Bug 566482

Summary: update diffutils to 3.0
Product: [Fedora] Fedora Reporter: acount closed by user <a1459440>
Component: diffutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: c719711, eblake, i18n-bugs, meyering, twaugh, upstream-release-monitoring
Target Milestone: ---Keywords: FutureFeature, Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: diffutils-3.0-1.fc16 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-13 10:56:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
diffutils-2.8.1-i18n-0.2.patch from OpenSuSE none

Description acount closed by user 2010-02-18 15:31:49 UTC
* Noteworthy changes in release 2.9 (2010-02-11) [stable]

** New features

  New diff option --suppress-blank-empty.

  Bring back support for `diff -NUM', where NUM is a number,
  even when conforming to POSIX 1003.1-2001.  This change reverts to
  the behavior of GNU diff 2.7 and earlier.  This is a change only
  when conforming to POSIX 1003.1-2001; there is no effect when
  conforming to older POSIX versions.

  This change is in response to decisions taken in the January 2005
  Austin Group standardization meeting.  For more details, please see
  "Utility Syntax Guidelines" in the Minutes of the January 2005
  Meeting <http://www.opengroup.org/austin/docs/austin_239.html>.

  sdiff now understands '1' and '2' as synonyms for 'l' and 'r'.

** Changes in behavior

  sdiff and diff3 now invoke diff, not $(bindir)/diff

** Administrivia

  New discussion and bug-reporting address: bug-diffutils@gnu.org

  updated gnulib support

Comment 1 Tim Waugh 2010-02-18 16:39:30 UTC
The i18n patch needs re-basing to 2.9.

Comment 2 acount closed by user 2010-03-16 11:51:07 UTC
ping...

Comment 3 Tim Waugh 2010-03-16 12:33:50 UTC
I haven't forgotten about this, but I've been busy with higher priority bugs (vs this feature request).  Re-basing the i18n patch is not trivial.

Comment 4 acount closed by user 2010-03-28 03:04:06 UTC
I am not hurry, but 2.8.1 is _eight_ years old!

Recently Jim Meyering  <meyering@redhat.com> has done a lots of commits in the diffutils source code, I guess he can help you with the i18n patch.

-thanks-

Comment 5 acount closed by user 2010-03-28 03:10:36 UTC
see this thread: http://lists.gnu.org/archive/html/bug-diffutils/2010-02/msg00022.html

Comment 6 Tim Waugh 2010-04-15 22:05:09 UTC
*** Bug 582837 has been marked as a duplicate of this bug. ***

Comment 7 Tim Waugh 2010-04-17 12:13:29 UTC
*** Bug 583241 has been marked as a duplicate of this bug. ***

Comment 8 acount closed by user 2010-04-27 13:12:47 UTC
state ?

Comment 9 Tim Waugh 2010-04-27 13:50:24 UTC
No change.  Help welcome re-basing this large i18n patch.

Comment 10 acount closed by user 2010-05-03 23:08:47 UTC
* Noteworthy changes in release 3.0 (2010-05-03) [stable]

** Bug fixes

  diff once again prints the required "\ No newline at end of file" line
  when at least one input lacks a newline-at-EOF and the final hunk plus
  context-length aligns exactly with the end of the newline-lacking file.
  [bug introduced between 2.8.7 and 2.9]

** Changes in behavior

  In context-style diffs, diff prints a portion of a preceding "function"
  line for each hunk, with --show-function-line=RE (-F) or
  --show-c-function (-p).  Now, it trims leading blanks from such lines
  before extracting a prefix.  This is useful especially when a function
  line is so far indented that the name itself would be truncated or not
  included in the limited-width substring that diff appends.

  diff once again reports a difference with the diagnostic
  "Binary files A and B differ" when at least one of the files
  appears to be binary.  From 2.8.4 through diffutils-2.9, it printed
  "Files A and B differ".

Comment 11 Andreas Schwab 2010-05-04 08:59:46 UTC
You may want to take a look at <http://download.opensuse.org/repositories/home:/AndreasSchwab/11.2/src/diffutils-3.0-145.1.src.rpm>.

Comment 12 acount closed by user 2010-05-04 09:18:53 UTC
Created attachment 411228 [details]
diffutils-2.8.1-i18n-0.2.patch from OpenSuSE

Comment 13 Tim Waugh 2010-05-04 10:29:52 UTC
*** Bug 588691 has been marked as a duplicate of this bug. ***

Comment 14 acount closed by user 2010-06-27 00:56:38 UTC
Closed.

I'm sorry, I'm going to delete my bz count.

Comment 15 Jim Meyering 2010-06-27 06:28:39 UTC
Thanks, but that's no reason to close this bug.  Reopened.

Comment 16 Account closed by user 2011-02-22 19:32:30 UTC
This looks dead.

Comment 17 Tim Waugh 2011-02-23 17:08:14 UTC
Not dead, just lower priority than other things at the moment.  I will get to it.

Comment 18 Account closed by user 2011-02-23 17:19:03 UTC
lower lower lower ;-)

2.8.1 is nine years old, and this bug was opened one year ago.

Comment 19 Tim Waugh 2011-04-13 10:56:36 UTC
I've dropped the i18n patch altogether.  If someone wants to look at adding it back in, please go ahead.