Bug 578048

Summary: lang-specific overrides rule doesn't work as expected
Product: [Fedora] Fedora Reporter: Akira TAGOH <tagoh>
Component: vlgothic-fontsAssignee: Akira TAGOH <tagoh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: fonts-bugs, glaubitz, i18n-bugs, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: vlgothic-fonts-20100416-1.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586848 (view as bug list) Environment:
Last Closed: 2010-05-10 19:50:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 578015    
Bug Blocks: 507684, 586848    

Description Akira TAGOH 2010-03-29 23:57:54 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 65-1-vlgothic-gothic.conf
 65-0-vlgothic-pgothic.conf
Comment 1 Akira TAGOH 2010-04-19 02:17:11 EDT
Fixed in vlgothic-fonts-20100416-1.fc13.
Comment 2 Fedora Update System 2010-04-19 02:31:52 EDT
vlgothic-fonts-20100416-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/vlgothic-fonts-20100416-1.fc13
Comment 3 Fedora Update System 2010-04-20 09:24:10 EDT
vlgothic-fonts-20100416-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vlgothic-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/vlgothic-fonts-20100416-1.fc13
Comment 4 Karel Klíč 2010-04-20 12:35:45 EDT
*** Bug 576175 has been marked as a duplicate of this bug. ***
Comment 5 Akira TAGOH 2010-04-26 07:12:09 EDT
Testing result:
# rpm -qa vlgothic-*
vlgothic-p-fonts-20100416-1.fc13.noarch
vlgothic-fonts-20100416-1.fc13.noarch
vlgothic-fonts-common-20100416-1.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=ja
VL-Gothic-Regular.ttf: "VL Gothic" "regular"
# fc-match monospace:lang=ja-jp
VL-Gothic-Regular.ttf: "VL Gothic" "regular"

That looks good.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=ja
VL-PGothic-Regular.ttf: "VL PGothic" "regular"
# fc-match sans:lang=ja-jp
VL-PGothic-Regular.ttf: "VL PGothic" "regular"

That looks good.

# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=ja
sazanami-mincho.ttf: "Sazanami Mincho" "Regular"
# fc-match serif:lang=ja-jp
sazanami-mincho.ttf: "Sazanami Mincho" "Regular"

No explicit rules for serif in vlgothic-fonts.

# for i in $(ls /usr/share/locale|grep -v -E "^(ja)$"); do fc-match sans:lang=$i|grep -E "^(VL.*)$"; [ $? = 0 ] && echo $i; done
#

No affects to other languages though, that may be good to get rid of compare="contains" since it matches to other languages unexpectedly.
Comment 6 Fedora Update System 2010-05-10 19:50:25 EDT
vlgothic-fonts-20100416-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.