Bug 582590

Summary: Preupgrade starts on VT7 but it runs on VT1
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: preupgradeAssignee: Richard Hughes <richard>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: bloch, jlaska, rhughes, richard
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-19 09:53:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 507681    
Attachments:
Description Flags
video demonstration none

Description Kamil Páral 2010-04-15 07:36:44 EDT
Description of problem:
When using preupgrade and rebooting to finish installation, you see only black screen. That is because the active terminal is VT7 (probably). But the preupgrade itself is displayed on VT1. You have to manually switch to VT1 to see the progress, otherwise you're left in the dark (literally).

According to some people after some time the terminal is switch automatically (some gdm timeout or something?). I can't confirm, never waited *that* long.

This problem has been confirmed by multiple people, as is seen from bug 575400 and its duplicates.

Version-Release number of selected component (if applicable):
preupgrade-1.1.4-1.fc12.noarch

How reproducible:
always
Comment 1 Richard Hughes 2010-04-16 06:27:29 EDT
I can't reproduce. Can you describe in detail what part of the post-reboot needs to be switched vt's? Thanks.
Comment 2 Kamil Páral 2010-04-16 06:49:56 EDT
Created attachment 407061 [details]
video demonstration

I'm adding a video demonstration of the issue. Does it help, or you have some more questions?

In this particular example you can also see bug 575400, but that doesn't matter, it works the same even if you have correct kickstart file, just after switching to VT1 you see a progress bar.
Comment 3 James Laska 2010-04-16 16:26:06 EDT
Is this the existing known issue affecting any kickstart grahpical installs? 

https://fedoraproject.org/wiki/Common_F13_bugs#black-screen-on-kickstart-install
Comment 4 James Laska 2010-04-16 16:28:16 EDT
kparal: Can you try testing with the updates.img (http://jlaska.fedorapeople.org/updates-577708.img) from bug#577708?
Comment 5 Kamil Páral 2010-04-19 04:27:19 EDT
(In reply to comment #4)
> kparal: Can you try testing with the updates.img
> (http://jlaska.fedorapeople.org/updates-577708.img) from bug#577708?    

Yes, copying updates.img to /boot/upgrade helped. The installation now runs in graphical mode, so VT7 is the correct display to use.
Comment 6 James Laska 2010-04-19 09:53:59 EDT
Thanks for the feedback Kamil!  I'm going to CLOSE this issue as a duplicate of bug#577708.  This should be resolved for all preupgrade users when anaconda is rebuilt for F-13 Branched later this week.

*** This bug has been marked as a duplicate of bug 577708 ***