This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 575400 - Preupgrade generated kickstart with an error
Preupgrade generated kickstart with an error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 578284 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-03-20 10:32 EDT by Adam Huffman
Modified: 2010-05-03 12:49 EDT (History)
11 users (show)

See Also:
Fixed In Version: preupgrade-1.1.5-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 12:13:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kickstart generated by preupgrade (276 bytes, text/plain)
2010-03-20 10:32 EDT, Adam Huffman
no flags Details
Anaconda log (4.03 KB, text/plain)
2010-03-20 10:33 EDT, Adam Huffman
no flags Details
Program log (47.36 KB, text/plain)
2010-03-20 10:34 EDT, Adam Huffman
no flags Details
Storage log (86.55 KB, text/plain)
2010-03-20 10:34 EDT, Adam Huffman
no flags Details
Syslog (63.09 KB, text/plain)
2010-03-20 10:36 EDT, Adam Huffman
no flags Details
X log (36.79 KB, text/plain)
2010-03-20 10:38 EDT, Adam Huffman
no flags Details
screenshot (22.86 KB, image/png)
2010-04-14 13:43 EDT, Kamil Páral
no flags Details

  None (edit)
Description Adam Huffman 2010-03-20 10:32:56 EDT
Created attachment 401439 [details]
Kickstart generated by preupgrade

Description of problem:

Just tried upgrading an F12 laptop to F13 using preupgrade.  The package download proceeded normally.  When I rebooted, there was quite a long pause with a blank screen, after which an error message appeared:

The kickstart configuration file is missing required
information that anaconda cannot prompt for.  Please add
the following sections and try again:
Disks to clear

Version-Release number of selected component (if applicable):
preupgrade-1.1.4-1.fc12.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Huffman 2010-03-20 10:33:55 EDT
Created attachment 401440 [details]
Anaconda log
Comment 2 Adam Huffman 2010-03-20 10:34:20 EDT
Created attachment 401441 [details]
Program log
Comment 3 Adam Huffman 2010-03-20 10:34:50 EDT
Created attachment 401442 [details]
Storage log
Comment 4 Adam Huffman 2010-03-20 10:36:44 EDT
Created attachment 401444 [details]
Syslog
Comment 5 Adam Huffman 2010-03-20 10:38:13 EDT
Created attachment 401446 [details]
X log
Comment 6 Kamil Páral 2010-04-14 13:41:44 EDT
*** Bug 578284 has been marked as a duplicate of this bug. ***
Comment 7 Kamil Páral 2010-04-14 13:43:54 EDT
Created attachment 406585 [details]
screenshot

I have just seen this issue too. My kickstart is exactly same as Adam's (apart from keyboard, lang and disk UUID).

I also attach screenshot of the error message.
Comment 8 Kamil Páral 2010-04-14 13:44:37 EDT
This issue has been confirmed by multiple people, proposing as F13Blocker.
Comment 9 Will Woods 2010-04-14 14:06:31 EDT
There's definitely a bug here somewhere. But the preupgrade-generated kickstart isn't necessarily the problem. 

Anaconda's not supposed to be clearing disks (or asking about which disks to clear) during an upgrade. That should be pretty obvious - you don't want anything to get deleted, you want it to get upgraded.

Could you try adding 'clearpart --none' to the kickstart and see if that works? Executing that command tells anaconda to skip the 'Disks to clear' screen - except since 'clearpart --none' is the default, this wasn't necessary in the past.
Comment 10 Kamil Páral 2010-04-15 07:38:29 EDT
Yes, that fixed the problem, Will, perfect. The only remaining issue is that you don't see anything until you manually switch to VT1. I have reported separate ticket about it: bug 582590.
Comment 11 Richard Hughes 2010-04-16 06:26:13 EDT
commit 741289d1c95938f3246da266d3bb08bea8685e52
Author: Richard Hughes <richard@hughsie.com>
Date:   Fri Apr 16 11:25:56 2010 +0100

    Add 'clearpart --none' to the kickstart, as anaconda no longer defaults to this. Fixes rh#575400
Comment 12 Richard Hughes 2010-04-16 07:16:04 EDT
Could you try the preupgrade package here please: http://people.freedesktop.org/~hughsient/fedora/13/i386/
Comment 13 Kamil Páral 2010-04-16 08:27:29 EDT
Could you please build package for x86_64? That would save lots of time for me.
Comment 14 Kamil Páral 2010-04-16 09:06:39 EDT
I'm afraid you forgot an end-of-line. My generated kickstart:

# ks.cfg generated by preupgrade
lang en_US.UTF-8
keyboard us
bootloader --upgrade --location=none
clearpart --noneupgrade --root-device=UUID=aaccda74-4c94-463a-8aea-f46d1c22545c
reboot


%post
grubby --remove-kernel=/boot/upgrade/vmlinuz
rm -rf /boot/upgrade /var/cache/yum/preupgrade*
%end

After trying to upgrade I see this error:

no such option: --noneupgrade
Comment 15 Kamil Páral 2010-04-16 09:22:40 EDT
Installed 0:1.1.5-0.2.fc13. Kickstart:

# ks.cfg generated by preupgrade
lang en_US.UTF-8
keyboard us
bootloader --upgrade --location=none
clearpart --none --root-device=UUID=aaccda74-4c94-463a-8aea-f46d1c22545c
upgrade
reboot


%post
grubby --remove-kernel=/boot/upgrade/vmlinuz
rm -rf /boot/upgrade /var/cache/yum/preupgrade*
%end

Error:

no such option: --root-device
Comment 16 Kamil Páral 2010-04-16 09:47:43 EDT
preupgrade-1.1.5-0.3.fc13.noarch finally looks ok :) Fixed.
Comment 17 Fedora Admin XMLRPC Client 2010-04-16 10:35:14 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 18 Adam Williamson 2010-04-16 16:37:39 EDT
Discussed at today's blocker review meeting, we accept this as a blocker:

"The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation of the previous stable Fedora release, either via preupgrade or by booting to the installer manually "

https://fedoraproject.org/wiki/Fedora_13_Beta_Release_Criteria

We hope the fixed build will be submitted as an update soon.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Huffman 2010-04-19 07:50:42 EDT
Yes, preupgrade-1.1.5-0.3.fc13.noarch worked for me as well.

Just to point out the obvious, this needs to be built for F12 as well as F13...
Comment 20 Nikola Pajkovsky 2010-04-22 08:03:50 EDT
Where do I find preupgrade-1.1.5-0.3.fc13.noarch? I can't find it in cvs.
Comment 21 Kamil Páral 2010-04-23 04:15:18 EDT
(In reply to comment #20)
> Where do I find preupgrade-1.1.5-0.3.fc13.noarch? I can't find it in cvs.    

See comment #12.
Comment 22 Nikola Pajkovsky 2010-04-23 05:26:47 EDT
Still not working.


$ preupgrade
/usr/lib/python2.6/site-packages/yum/__init__.py:215: UserWarning: Use .preconf instead of passing args to _getConfig
  warnings.warn('Use .preconf instead of passing args to _getConfig')
Loaded plugins: blacklist, presto, refresh-packagekit, whiteout
Detected in-progress upgrade to Fedora 13 (Branch)
preupgrade-main (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-13&arch=$basearch
  now: http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-13&arch=i386
preupgrade (mirrorlist) 
  url: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/13/$basearch/os
  now: http://mirrors.fedoraproject.org/mirrorlist?path=pub/fedora/linux/development/13/i386/os
unknown metadata being downloaded: repomdKIYffCtmp.xml
preupgrade-rpmfusion-free-rawhide (mirrorlist) 
  url: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-rawhide&arch=i386
  now: http://mirrors.rpmfusion.org/mirrorlist?repo=free-fedora-rawhide&arch=i386
unknown metadata being downloaded: repomd9scYmItmp.xml
unknown metadata being downloaded: MEMORY
Fetched treeinfo from http://errors.secsup.org
Failed to download installer metadata
Fetched treeinfo from http://errors.secsup.org
Failed to download installer metadata
Comment 23 Kamil Páral 2010-04-23 05:50:07 EDT
(In reply to comment #22)
> Still not working.
> 

Nikola, I think you should file a separate bug.
Comment 24 Adam Williamson 2010-04-23 15:24:12 EDT
as posted on 572148:

Discussed at today's blocker meeting. Richard, when do you plan to submit this
fix to F12 updates? It's still blocking the release of F13 until that happens.
Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Fedora Update System 2010-04-26 07:26:47 EDT
preupgrade-1.1.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/preupgrade-1.1.5-1.fc12
Comment 26 Fedora Update System 2010-04-26 22:18:10 EDT
preupgrade-1.1.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/preupgrade-1.1.5-1.fc12
Comment 27 John T. Rose 2010-04-27 09:42:10 EDT
I'm still getting a traceback with preupgrade-1.1.5-1.fc12.

  File "/usr/bin/anaconda", line 817 in <module>
    import kickstart
  File "/usr/lib/anaconda/kickstart.py", line 21 in <module>
    from storage.deviceaction import *
  File "/usr/lib/anaconda/storage/__init__.py", line 31 in <module>
    import parted
  File "/usr/lib64/python2.6/site-packages/parted/__init__.py", line 52 in <module>
    from partition import Partition
  File "/usr/lib64/python2.6/site-packages/parted/partition.py", line 249 in <module>
    partitionFlag[__flag] = _ped.partition_flag_get_name(__flag)
ValueError: Invalid flag provided.

The kickstart file appears to be as it was intended:

# ks.cfg generated by preupgrade
lang en_US.UTF-8
keyboard us
bootloader --upgrade --location=none
clearpart --none
upgrade --root-device=UUID=ef202230-5570-4fbf-95f7-fc30760ebda0
reboot


%post
grubby --remove-kernel=/boot/upgrade/vmlinuz
rm -rf /boot/upgrade /var/cache/yum/preupgrade*
%end
Comment 28 Richard Hughes 2010-04-28 04:24:56 EDT
(In reply to comment #27)
> I'm still getting a traceback with preupgrade-1.1.5-1.fc12.
> 
>   File "/usr/bin/anaconda", line 817 in <module>
>     import kickstart
>   File "/usr/lib/anaconda/kickstart.py", line 21 in <module>
>     from storage.deviceaction import *
>   File "/usr/lib/anaconda/storage/__init__.py", line 31 in <module>
>     import parted
>   File "/usr/lib64/python2.6/site-packages/parted/__init__.py", line 52 in
> <module>
>     from partition import Partition
>   File "/usr/lib64/python2.6/site-packages/parted/partition.py", line 249 in
> <module>
>     partitionFlag[__flag] = _ped.partition_flag_get_name(__flag)
> ValueError: Invalid flag provided.

This is a different bug. please don't piggy-back onto this one. If you file it against the parted component I think that is the right place.
Comment 29 Adam Williamson 2010-05-03 11:16:27 EDT
Kamil, can you please confirm the released 0.1.5 fixes this bug (despite its other problems)? Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 30 Fedora Update System 2010-05-03 12:13:02 EDT
preupgrade-1.1.5-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Kamil Páral 2010-05-03 12:49:09 EDT
(In reply to comment #29)
> Kamil, can you please confirm the released 0.1.5 fixes this bug (despite its
> other problems)? Thanks.

Yes, already confirmed in Bodhi. Problem fixed.

Note You need to log in before you can comment on or make changes to this bug.