Bug 587149

Summary: Warning and failure during update of gnome-settings-daemon
Product: [Fedora] Fedora Reporter: Joachim Backes <joachim.backes>
Component: gnome-settings-daemonAssignee: Bastien Nocera <bnocera>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: bnocera, mads, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gnome-settings-daemon-2.30.1-4.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-30 05:23:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 507684    

Description Joachim Backes 2010-04-29 08:15:18 UTC
Description of problem:
If updating gnome-seetings-daemon, getting the following warning an failure message:

  Installing     : gnome-settings-daemon-2.30.1-3.fc13.i686                                                                           1/1 
I/O warning : failed to load external entity "/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas"
Failed to open `/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas': No such file or directory

Installed:
gnome-settings-daemon.i686 0:2.30.1-3.fc13                                                                          

Version-Release number of selected component (if applicable):
gnome-settings-daemon-2.30.1-3.fc13.i686

How reproducible:
--

Steps to Reproduce:
1.update (or reinstall) gnome-settings-daemon
2.
3.
  
Actual results:
See description

Expected results:
No warning or other message

Additional info:

I tried to downgrade and then update gnome-settings-daemon. Getting the same result.

Comment 1 Mads Kiilerich 2010-04-29 09:09:49 UTC
The pre/post scripts references apps_gnome_settings_daemon_screensaver schema which doesn't exist.

However, it seems like these are missing:
apps_gnome_settings_daemon_housekeeping 
apps_gnome_settings_daemon_xrandr
desktop_gnome_keybindings
?

Comment 2 Mads Kiilerich 2010-04-29 09:14:35 UTC
Bug 586258 was F13Blocker. This is less critical, so I assume F13Target is sufficient.

Comment 3 Fedora Update System 2010-04-29 21:29:41 UTC
gnome-settings-daemon-2.30.1-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnome-settings-daemon-2.30.1-4.fc13

Comment 4 Joachim Backes 2010-04-30 05:23:20 UTC
Works for me.

Comment 5 Fedora Update System 2010-05-04 23:56:18 UTC
gnome-settings-daemon-2.30.1-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.