Bug 587149 - Warning and failure during update of gnome-settings-daemon
Warning and failure during update of gnome-settings-daemon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-04-29 04:15 EDT by Joachim Backes
Modified: 2010-05-04 19:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: gnome-settings-daemon-2.30.1-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 01:23:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2010-04-29 04:15:18 EDT
Description of problem:
If updating gnome-seetings-daemon, getting the following warning an failure message:

  Installing     : gnome-settings-daemon-2.30.1-3.fc13.i686                                                                           1/1 
I/O warning : failed to load external entity "/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas"
Failed to open `/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas': No such file or directory

Installed:
gnome-settings-daemon.i686 0:2.30.1-3.fc13                                                                          

Version-Release number of selected component (if applicable):
gnome-settings-daemon-2.30.1-3.fc13.i686

How reproducible:
--

Steps to Reproduce:
1.update (or reinstall) gnome-settings-daemon
2.
3.
  
Actual results:
See description

Expected results:
No warning or other message

Additional info:

I tried to downgrade and then update gnome-settings-daemon. Getting the same result.
Comment 1 Mads Kiilerich 2010-04-29 05:09:49 EDT
The pre/post scripts references apps_gnome_settings_daemon_screensaver schema which doesn't exist.

However, it seems like these are missing:
apps_gnome_settings_daemon_housekeeping 
apps_gnome_settings_daemon_xrandr
desktop_gnome_keybindings
?
Comment 2 Mads Kiilerich 2010-04-29 05:14:35 EDT
Bug 586258 was F13Blocker. This is less critical, so I assume F13Target is sufficient.
Comment 3 Fedora Update System 2010-04-29 17:29:41 EDT
gnome-settings-daemon-2.30.1-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnome-settings-daemon-2.30.1-4.fc13
Comment 4 Joachim Backes 2010-04-30 01:23:20 EDT
Works for me.
Comment 5 Fedora Update System 2010-05-04 19:56:18 EDT
gnome-settings-daemon-2.30.1-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.