Bug 586258 - gnome-settings-daemon-2.30.1-1 fails to upgrade
Summary: gnome-settings-daemon-2.30.1-1 fails to upgrade
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 586280 586458 586649 (view as bug list)
Depends On:
Blocks: F13Blocker, F13FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2010-04-27 07:30 UTC by James Cassell
Modified: 2010-05-03 23:42 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 20:53:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Cassell 2010-04-27 07:30:44 UTC
Description of problem:
Error updating

Error in PREIN scriptlet in rpm package gnome-settings-daemon-2.30.1-1.fc13.x86_64
/var/tmp/rpm-tmp.Uxs7Ln: line 11: apps_gnome_settings_daemon_screensaver: command not found
error: %pre(gnome-settings-daemon-2.30.1-1.fc13.x86_64) scriptlet failed, exit status 127
error:   install: %pre scriptlet failed (2), skipping gnome-settings-daemon-2.30.1-1.fc13
gnome-settings-daemon-2.30.0-1.fc13.x86_64 was supposed to be removed but is not!

Failed:
  gnome-settings-daemon.x86_64 0:2.30.1-1.fc13    


Version-Release number of selected component (if applicable):
2.30.1-1.fc13

How reproducible:
yes

Steps to Reproduce:
1.
2.
3.
  
Actual results:
doesn't upgrade

Expected results:
should upgrade successfully

Additional info:

Comment 1 Karel Volný 2010-04-27 09:59:56 UTC
*** Bug 586280 has been marked as a duplicate of this bug. ***

Comment 2 cschwangler 2010-04-27 10:03:05 UTC
Same problem here with gnome-settings-daemon-2.30.0-1.fc13.i686:

Error in PREIN scriptlet in rpm package gnome-settings-daemon-2.30.1-1.fc13.i686
/var/tmp/rpm-tmp.3GrftG: line 11: apps_gnome_settings_daemon_screensaver: command not found
error: %pre(gnome-settings-daemon-2.30.1-1.fc13.i686) scriptlet failed, exit status 127
error:   install: %pre scriptlet failed (2), skipping gnome-settings-daemon-2.30.1-1.fc13

Comment 3 Felix Möller 2010-04-27 12:59:38 UTC
I am hit by this too.

The error is not even presented in the gui. See bug #586382.

Comment 4 Mads Kiilerich 2010-04-27 13:27:22 UTC
That is due to preinstall scriptlet (using /bin/sh):

if [ "$1" -gt 1 ] ; then 
    rm -rf /var/lib/rpm-state/gconf/* 
    for schema in apps_gnome_settings_daemon_keybindings \ ; do 
        if test -f /etc/gconf/schemas/"$schema".schemas ; then 
            cp -p /etc/gconf/schemas/"$schema".schemas /var/lib/rpm-state/gconf/ || : 
        fi 
    done 
fi 
                      apps_gnome_settings_daemon_screensaver \
                      desktop_gnome_font_rendering \
                      desktop_Gnome_peripherals_touchpad \
                      gnome-settings-daemon

expanded from  %pre

%gconf_schema_prepare apps_gnome_settings_daemon_keybindings \
                      apps_gnome_settings_daemon_screensaver \
                      desktop_gnome_font_rendering \
                      desktop_Gnome_peripherals_touchpad \
                      gnome-settings-daemon

introduced in
* Mon Apr 26 2010 Matthias Clasen <mclasen@redhat.com> 2.30.1-1
- Update to 2.30.1
- Spec file cleanups

committed in f13 2010/04/27 00:23:50.

RPM Macros are apparently unaware of shell quoting.

Comment 5 Patrick Klingemann 2010-04-27 15:59:49 UTC
Same issue here, I can provide the yum output if necessary, but it looks like y'all are past that point now.

Comment 6 Yanko Kaneti 2010-04-27 19:41:34 UTC
*** Bug 586458 has been marked as a duplicate of this bug. ***

Comment 7 Mads Kiilerich 2010-04-29 09:02:06 UTC
*** Bug 586649 has been marked as a duplicate of this bug. ***

Comment 8 Mads Kiilerich 2010-04-29 09:11:50 UTC
Confirmed solved in gnome-settings-daemon-2.30.1-3.fc13 - which however has bug 587149.

Comment 9 James Laska 2010-04-29 12:23:13 UTC
Confirmed fixed as well.  I've added feedback to the bodhi update request ... https://admin.fedoraproject.org/updates/gnome-settings-daemon-2.30.1-3.fc13

Comment 10 cschwangler 2010-04-29 16:27:07 UTC
I can confirm that the update works, but, as mentioned in bug 587149, I get this message

  Updating       : gnome-settings-daemon-2.30.1-3.fc13.i686                                                           76/182 
I/O warning : failed to load external entity "/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas"
Failed to open `/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas': No such file or directory

Comment 11 cyrushmh 2010-04-30 06:08:12 UTC
(In reply to comment #10)
> I can confirm that the update works, but, as mentioned in bug 587149, I get
> this message
> 
>   Updating       : gnome-settings-daemon-2.30.1-3.fc13.i686                    
>                                       76/182 
> I/O warning : failed to load external entity
> "/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas"
> Failed to open
> `/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas': No such
> file or directory    

#yum --enablerepo=updates-testing update

 正在升级       : gnome-settings-daemon-2.30.1-3.fc13.i686                         
                                                                   5/16 
I/O warning : failed to load external entity
"/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas"
打开“/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas”失败:没有那个文件或目录


2.6.33.2-57.fc13.i686.PAE

Comment 12 Adam Williamson 2010-05-03 20:53:07 UTC
the critical bit of this - the failure to update - has been fixed. The message has been reported as a separate bug, so let's close this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 cyrushmh 2010-05-03 23:42:01 UTC
pass, it is work normal


Note You need to log in before you can comment on or make changes to this bug.