Bug 606892

Summary: Consider updating cmake to 2.8.X
Product: Red Hat Enterprise Linux 6 Reporter: Orion Poplawski <orion>
Component: cmakeAssignee: Patsy Franklin <pfrankli>
Status: CLOSED ERRATA QA Contact: qe-baseos-tools
Severity: medium Docs Contact:
Priority: low    
Version: 6.0CC: bradbell, dpierce, erik-fedora, iboverma, jherrman, law, matt, mcermak, mnewsome, ovasik, riek, rvokal, susi.lehtola, tlavigne, tpelka, vchoudha
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: cmake-2.8.12.2-4.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The cmake packages have been upgraded to upstream version 2.8.12, which provides a number of bug fixes and enhancements over the previous version.
Story Points: ---
Clone Of:
: 1088669 (view as bug list) Environment:
Last Closed: 2014-10-14 03:10:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 1023566, 1056252, 611250, 752864, 883504, 896116, 949715, 1088669    

Description Orion Poplawski 2010-06-22 12:49:33 EDT
Description of problem:

There may be other issues, but I think it would be unfortunate if RHEL6 was stuck with cmake 2.6.X for it's lifetime.  I would think that now (before release) would be easiest time for a move to 2.8 to take place.
Comment 2 RHEL Product and Program Management 2010-06-22 13:13:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Radek Vokal 2010-06-22 16:46:05 EDT
(In reply to comment #0)
> Description of problem:
> 
> There may be other issues, but I think it would be unfortunate if RHEL6 was
> stuck with cmake 2.6.X for it's lifetime.  I would think that now (before
> release) would be easiest time for a move to 2.8 to take place.    

It's quite late in the game for any rebase in RHEL6. Can you please elaborate more on features we're missing with 2.6.x version?
Comment 4 Orion Poplawski 2010-06-22 18:45:52 EDT
Main addition that I'm aware of is much better support for other languages including Fortran.  It may not turn out to be a big deal, but I could also see projects dropping support for 2.6 as time goes on.  I'd be curious to know what in RHEL6 is using cmake, I wouldn't have thought it was that much.
Comment 11 Suzanne Yeghiayan 2011-01-06 17:20:02 EST
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated 
in the current release, Red Hat is unfortunately unable to  
address this request at this time.  This request has been 
proposed for the next release of Red Hat Enterprise Linux.
If you would like it considered as an exception in the 
current release, please ask your support representative.
Comment 12 RHEL Product and Program Management 2011-07-05 20:16:05 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 Orion Poplawski 2011-10-06 10:52:56 EDT
*** Bug 743910 has been marked as a duplicate of this bug. ***
Comment 14 Jonathan Underwood 2012-05-02 19:48:42 EDT
Any update on this? cmake 2.6 is considerably out of date at this point, and software is beginning to require 2.8. For example, this is preventing packaging of the Fenics project for EPEL.

Can we have a definitive answer - if RHEL is not going to rebase, then we can maybe start to look at a cmake28 package for EPEL.
Comment 15 Jonathan Underwood 2012-05-02 19:50:25 EDT
For info: CMake 2.8.0 was released in September 2009
Comment 16 Orion Poplawski 2012-05-03 00:23:28 EDT
Also, cmake does not affect the runtime for anything and is not a dependency for any non-devel package.
Comment 18 Jonathan Underwood 2012-05-07 20:28:21 EDT
I've generated a parallel installable cmake28 package for EL6 in the meantime, review request here:

https://bugzilla.redhat.com/show_bug.cgi?id=819678
Comment 19 Jeff Law 2014-02-03 11:22:51 EST
*** Bug 831346 has been marked as a duplicate of this bug. ***
Comment 20 Jeff Law 2014-02-03 11:23:58 EST
*** Bug 831345 has been marked as a duplicate of this bug. ***
Comment 21 Jeff Law 2014-02-03 11:28:25 EST
*** Bug 949713 has been marked as a duplicate of this bug. ***
Comment 26 errata-xmlrpc 2014-10-14 03:10:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1506.html