Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 611250 - FindGTK2.cmake module missing
FindGTK2.cmake module missing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cmake (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: 6.1
Assigned To: Patsy Franklin
qe-baseos-tools
: Reopened
Depends On: 606892
Blocks: 1056252
  Show dependency treegraph
 
Reported: 2010-07-04 09:32 EDT by Daniel Riek
Modified: 2014-10-14 03:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: cmake-2.8.12.2-2.el6
Doc Type: Bug Fix
Doc Text:
Previously, the FindGTK2.cmake module was missing from the cmake packages. As a consequence, building GTK2 applications failed. This update adds FindGTK2.cmake and GTK2 applications now build as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1506 normal SHIPPED_LIVE cmake bug fix and enhancement update 2014-10-13 21:22:34 EDT

  None (edit)
Description Daniel Riek 2010-07-04 09:32:56 EDT
Description of problem:
The FindGTK2.cmake module is missing from the cmake rpm, which means that building gtk2 apps fails.

Version-Release number of selected component (if applicable):
cmake-2.6.4-5.el6

How reproducible:
Always.

Steps to Reproduce:
1. Run cmake on a source tree using gtk2
2. Example is http://sourceforge.net/projects/opencpn/files/opencpn/2.1.0/OpenCPN-2.1.624a-Source.tar.gz/download
  
Actual results:
Watch cmake complain, that it can't find the FindGTK2.cmake module

Expected results:
Cmake to successfully configure the build tree

Additional info:
The missing module is available at: http://cmake-modules.googlecode.com/svn/trunk/Modules/GTK2/FindGTK2.cmake
Comment 2 Jaroslav Reznik 2010-07-06 03:24:21 EDT
FindGTK2 is not included in CMake 2.6 as shipped in RHEL 6. It's part of CMake 2.8 tarball - this will lead to rebase to 2.8 but it's too late to change buildsystem component in this phase of RHEL 6 development though it could be possible as 2.6 and 2.8 are compatible. See request to rebase CMake https://bugzilla.redhat.com/show_bug.cgi?id=606892. Rebase would fix this bug, so I'm closing this one as not a bug and redirecting to rebase one.
Comment 6 RHEL Product and Program Management 2011-01-07 10:35:55 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 10 RHEL Product and Program Management 2012-09-07 01:03:18 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 12 Orion Poplawski 2014-03-05 12:15:08 EST
FYI - cmake28 is available from Fedora EPEL.
Comment 15 errata-xmlrpc 2014-10-14 03:11:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1506.html

Note You need to log in before you can comment on or make changes to this bug.