Bug 620623

Summary: Packages with unresolved dependencies
Product: [Fedora] Fedora Reporter: MingtaoNiu <mniu>
Component: distributionAssignee: Bill Nottingham <notting>
Status: CLOSED ERRATA QA Contact: Bill Nottingham <notting>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: awilliam, dcantrell, dmalcolm, ivazqueznet, james.antill, jlaska, jonathansteffan, pfrields, rhe, rvokal, stickster, tcallawa
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-12 01:37:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 611009, 620944, 621286    
Bug Blocks: 611990    
Attachments:
Description Flags
error info when checking repoclosue none

Description MingtaoNiu 2010-08-03 02:55:55 UTC
Created attachment 436178 [details]
error info when checking repoclosue

Description of problem:
When I checked the dependencies of all packages, there were a few packages with
unresolved dependencies from myrepo in the output.
Also there was a unicodewarning.

Version-Release number of selected component (if applicable):

14-alpha-tc1-i386-DVD.iso

How reproducible:
100%

Steps to Reproduce:
1.mount the iso
2.Check the dependencies of all packages

Actual results:

/usr/lib/python2.6/site-packages/yum/packages.py:401: UnicodeWarning: Unicode
equal comparison failed to convert both arguments to Unicode - interpreting
them as being unequal
  if prcotuple in self.prco[prcotype]:
Repos looked at: 1
   myrepo
Num Packages in Repos: 2770
package: BackupPC-3.1.0-14.1.fc14.noarch from myrepo
  unresolved deps: 
     perl-suidperl
package: blueman-1.21-4.fc14.i686 from myrepo
  unresolved deps: 
     python(abi) = 0:2.6
package: enblend-4.0-4.fc13.i686 from myrepo
  unresolved deps: 
     libboost_filesystem.so.1.41.0
     libboost_system.so.1.41.0
package: gnome-dvb-daemon-0.1.20-1.fc14.i686 from myrepo
  unresolved deps: 
     python(abi) = 0:2.6
package: gnote-0.7.2-1.fc14.i686 from myrepo
  unresolved deps: 
     libboost_filesystem-mt.so.1.41.0
     libboost_system-mt.so.1.41.0
package: hugin-base-2010.0.0-3.fc14.i686 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.41.0
package: python-psyco-1.6-4.fc12.i686 from myrepo
  unresolved deps: 
     libpython2.6.so.1.0
     python(abi) = 0:2.6
package: totem-2.30.2-2.fc14.i686 from myrepo
  unresolved deps: 
     libpython2.6.so.1.0
package: wireshark-1.2.9-3.fc14.i686 from myrepo
  unresolved deps: 
     python(abi) = 0:2.6

Expected results:
   1.  Checking dependencies finished successfully
   2. There are no packages with unresolved dependencies from myrepo in the
output 

Additional info:

Comment 1 Dave Malcolm 2010-08-03 18:53:03 UTC
(In reply to comment #0)

[snip]

> package: BackupPC-3.1.0-14.1.fc14.noarch from myrepo
>   unresolved deps: 
>      perl-suidperl

Not python

> package: blueman-1.21-4.fc14.i686 from myrepo
>   unresolved deps: 
>      python(abi) = 0:2.6

This was bug 619945


> package: enblend-4.0-4.fc13.i686 from myrepo
>   unresolved deps: 
>      libboost_filesystem.so.1.41.0
>      libboost_system.so.1.41.0

Not python


> package: gnome-dvb-daemon-0.1.20-1.fc14.i686 from myrepo
>   unresolved deps: 
>      python(abi) = 0:2.6

gnome-dvb-daemon was bug 619942


> package: gnote-0.7.2-1.fc14.i686 from myrepo
>   unresolved deps: 
>      libboost_filesystem-mt.so.1.41.0
>      libboost_system-mt.so.1.41.0
> package: hugin-base-2010.0.0-3.fc14.i686 from myrepo
>   unresolved deps: 
>      libboost_thread-mt.so.1.41.0


Not python


> package: python-psyco-1.6-4.fc12.i686 from myrepo
>   unresolved deps: 
>      libpython2.6.so.1.0
>      python(abi) = 0:2.6

python-pysco is bug 620211


> package: totem-2.30.2-2.fc14.i686 from myrepo
>   unresolved deps: 
>      libpython2.6.so.1.0

This was bug 618791


> package: wireshark-1.2.9-3.fc14.i686 from myrepo
>   unresolved deps: 
>      python(abi) = 0:2.6

This was bug 619949

Comment 2 Paul W. Frields 2010-08-03 20:00:05 UTC
Newest gnote removes this problem:

$ koji latest-pkg --quiet dist-f14 gnote
gnote-0.7.2-2.fc14                        dist-f14              sundaram

BackupPC dependency problem looks to be solved in #611009:

$ koji latest-pkg --quiet dist-f14 BackupPC
BackupPC-3.1.0-15.fc14                    dist-f14              trasher

Only enblend looks to still have problems -- no new rebuild in months.

Comment 3 Paul W. Frields 2010-08-03 20:03:39 UTC
enblend problem is bug #620944

Comment 4 Jens Petersen 2010-08-04 01:59:59 UTC
I don't think this is an alpha blocker any more.

Is there a 2.7 tracker bug?

Comment 5 Dave Malcolm 2010-08-04 14:36:31 UTC
(In reply to comment #4)
> Is there a 2.7 tracker bug?

Two of them:

Bug 619913 (alias="Python27Rebuild") tracks packages needing to be rebuilt for Python 2.7

Bug 620817 (alias="Python27") tracks issues that relate to Python 2.7 (e.g. things in other packages that got broken by the 2.6->2.7 change, upgrade issues, etc).

Comment 6 James Laska 2010-08-04 16:49:52 UTC
The following media-kit repoclosure bugs are still present on 'test compose#2'.  These are valid F14Alpha blockers

# mount -o ro,loop /var/lib/libvirt/images/Fedora-14-x86_64-DVD.iso /media
# repoclosure --repofrompath myrepo,/media -a x86_64 --newest -t -r myrepo 
Added myrepo repo from /media
Reading in repository metadata - please wait....
Checking Dependencies
/usr/lib/python2.6/site-packages/yum/packages.py:401: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  if prcotuple in self.prco[prcotype]:
Repos looked at: 1
   myrepo
Num Packages in Repos: 2765
package: BackupPC-3.1.0-14.1.fc14.noarch from myrepo
  unresolved deps: 
     perl-suidperl

https://bugzilla.redhat.com/show_bug.cgi?id=611009

package: enblend-4.0-4.fc13.x86_64 from myrepo
  unresolved deps: 
     libboost_filesystem.so.1.41.0()(64bit)
     libboost_system.so.1.41.0()(64bit)

https://bugzilla.redhat.com/show_bug.cgi?id=620944

package: gnote-0.7.2-1.fc14.x86_64 from myrepo
  unresolved deps: 
     libboost_system-mt.so.1.41.0()(64bit)
     libboost_filesystem-mt.so.1.41.0()(64bit)

Appears to be resolved an pending in updates-testing (https://admin.fedoraproject.org/updates/gnote-0.7.2-2.fc14)

package: hugin-base-2010.0.0-3.fc14.x86_64 from myrepo
  unresolved deps: 
     libboost_thread-mt.so.1.41.0()(64bit)

Doesn't appear to be resolved yet.  Will find or file a bz and have it depends on this issue.

Comment 7 Dave Malcolm 2010-08-04 17:00:57 UTC
Editing component from "python" to "distribution"

Comment 8 John Poelstra 2010-08-05 16:44:13 UTC
What are the next steps and plans for fixing this bug?  Can someone please provide more information?

If this is in fact a blocker we can't compose the Fedora 14 Alpha Release Candidate today unless it is fixed.

Comment 9 Paul W. Frields 2010-08-05 17:20:07 UTC
I believe this bug can be closed, because all the dependent bugs remaining for boost rebuilds have been rebuilt and pushed to stable, which should fix those dep problems (BackupPC, enblend, gnote, and hugin).

The remaining problem is python-psyco which is reported by upstream to be incompatible with Python 2.7.  I don't know how to solve that problem, other than the "nuclear option" (?) of excluding it somehow from the compose/repo.

I'm clearing NEEDINFO because I think that answers for all the packages, but I'm not closing until the python-psyco question is resolved.  Dave?

Comment 10 James Laska 2010-08-05 18:54:03 UTC
Closing based on comment#9.   There are no more unresolved bugs depending on this.

Comment 11 He Rui 2010-08-06 10:06:23 UTC
(In reply to comment #9)
> I believe this bug can be closed, because all the dependent bugs remaining for
> boost rebuilds have been rebuilt and pushed to stable, which should fix those
> dep problems (BackupPC, enblend, gnote, and hugin).
> 
> The remaining problem is python-psyco which is reported by upstream to be
> incompatible with Python 2.7.  I don't know how to solve that problem, other
> than the "nuclear option" (?) of excluding it somehow from the compose/repo.
> 
> I'm clearing NEEDINFO because I think that answers for all the packages, but
> I'm not closing until the python-psyco question is resolved.  Dave?    

Confirmed remaining problem in python-psyco when testing F14-alpha-rc1-i386-DVD.iso:

package: python-psyco-1.6-4.fc12.i686 from myrepo
  unresolved deps: 
     libpython2.6.so.1.0
     python(abi) = 0:2.6


Change the status back to ASSIGNED.

Comment 12 James Laska 2010-08-06 13:00:48 UTC
(In reply to comment #11)
> Confirmed remaining problem in python-psyco when testing
> F14-alpha-rc1-i386-DVD.iso:
> 
> package: python-psyco-1.6-4.fc12.i686 from myrepo
>   unresolved deps: 
>      libpython2.6.so.1.0
>      python(abi) = 0:2.6
> 
> Change the status back to ASSIGNED.    

Ergh, I missed that one.  bug#620211 should have been linked to this issue.

Comment 13 Adam Williamson 2010-08-06 18:22:58 UTC
I have submitted an eclipse-pydev update:

https://admin.fedoraproject.org/updates/eclipse-pydev-1.5.9-2.fc14

this drops the dependency on python-psyco for now. The impact of this is that debugging Python will be slower (on 32-bit installs, psyco doesn't work on 64-bit anyway so the 64-bit build is not affected). However, everything should still work.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 14 James Laska 2010-08-09 20:27:29 UTC
eclipse-pydev is now in stable.  Marking this bug as ON_QA again, pending retest against RC#3.

Comment 15 Adam Williamson 2010-08-11 21:26:19 UTC
For RC3, the repoclosure test passed (see https://fedoraproject.org/wiki/Test_Results:Current_Installation_Test , QA:Testcase_Mediakit_Repoclosure entry in 'DVD.iso installation' section). Do we close this bug, take it off the blocker list, or what?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 16 Adam Williamson 2010-08-12 01:37:23 UTC
Discussed at today's go/no-go meeting. We agreed that, as there are no unresolved deps in the RC3 package set, the bug should be closed. It can be reopened (or a new bug opened) if dependency problems appear on RC4 or future composes.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers