Bug 631838

Summary: Publican should depend on kdesdk-utils rather than kdesdk
Product: [Fedora] Fedora EPEL Reporter: Gianluca Sforna <giallu>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: el5CC: jfearn, kevin, kms, mdehaan, mmcallis, petersen, publican-list, rdieter, r.landmann, stickster
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 443024 Environment:
Last Closed: 2010-11-21 23:48:01 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 432443, 443024    
Bug Blocks:    

Description Gianluca Sforna 2010-09-08 10:04:23 EDT
+++ This bug was initially created as a clone of Bug #443024 +++

The current publican SPEC file has a dependency on the kdesdk package for the
xml2pot and po2xml binaries.  This requires GNOME users to install the bulk of
the KDE system just to use Publican.  I have submitted a patch to create a
sub-package of kdesdk (443023).  The patch attached changes Publican to depend
on the new kdesdk-potools subpackage which means that GNOME user would only need
Publican, this new sub-package, and QT, to create documentation.

--- Additional comment from kms@passback.co.uk on 2008-04-18 04:32:03 EDT ---

Created attachment 302851 [details]
Patch to SPEC file to depend on kdesdk-potools rather than kdesdk

--- Additional comment from rdieter@math.unl.edu on 2008-04-18 08:20:15 EDT ---

In the meantime, instead of using
Requires: kdesdk
Consider using
Requires: %{_bindir}/xml2pot %{_bindir}/po2xml
instead (asap).

This should ensure things continue to work before and after any split is done 
in kdesdk (which should be coming soon, hopefully).

--- Additional comment from jfearn@redhat.com on 2008-04-20 23:49:21 EDT ---

Changed requires and buildrequires to: %{_bindir}/xml2pot %{_bindir}/po2xml

--- Additional comment from petersen@redhat.com on 2008-06-24 23:31:07 EDT ---

I still see "Requires: kdesdk" in both devel and F-9.

It can be replaced by kdesdk-utils for both of them or the above if you prefer.

--- Additional comment from jfearn@redhat.com on 2008-06-24 23:42:40 EDT ---

0.34, where this bug has been fixed, is still being baked.

--- Additional comment from stickster@gmail.com on 2008-07-13 11:35:29 EDT ---

This can be fixed in the current (F-8, F-9, devel) package CVS -- it's just a
specfile change and a new build and push.  It doesn't need to hang on 0.34 being
ready.  I'm happy to do it, if that helps.

--- Additional comment from updates@fedoraproject.org on 2008-07-14 22:53:14 EDT ---

publican-0.33-1.fc9 has been submitted as an update for Fedora 9

--- Additional comment from jfearn@redhat.com on 2008-07-14 23:20:24 EDT ---

Vote 1: https://admin.fedoraproject.org/updates/F9/pending/publican-0.33-1.fc9

Also built in devel and F8. However as kdesdk-utils is not available in F8 I did
not push it as an update.

--- Additional comment from jfearn@redhat.com on 2008-07-15 18:20:52 EDT ---

*** Bug 455412 has been marked as a duplicate of this bug. ***

--- Additional comment from updates@fedoraproject.org on 2008-07-17 10:16:41 EDT ---

publican-0.33-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 1 Kevin Kofler 2010-09-08 10:27:17 EDT
Uh, AFAIK, EL5 doesn't have the kdesdk-utils split (it was branched from FC6 and we made the split in F9) and is unlikely to get it.
Comment 2 Gianluca Sforna 2010-09-08 10:33:07 EDT
Doh. so I'm bound to install >100Mb worth of packages including qt, a sound server and other assorted stuff onto a headless server along with a publican, scary...
Comment 3 Jeff Fearn 2010-09-08 17:28:07 EDT
FWIW I wouldn't install the EPEL version, it is ancient and can't be updated in EPEL due to newer versions requiring updated RHEL5 packages.

In fact I will look in to the dead package process for EPEL4 and EPEL5 since this old version isn't being maintained and isn't compatible with the versions in Fedora or RHEL6.
Comment 4 Ruediger Landmann 2010-11-21 23:48:01 EST
As Jeff said, Publican has been unmaintainable for EPEL4 and EPEL5 for a long time now, so we've finally retired it from those branches.

Sorry, Gianluca, but we can't fix this for you :(
Comment 5 Gianluca Sforna 2010-11-22 02:33:03 EST
Unfortunate but that's ok. I hope there is some kind of plan to make publica available (and maintainable) in EPEL6 or RHEL6
Comment 6 Jeff Fearn 2010-11-22 02:48:24 EST
Hi Gianluca publican 2.1 shipped on RHEL6, adventurous souls should be able to build from trunk since there haven't been any dep changes ... yet :)