Bug 432443 - split out text utilities to a subpackage
split out text utilities to a subpackage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 443023 446046 (view as bug list)
Depends On:
Blocks: F9Target 443024 631838
  Show dependency treegraph
 
Reported: 2008-02-11 21:19 EST by Jens Petersen
Modified: 2010-09-08 10:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 09:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-02-11 21:19:20 EST
Description of problem:
kdesdk provides a number of commandline utilities that have no dependency
or qt or kde, but are used by some packages at buildtime, etc.
Since kdesdk and all its deps is huge it would be very nice if those
text utilities could all be moved to a separate subpackage.

Not sure on the best name: how about kdesdk-utilities?

Steps to Reproduce:
1. build a package which requires po2xml
  
Actual results:
need to BR: kdesdk

Expected results:
just BR a small package containing po2xml.

Additional info:
debian has poxml and Mandriva has kdesdk-po2xml.
Comment 1 Jens Petersen 2008-02-19 19:00:28 EST
I think this is the list of files in /usr/bin that do not depend on any kde libs:

for i in `rpm -ql kdesdk | grep /usr/bin`; do ldd $i | ( grep -q libkde $i ||
echo $i ) ; done 
Comment 2 Kevin Kofler 2008-04-18 06:07:22 EDT
*** Bug 443023 has been marked as a duplicate of this bug. ***
Comment 3 Rex Dieter 2008-04-18 08:34:52 EDT
I'll see about trying to make this happen today.

1.  I'm currently leaning toward naming this kdesdk-utils.  In the meantime, 
I'll continue to look for better pkg name alternatives (and precedents from 
other distros).

2.  It will initially include: 
po2xml
xml2pot
as required by publican.  We can consider adding other goodies, when/if it 
makes sense. 

Comment 4 Rex Dieter 2008-04-18 08:46:02 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=572081

* Fri Apr 18 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0.3-4
- utils: po2xml, xml2pot (#432443)
Comment 5 Rex Dieter 2008-04-18 09:31:18 EDT
mailed rel-eng for f9-final tagging.
Comment 6 Kevin Kofler 2008-05-12 07:11:57 EDT
*** Bug 446046 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.