Bug 443024 - Publican should depend on kdesdk-utils rather than kdesdk
Publican should depend on kdesdk-utils rather than kdesdk
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
: Reopened
: 455412 (view as bug list)
Depends On: 432443
Blocks: 631838
  Show dependency treegraph
 
Reported: 2008-04-18 04:32 EDT by Keith Sharp
Modified: 2010-11-23 23:19 EST (History)
6 users (show)

See Also:
Fixed In Version: 0.34
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 631838 (view as bug list)
Environment:
Last Closed: 2008-07-20 19:36:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to SPEC file to depend on kdesdk-potools rather than kdesdk (1.41 KB, patch)
2008-04-18 04:32 EDT, Keith Sharp
no flags Details | Diff

  None (edit)
Description Keith Sharp 2008-04-18 04:32:03 EDT
The current publican SPEC file has a dependency on the kdesdk package for the
xml2pot and po2xml binaries.  This requires GNOME users to install the bulk of
the KDE system just to use Publican.  I have submitted a patch to create a
sub-package of kdesdk (443023).  The patch attached changes Publican to depend
on the new kdesdk-potools subpackage which means that GNOME user would only need
Publican, this new sub-package, and QT, to create documentation.
Comment 1 Keith Sharp 2008-04-18 04:32:03 EDT
Created attachment 302851 [details]
Patch to SPEC file to depend on kdesdk-potools rather than kdesdk
Comment 2 Rex Dieter 2008-04-18 08:20:15 EDT
In the meantime, instead of using
Requires: kdesdk
Consider using
Requires: %{_bindir}/xml2pot %{_bindir}/po2xml
instead (asap).

This should ensure things continue to work before and after any split is done 
in kdesdk (which should be coming soon, hopefully).
Comment 3 Jeff Fearn 2008-04-20 23:49:21 EDT
Changed requires and buildrequires to: %{_bindir}/xml2pot %{_bindir}/po2xml
Comment 4 Jens Petersen 2008-06-24 23:31:07 EDT
I still see "Requires: kdesdk" in both devel and F-9.

It can be replaced by kdesdk-utils for both of them or the above if you prefer.
Comment 5 Jeff Fearn 2008-06-24 23:42:40 EDT
0.34, where this bug has been fixed, is still being baked.
Comment 6 Paul W. Frields 2008-07-13 11:35:29 EDT
This can be fixed in the current (F-8, F-9, devel) package CVS -- it's just a
specfile change and a new build and push.  It doesn't need to hang on 0.34 being
ready.  I'm happy to do it, if that helps.
Comment 7 Fedora Update System 2008-07-14 22:53:14 EDT
publican-0.33-1.fc9 has been submitted as an update for Fedora 9
Comment 8 Jeff Fearn 2008-07-14 23:20:24 EDT
Vote 1: https://admin.fedoraproject.org/updates/F9/pending/publican-0.33-1.fc9

Also built in devel and F8. However as kdesdk-utils is not available in F8 I did
not push it as an update.
Comment 9 Jeff Fearn 2008-07-15 18:20:52 EDT
*** Bug 455412 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2008-07-17 10:16:41 EDT
publican-0.33-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.