Bug 637495

Summary: Anaconda loses InstallMedia repo.
Product: [Fedora] Fedora Reporter: Steven Haigh <netwiz>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: anaconda-maint-list, clydekunkel7734, harald, jlaska, jonathan, rhe, robatino, tcallawa, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: udev-161-4.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-13 08:47:23 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 641108    
Attachments:
Description Flags
anaconda.log
none
anaconda.syslog
none
anaconda.storage.log
none
anaconda-logs.tgz (/tmp/*log*)
none
output of dmesg from DVD boot
none
output of 'strace /lib/udev/cdrom_id --debug /dev/sr0' none

Description Steven Haigh 2010-09-26 03:50:49 EDT
Description of problem:
When trying to install onto an EeePC 1005P with USB DVD drive, I attempted to boot from the DVD and complete an install as per normal from the RC3 DVD.

When it got to the repo selection screen, the only repos that could be selected were internet based repos - even though the full install was available on the DVD that was booted from.

How reproducible:
Every install.

Steps to Reproduce:
1. Boot from DVD in USB DVD drive.
2. Proceed with install.

Will attach all anaconda logs for reference.
Comment 1 Steven Haigh 2010-09-26 03:51:28 EDT
Created attachment 449694 [details]
anaconda.log
Comment 2 Steven Haigh 2010-09-26 03:52:06 EDT
Created attachment 449695 [details]
anaconda.syslog
Comment 3 Steven Haigh 2010-09-26 03:54:10 EDT
Created attachment 449696 [details]
anaconda.storage.log
Comment 4 Steven Haigh 2010-09-26 03:54:53 EDT
Please let me know if any additional information is required.
Comment 5 Chris Lumens 2010-09-27 10:40:11 EDT
When you get to the boot menu on the DVD, can you remove the following argument:

stage2=hd:LABEL=Fedora

and see if anaconda figures it out correctly?
Comment 6 Clyde E. Kunkel 2010-09-27 10:56:00 EDT
I tried a clean install from an USB HP DVD reader/writer using the beta gold DVD and did not encounter any problems.  Did not specify any addition parms on the kernel cmd line.
Comment 7 Steven Haigh 2010-09-28 13:57:01 EDT
Tried removing stage2=hd:LABEL=Fedora from the boot lines on the DVD with no difference. Only internet repos were visible.
Comment 8 James Laska 2010-10-04 09:45:24 EDT
I think this is related to (or a duplicate of) bug#627789.  Can you retry your test, and boot with the option "updates=http://bcl.fedorapeople.org/updates/627789.img"

Let me know if that resolves the reported problem.  If so, please CLOSE DUPLICATE this issue against 627789.  Thanks!
Comment 9 James Laska 2010-10-04 14:08:55 EDT
(In reply to comment #8)
> Let me know if that resolves the reported problem.  If so, please CLOSE
> DUPLICATE this issue against 627789.  Thanks!

I stand corrected, this is unrelated to that problem.  There is something specific to this USB DVD install case where the DVD is used for stage2 (install.img), but then it is no longer seen when it comes time for 'reposetup'

According to clumens and bcl, "no ID_FS_TYPE for sr0" may indicate that udev has somehow eaten information about this drive?

The attached /tmp/storage.log also indicates a similar problem 

> 04:01:15,620 DEBUG storage: no type or existing type for sr0, bailing

Not sure if the following udevadm information is helpful ...

# udevadm info --query=all --name=sr0
P: /devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1:1.0/host4/target4:0:0/4:0:0:0/block/sr0
N: sr0
S: block/11:0
S: scd0
S: disk/by-id/usb-HL-DT-ST_DVDRAM_GSA-4084N-0:0
S: disk/by-path/pci-0000:00:1d.7-usb-0:1:1.0-scsi-0:0:0:0
E: UDEV_LOG=3
E: DEVPATH=/devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1:1.0/host4/target4:0:0/4:0:0:0/block/sr0
E: SUBSYSTEM=block
E: DEVNAME=sr0
E: ID_CDROM=1
E: ID_CDROM_CD_R=1
E: ID_CDROM_CD_RW=1
E: ID_CDROM_DVD=1
E: ID_CDROM_DVD_R=1
E: ID_CDROM_DVD_RAM=1
E: ID_CDROM_MEDIA=1
E: ID_VENDOR=HL-DT-ST
E: ID_VENDOR_ENC=HL-DT-ST
E: ID_VENDOR_ID=05e3
E: ID_MODEL=DVDRAM_GSA-4084N
E: ID_MODEL_ENC=DVDRAM\x20GSA-4084N
E: ID_MODEL_ID=0701
E: ID_REVISION=KQ09
E: ID_SERIAL=HL-DT-ST_DVDRAM_GSA-4084N-0:0
E: ID_TYPE=cd
E: ID_INSTANCE=0:0
E: ID_BUS=usb
E: ID_USB_INTERFACES=:080650:
E: ID_USB_INTERFACE_NUM=00
E: ID_USB_DRIVER=usb-storage
E: ID_PATH=pci-0000:00:1d.7-usb-0:1:1.0-scsi-0:0:0:0
E: ANACBIN=/usr/sbin
E: MAJOR=11
E: MINOR=0
E: DEVTYPE=disk
E: DEVLINKS=/dev/block/11:0 /dev/scd0 /dev/disk/by-id/usb-HL-DT-ST_DVDRAM_GSA-4084N-0:0 /dev/disk/by-path/pci-0000:00:1d.7-usb-0:1:1.0-scsi-0:0:0:0
E: TAGS=:udev-acl:
Comment 10 James Laska 2010-10-04 14:12:03 EDT
(In reply to comment #5)
> When you get to the boot menu on the DVD, can you remove the following
> argument:
> 
> stage2=hd:LABEL=Fedora
> 
> and see if anaconda figures it out correctly?

14:11:22   CRCinAU: it works exactly the same as having it on there
14:11:34   CRCinAU: ie only http repos are listed
Comment 11 James Laska 2010-10-04 14:13:19 EDT
Additional information, running 'blkid' by hand on the installing system, it doesn't see sr0 either.

# blkid 
/dev/loop0: TYPE="squashfs" 
/dev/sda1: UUID="52b9e00f-32d1-4d9a-9fb8-acad6a97398c" TYPE="ext4" 
/dev/sda2: UUID="ecb3ebb9-d3e4-448e-a062-be8143c1a74d" TYPE="swap" 
/dev/sda3: UUID="8c9d518c-d3a6-4f77-8f27-a131d27a69ac" TYPE="xfs"
Comment 12 James Laska 2010-10-04 14:53:07 EDT
Created attachment 451498 [details]
anaconda-logs.tgz (/tmp/*log*)

Yay!  I've duplicated this install issue on a nearby system using a USB CD-ROM.  The good news, the install continues using the HTTP repos, the bad news is that it defeats the purpose of a CD/DVD install since it requires networking.  I suspect this is specific to USB CD/DVD installs, as regular CD/DVD installs appear to work without error.

Attaching a tarball containing the following log information.

# tar -ztvf /tmp/anaconda-logs.tgz 
-rw-r--r-- root/root     65283 2010-10-04 14:48 tmp/X.log
-rw-r--r-- root/root      9374 2010-10-04 14:47 tmp/anaconda.log
-rw-r--r-- root/root       660 2010-10-04 14:49 tmp/blkid.log
-rw-r--r-- root/root      2386 2010-10-04 14:46 tmp/ifcfg.log
-rw-r--r-- root/root     10561 2010-10-04 14:42 tmp/program.log
-rw-r--r-- root/root    131372 2010-10-04 14:42 tmp/storage.log
-rw-r--r-- root/root     75317 2010-10-04 14:46 tmp/syslog
-rw-r--r-- root/root      2114 2010-10-04 14:49 tmp/udevadm.log
-rw-r--r-- root/root      1396 2010-10-04 14:47 tmp/yum.log
Comment 13 James Laska 2010-10-05 09:46:33 EDT
Adding harald for expertise on udev.  

Summary: USB CD/DVD installs correctly boot and transition to stage2, but the package repo on the CD/DVD isn't available during package install.  The CD/DVD is available to mount manually from tt2, but doesn't show up when running 'blkid'. 'blkid'?  

See comment#9 for thoughts from clumens regarding the message "no ID_FS_TYPE for sr0"
Comment 14 Harald Hoyer 2010-10-05 09:51:06 EDT
is anaconda doing a chroot? if yes, then the cdrom must also be mounted in the new chroot.
Comment 15 Harald Hoyer 2010-10-05 09:53:56 EDT
cdrom_id uses /proc/self/mountinfo, and if the cdrom is not found there, then it assumes the cdrom is not mounted. It then tries to open the cdrom with O_EXCL, which fails with -EBUSY for a mounted cdrom. If the cdrom is found in /proc/self/mountinfo, cdrom_id does not use O_EXCL.
Comment 16 James Laska 2010-10-05 10:45:59 EDT
(In reply to comment #14)
> is anaconda doing a chroot? if yes, then the cdrom must also be mounted in the
> new chroot.

(In reply to comment #14)
> is anaconda doing a chroot? if yes, then the cdrom must also be mounted in the
> new chroot.

I don't think stage#2 anaconda runs in a chroot.

sh-4.1# ps -wef | grep anaconda
root       538    99  0 14:29 tty1     00:00:05 /usr/bin/python /usr/bin/anaconda --stage2 cdrom:///dev/sr0:/mnt/stage2 --graphical --selinux
root       577   538  0 14:30 tty1     00:00:00 /usr/bin/python /usr/bin/anaconda --stage2 cdrom:///dev/sr0:/mnt/stage2 --graphical --selinux
root       693   680  0 14:43 pts/0    00:00:00 grep anaconda

sh-4.1# ls -ltd /proc/{538,577}/cwd
lrwxrwxrwx. 1 root root 0 Oct  5 14:44 /proc/577/cwd -> /
lrwxrwxrwx. 1 root root 0 Oct  5 14:43 /proc/538/cwd -> /

(In reply to comment #15)
> cdrom_id uses /proc/self/mountinfo, and if the cdrom is not found there, then
> it assumes the cdrom is not mounted. It then tries to open the cdrom with
> O_EXCL, which fails with -EBUSY for a mounted cdrom. If the cdrom is found in
> /proc/self/mountinfo, cdrom_id does not use O_EXCL.

sh-4.1# cat /proc/self/mountinfo 
1 1 0:1 / / rw,relatime - rootfs rootfs rw
16 1 0:3 / /proc rw,relatime - proc /proc rw
17 1 0:16 / /dev rw,relatime - tmpfs /dev rw,seclabel
18 17 0:10 / /dev/pts rw,relatime - devpts /dev/pts rw,seclabel,mode=600,ptmxmode=000
19 1 0:17 / /sys rw,relatime - sysfs /sys rw,seclabel
20 1 0:18 / /tmp rw,relatime - tmpfs none rw,seclabel,size=256000k
21 1 11:0 / /mnt/stage2 ro,relatime - iso9660 /dev/sr0 ro
22 1 7:0 / /mnt/runtime ro,relatime - squashfs /dev/loop0 ro
23 1 0:13 / /selinux rw,relatime - selinuxfs /selinux rw
Comment 17 James Laska 2010-10-05 11:17:55 EDT
With Harald's help, we determined that F-14-Beta and F-13 + udev-153-4.fc13 both experience the following problem ...

# /lib/udev/cdrom_id --debug /dev/sr1
main: probing: '/dev/sr1'
cd_inquiry: INQUIRY: [TEAC    ][CD-210PU        ][10A6]
info_scsi_cmd_err: GET CONFIGURATION failed with SK=5h/ASC=20h/ACQ=00h
cd_profiles: drive is pre-MMC2 and does not support 46h get configuration command
cd_profiles: trying to work around the problem
info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h
cd_profiles_old_mmc: no current profile, assuming no media
ID_CDROM=1
ID_CDROM_MRW=1
ID_CDROM_MRW_W=1
ID_CDROM_MEDIA=1

Harald identified a recent upstream udev patch intended to work with buggy/quirky optical devices (see http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=678df8a461c7573bf423a39be383bc7b70d943df).

I tested an updated cdrom_id binary built with that patch on my F-13 system, and it appears to properly identify the optical device.

# /tmp/cdrom_id --debug /dev/sr1
main: probing: '/dev/sr1'
cd_inquiry: INQUIRY: [TEAC    ][CD-210PU        ][10A6]
info_scsi_cmd_err: GET CONFIGURATION failed with SK=5h/ASC=20h/ACQ=00h
cd_profiles: drive is pre-MMC2 and does not support 46h get configuration command
cd_profiles: trying to work around the problem
info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h
cd_profiles_old_mmc: no current profile, but disc is present; assuming CD-ROM
cd_media_toc: READ TOC: len: 20
cd_media_toc: track=1 info=0x4(data) start_block=0
cd_media_toc: last track 1 starts at block 0
info_scsi_cmd_err: READ DISC INFORMATION failed with SK=5h/ASC=20h/ACQ=00h
ID_CDROM=1
ID_CDROM_MRW=1
ID_CDROM_MRW_W=1
ID_CDROM_MEDIA=1
ID_CDROM_MEDIA_CD=1
ID_CDROM_MEDIA_TRACK_COUNT_DATA=1


Steven, on the installing F-14 system where you boot the USB DVD drive, can you run the following command ...

# /lib/udev/cdrom_id --debug /dev/sr0
Comment 18 Fedora Update System 2010-10-05 11:18:31 EDT
udev-161-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/udev-161-3.fc14
Comment 19 Steven Haigh 2010-10-05 11:58:12 EDT
(In reply to comment #17)
> Steven, on the installing F-14 system where you boot the USB DVD drive, can you
> run the following command ...
> 
> # /lib/udev/cdrom_id --debug /dev/sr0

# /lib/udev/cdrom_id --debug /dev/sr0
main: probing: '/dev/sr0'
cd_inquiry: INQUIRY: [HL-DT-ST][DVDRAM GSA-4084N][KQ09]
info_scsi_cmd_err: GET CONFIGURATION failed
ID_CDROM=1
ID_CDROM_CD_R=1
ID_CDROM_CD_RW=1
ID_CDROM_DVD=1
ID_CDROM_DVD_R=1
ID_CDROM_DVD_RAM=1
ID_CDROM_MEDIA=1
Comment 20 Harald Hoyer 2010-10-05 12:41:05 EDT
(In reply to comment #19)

> info_scsi_cmd_err: GET CONFIGURATION failed

I think there is some information missing here. The error message should be something like:

GET CONFIGURATION failed with SK=xxx/ASC=xxx/ACQ=xxxx

This could help us to see why it is failing.
Comment 21 Steven Haigh 2010-10-05 12:44:48 EDT
My complete SSH connection to this system is:

$ ssh root@10.1.1.175
The authenticity of host '10.1.1.175 (10.1.1.175)' can't be established.
RSA key fingerprint is 6a:25:34:58:20:be:4a:98:98:5b:e8:c6:75:3e:50:de.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '10.1.1.175' (RSA) to the list of known hosts.
[anaconda root@localhost ~]# /lib/udev/cdrom_id --debug /dev/sr0
main: probing: '/dev/sr0'
cd_inquiry: INQUIRY: [HL-DT-ST][DVDRAM GSA-4084N][KQ09]
info_scsi_cmd_err: GET CONFIGURATION failed
ID_CDROM=1
ID_CDROM_CD_R=1
ID_CDROM_CD_RW=1
ID_CDROM_DVD=1
ID_CDROM_DVD_R=1
ID_CDROM_DVD_RAM=1
ID_CDROM_MEDIA=1
[anaconda root@localhost ~]#
Comment 22 Harald Hoyer 2010-10-05 12:51:47 EDT
Hmm, ok, so it fails with "-1" ... without any more informational scsi error
Comment 23 Steven Haigh 2010-10-05 13:00:56 EDT
Created attachment 451726 [details]
output of dmesg from DVD boot

Added output of dmesg from booting off the DVD to repo selection stage.
Comment 24 Steven Haigh 2010-10-05 13:08:16 EDT
Not sure if this is helpful, but for I've provided it for completeness...

[anaconda root@localhost ~]# cat /proc/self/mountinfo
1 1 0:1 / / rw,relatime - rootfs rootfs rw
16 1 0:3 / /proc rw,relatime - proc /proc rw
17 1 0:16 / /dev rw,relatime - tmpfs /dev rw,seclabel
18 17 0:10 / /dev/pts rw,relatime - devpts /dev/pts rw,seclabel,gid=5,mode=620,ptmxmode=000
19 1 0:17 / /sys rw,relatime - sysfs /sys rw,seclabel
20 1 0:18 / /tmp rw,relatime - tmpfs none rw,seclabel,size=256000k
21 1 11:0 / /mnt/stage2 ro,relatime - iso9660 /dev/sr0 ro
22 1 7:0 / /mnt/runtime ro,relatime - squashfs /dev/loop0 ro
23 1 0:13 / /selinux rw,relatime - selinuxfs /selinux rw
24 1 8:3 / /mnt/sysimage rw,relatime - xfs /dev/sda3 rw,seclabel,attr2,noquota
25 24 8:1 / /mnt/sysimage/boot rw,relatime - ext4 /dev/sda1 rw,seclabel,barrier=1,data=ordered
26 24 0:16 / /mnt/sysimage/dev rw,relatime - tmpfs /dev rw,seclabel
27 26 0:10 / /mnt/sysimage/dev/pts rw,relatime - devpts /dev/devpts rw,seclabel,gid=5,mode=620,ptmxmode=000
28 26 0:19 / /mnt/sysimage/dev/shm rw,relatime - tmpfs /dev/tmpfs rw,seclabel
29 24 0:3 / /mnt/sysimage/proc rw,relatime - proc /dev/proc rw
30 24 0:17 / /mnt/sysimage/sys rw,relatime - sysfs /dev/sysfs rw,seclabel
[anaconda root@localhost ~]#
Comment 25 Steven Haigh 2010-10-05 13:23:42 EDT
Created attachment 451734 [details]
output of 'strace /lib/udev/cdrom_id --debug /dev/sr0'

Attached output of 'strace /lib/udev/cdrom_id --debug /dev/sr0'

Also, the following was seen in dmesg when plugging in this USB DVD drive:

usb 1-3: new high speed USB device using ehci_hcd and address 4
usb 1-3: New USB device found, idVendor=05e3, idProduct=0701
usb 1-3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
usb 1-3: Product: USB TO IDE
Initializing USB Mass Storage driver...
usb-storage 1-3:1.0: Quirks match for vid 05e3 pid 0701: 520
scsi4 : usb-storage 1-3:1.0
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
scsi 4:0:0:0: CD-ROM            HL-DT-ST DVDRAM GSA-4084N KQ09 PQ: 0 ANSI: 0
sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 4:0:0:0: Attached scsi CD-ROM sr0
sr 4:0:0:0: Attached scsi generic sg1 type 5
Comment 26 Steven Haigh 2010-10-05 15:06:06 EDT
Installed udev-161-3.fc14 from http://koji.fedoraproject.org/koji/buildinfo?buildID=199008

Same output from cdrom_id. Interestingly, on a working F14 install, the DVD drive does not get auto-mounted in gnome. Probably the same root cause as everything else, but I thought it would be worth mentioning as well.
Comment 27 James Laska 2010-10-05 15:57:10 EDT
When testing udev-161-3.fc14 on an installed F-14 system, it allows GNOME to see the optical USB CD-ROM device I was attempting to install from in comment#17.  I'm attempting to create F-14 ISO media with the updated udev package to confirm if this resolves the installer issue for me.

Harald, it seems that the failures of Steven's optical USB DVD drive might be different.  How would you like to proceed with the originally reported issue?
Comment 28 Fedora Update System 2010-10-05 17:49:58 EDT
udev-161-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/udev-161-3.fc14
Comment 29 Steven Haigh 2010-10-06 18:33:55 EDT
Just to confirm, udev-161-3.fc14 does not seem to solve this issue.
Comment 30 James Laska 2010-10-07 08:04:25 EDT
(In reply to comment #27)
> Harald, it seems that the failures of Steven's optical USB DVD drive might be
> different.  How would you like to proceed with the originally reported issue?

Harald ... what are your thoughts?  It seems the fix resolves the issue for my USB CD-ROM drive, but the originally reported USB DVD drive issue remains.

Would you like me to clone this into a new bug to continue working the USB-DVD drive failure?
Comment 31 Steven Haigh 2010-10-07 08:14:50 EDT
(In reply to comment #30)
> Harald ... what are your thoughts?  It seems the fix resolves the issue for my
> USB CD-ROM drive, but the originally reported USB DVD drive issue remains.

James, Out of interest, when you have udev-161-3 installed, does the DVD/CD drive appear in gnome automatically? I found that although it is not seen within gnome, when plugging the drive in I could manually mount it via: mount /dev/cdrom /path/to/mount and access the drive as per normal.

Also, did you manage (or is it possible) to do an update image for the install process that I might be able to test out for the installer?
Comment 32 Harald Hoyer 2010-10-07 08:44:59 EDT
(In reply to comment #29)
> Just to confirm, udev-161-3.fc14 does not seem to solve this issue.

If you have x86_64, can you run:
http://people.redhat.com/harald/downloads/udev/cdrom_id

with "--debug" ?
Comment 33 Steven Haigh 2010-10-07 08:49:21 EDT
I just booted up an F13 live CD - where everything works as it should.

Interestingly:
[liveuser@localhost ~]$ /lib/udev/cdrom_id --debug /dev/sr0
main: probing: '/dev/sr0'
cd_inquiry: INQUIRY: [HL-DT-ST][DVDRAM GSA-4084N][KQ09]
info_scsi_cmd_err: GET CONFIGURATION failed
ID_CDROM=1
ID_CDROM_CD_R=1
ID_CDROM_CD_RW=1
ID_CDROM_DVD=1
ID_CDROM_DVD_R=1
ID_CDROM_DVD_RAM=1
ID_CDROM_MRW=1
ID_CDROM_MRW_W=1
ID_CDROM_MEDIA=1
[liveuser@localhost ~]$ 

Sadly, I only have i686 on this system. Apparently it is capable of x86_64, however with only 1Gb of RAM, its not really worth running.
Comment 34 James Laska 2010-10-07 09:35:22 EDT
We discussed on IRC, but responding here for completeness 

(In reply to comment #31)
> (In reply to comment #30)
> > Harald ... what are your thoughts?  It seems the fix resolves the issue for my
> > USB CD-ROM drive, but the originally reported USB DVD drive issue remains.
> 
> James, Out of interest, when you have udev-161-3 installed, does the DVD/CD
> drive appear in gnome automatically? I found that although it is not seen
> within gnome, when plugging the drive in I could manually mount it via: mount
> /dev/cdrom /path/to/mount and access the drive as per normal.

Yes, the good news was that with udev-161-3, the USB CD drive appeared in GNOME/nautilus and was accessible without requiring any command-line access.  This was not the case prior to the updated udev package.

> Also, did you manage (or is it possible) to do an update image for the install
> process that I might be able to test out for the installer?

I created updated ISO images for test the other day, but they failed to boot.  I'm still getting familiar with creating ISO images myself.  I'll try again shortly.
Comment 37 Fedora Update System 2010-10-07 15:53:21 EDT
udev-161-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update udev'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/udev-161-4.fc14
Comment 38 James Laska 2010-10-12 16:15:30 EDT
I confirmed that this fixed my USB CD-ROM issue using the ISO's posted for the F-14 Pre-RC acceptance test milestone (http://serverbeach1.fedoraproject.org/pub/alt/stage/14.TC1/).

I'd still like to see Steven's test results using the images above (or the official F-14-Final TC1 ISOs).
Comment 39 Fedora Update System 2010-10-13 08:47:17 EDT
udev-161-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.