Bug 627789 - Error setting up repository - 16, Device busy
Error setting up repository - 16, Device busy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Reopened
: 634940 636826 637630 638788 639809 (view as bug list)
Depends On:
Blocks: F14AnacondaBlocker
  Show dependency treegraph
 
Reported: 2010-08-26 20:35 EDT by Brian Lane
Modified: 2013-01-10 01:11 EST (History)
17 users (show)

See Also:
Fixed In Version: anaconda-14.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 12:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda log up to error dialog (52.00 KB, text/plain)
2010-09-24 14:24 EDT, Michael Schwendt
no flags Details
logs (383.19 KB, text/plain)
2010-09-24 14:24 EDT, Brian Lane
no flags Details

  None (edit)
Description Brian Lane 2010-08-26 20:35:31 EDT
Use livecd-iso-to-disk to write a boot.iso to USB flash drive.

Gets to partitioning, setup grub, then throws up a dialog saying Error setting up repository - 16, Device busy. Hit ok and a blank repe edit dialog is shown. Hit cancel and it then finds the correct repositories and proceeds with the install.
Comment 1 Brian Lane 2010-09-03 12:20:30 EDT
Problem was a race between unmounting the iso and deactivating the loopback. mount can now handle mounting iso's with loop without needing losetup.
Comment 2 Brian Lane 2010-09-18 14:34:01 EDT
*** Bug 634940 has been marked as a duplicate of this bug. ***
Comment 3 Hedayat Vatankhah 2010-09-20 13:26:36 EDT
Still persist in Beta RC2 and the same error (Device or resource Busy).
Comment 4 Brian Lane 2010-09-20 14:22:38 EDT
Adding as a F14Blocker, this prevents you from using livecd-iso-to-disk to make usb install media with non-live-cd iso's as covered by 3.2.2.1.2. Making Fedora USB Media with livecd-tools
Comment 5 Brian Lane 2010-09-20 14:59:08 EDT
(In reply to comment #4)
> Adding as a F14Blocker, this prevents you from using livecd-iso-to-disk to make
> usb install media with non-live-cd iso's as covered by 3.2.2.1.2. Making Fedora
> USB Media with livecd-tools

I meant F14Beta, not F14Blocker
Comment 6 Adam Williamson 2010-09-20 17:46:27 EDT
jlaska and I agree that this is at least nice-to-have, though we're not sure about blockeriness. Please include the fix in the next anaconda build for Beta. Thanks!
Comment 7 Andre Robatino 2010-09-20 20:16:00 EDT
This bug is not mentioned in the list of bugs fixed in the latest anaconda build:

https://admin.fedoraproject.org/updates/anaconda-14.17.4-1.fc14

It appears to be the only bug blocking the Beta at the moment (if I understand the criteria).
Comment 8 Adam Williamson 2010-09-20 20:21:01 EDT
yeah, it appears the fix was missed (intentionally or not we're not sure). this is not an AcceptedBlocker, though, and jlaska and I provisionally classed it as a nice-to-have.
Comment 9 Hedayat Vatankhah 2010-09-21 02:20:23 EDT
BTW, It'll block F14 (release) since it prevents hard disk install.
Comment 10 Chris Lumens 2010-09-22 12:13:41 EDT
Log files would always be nice.
Comment 11 Brian Lane 2010-09-22 13:27:51 EDT
IIRC it doesn't log anything (or if it does, nothing useful). Next time I hit it I'll look to make sure.
Comment 12 James Laska 2010-09-22 16:10:04 EDT
(In reply to comment #9)
> BTW, It'll block F14 (release) since it prevents hard disk install.

Note, I completed a hard disk ISO install several times on F-14-Beta without trouble.  This issue doesn't appear to block that installation case.
Comment 13 Hedayat Vatankhah 2010-09-22 16:19:20 EDT
Look at bug #634940. It just didn't work from Fedora Alpha to Beta RC2 for me.
Comment 14 Adam Williamson 2010-09-22 17:14:06 EDT
This was discussed at the go/no-go meeting today. We have no specific criteria covering iso-to-usb functionality, but we discussed it on merit, and agreed it wasn't a Beta blocker, though we may wish to make it a Final blocker. Putting on the final blocker list for further review.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Chris Lumens 2010-09-23 10:19:34 EDT
*** Bug 636826 has been marked as a duplicate of this bug. ***
Comment 16 Michael Schwendt 2010-09-23 14:03:17 EDT
This is what had hit me with F14 RC3 i386. After the "Device or resource busy" dialog, the installer automatically enabled a stale http base repo with old packages, and I didn't pay attention to that or the actual package installation step.
Comment 17 James Laska 2010-09-24 13:02:04 EDT
(In reply to comment #16)
> This is what had hit me with F14 RC3 i386. After the "Device or resource busy"
> dialog, the installer automatically enabled a stale http base repo with old
> packages, and I didn't pay attention to that or the actual package installation
> step.

Are you able to upload /tmp/anaconda.log when you encounter this error?
Comment 18 Michael Schwendt 2010-09-24 14:24:10 EDT
Created attachment 449481 [details]
Anaconda log up to error dialog

Not sure that's helpful as the last lines don't tell anything about the loop-mounted image.
Comment 19 Brian Lane 2010-09-24 14:24:15 EDT
Created attachment 449482 [details]
logs
Comment 20 Brian Lane 2010-09-24 14:57:50 EDT
This is fixed in commits 7fefb17c908c1bb6b0fbac1daddc770855d2d568 and 11c71a20afc87d5a1c43ed56c281cfe30bdfe6c6, it just barely missed making it into Beta, but should be included in the final release.
Comment 21 James Laska 2010-09-27 09:58:59 EDT
For anything hitting this problem in F-14-Beta, bcl has created an updates.img to work around this problem.  The image is available at http://bcl.fedorapeople.org/updates/627789.img

For information on using an updates.img, please see https://fedoraproject.org/wiki/Anaconda/Updates
Comment 22 Chris Lumens 2010-09-27 10:08:10 EDT
*** Bug 637630 has been marked as a duplicate of this bug. ***
Comment 23 Hedayat Vatankhah 2010-09-27 18:06:44 EDT
Seems to be fixed for me (however, if you go forward and them come back and then try to go forward again, it says "error mounting an already mounted iso" during a hard disk installation, but its a different bug).
Comment 24 Hedayat Vatankhah 2010-09-27 21:22:38 EDT
Well, I was wrong! When I run the installer using KVM on my system, the error doesn't appear and I can select the packages to install. But when I run the installer after boot, I still receive the "Device or resource busy" error before the repository selection dialog.
(I've put the updated image file in the images directory in hard disk beside F14 beta RC3 iso. I put 2 copies, one with 627789.img name and another copy with update.img name)
Comment 25 Hedayat Vatankhah 2010-09-27 21:36:02 EDT
Oops, sorry. I renamed update.img to updates.img and made sure that it is really applied during installer bootup.
This time, instead of the "Device or resource busy" error I got an exception! But I didn't saved the exception in a proper place. I'll reproduce the error and attach the exception in a few hours.
Comment 26 He Rui 2010-09-28 01:52:20 EDT
I encountered this bug when installing F14-beta-rc3 with repo=nfsiso: (the nfs directory contained multiple isos). 

After I applied the updates image on comment#21, I can retrieve the repo successfully.
Comment 27 A.J. Werkman 2010-09-28 10:36:34 EDT
With updates.img no bug for me anymore.
Comment 28 Hedayat Vatankhah 2010-09-28 11:03:30 EDT
I tried again and this time the exception didn't occur. Anyway, at least the "Device or resource busy" bug is solved for me too.
Comment 29 Chris Lumens 2010-09-30 09:59:15 EDT
*** Bug 638788 has been marked as a duplicate of this bug. ***
Comment 30 Michael Schwendt 2010-09-30 13:54:34 EDT
The mentioned updates.img fixes this.
Comment 31 Tom Horsley 2010-09-30 17:38:01 EDT
The updates.img did indeed fix my problem from bug 638788.
Comment 32 Chris Lumens 2010-10-04 09:57:50 EDT
*** Bug 639809 has been marked as a duplicate of this bug. ***
Comment 33 John Poelstra 2010-10-06 17:17:12 EDT
Is there an official build and bodhi update that addresses this issue?
Comment 34 Adam Williamson 2010-10-06 17:44:45 EDT
we have the acceptance test run due tomorrow: it would be good to have anaconda 14.18 available to do that test run with.
Comment 35 Chris Lumens 2010-10-07 09:11:03 EDT
dlehman built it last night
Comment 36 James Laska 2010-10-12 12:00:19 EDT
Brian, you had the most consistent reproducer, are you still seeing this?
Comment 37 James Laska 2010-10-12 12:02:39 EDT
Moving to ON_QA as this is available for testing (see https://admin.fedoraproject.org/updates/anaconda-14.19-1.fc14)
Comment 38 Brian Lane 2010-10-12 13:43:29 EDT
(In reply to comment #37)
> Moving to ON_QA as this is available for testing (see
> https://admin.fedoraproject.org/updates/anaconda-14.19-1.fc14)

Yes, works fine for me with the netinst.iso image using anaconda-14.18
Comment 39 He Rui 2010-10-13 05:17:51 EDT
Verified it fixed in anaconda 14.19.
Comment 40 Jesse Keating 2010-10-21 12:05:29 EDT
14.22 is in stable.

Note You need to log in before you can comment on or make changes to this bug.