Bug 639280

Summary: vte not setting TERM variable for terminal emulators other than gnome-terminal
Product: [Fedora] Fedora Reporter: rvcsaba
Component: vteAssignee: Behdad Esfahbod <behdad>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 14CC: aronparsons, awilliam, behdad, dennis, devurandom, johannes.lips, kevin, nathan, simon, tomspur, walters
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AcceptedNTH
Fixed In Version: vte-0.26.1-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 754557 (view as bug list) Environment:
Last Closed: 2010-10-14 10:10:43 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 635218    

Description rvcsaba 2010-10-01 07:11:00 EDT
Description of problem:

I use Xfce Terminal, but I type

mc

it print the message:

Your terminal lacks the ability to clear the screen or position the cursor.

This problem since update ~ 1st october, 2010. If I use gnome-terminal, mc work.


Version-Release number of selected component (if applicable):

Terminal-0.4.5-2.fc14.x86_64


How reproducible:

always


Expected results:

Terminal is good.
Comment 1 rvcsaba 2010-10-01 08:15:00 EDT
Other applications in terminal:

less /etc/system-release
WARNING: terminal is not fully functional
/etc/system-release  (press RETURN)
Comment 2 Kevin Fenzi 2010-10-01 11:18:38 EDT
I've had another report of this too. ;( 

TERM is not getting set right. 

Can you do an 'env' command and add the output here?
Also, if you do: 

export TERM=xterm 

does everything start working?
Comment 3 Dennis Gilmore 2010-10-01 11:25:05 EDT
i had this also

TERM was set to dumb for me
Comment 4 rvcsaba 2010-10-01 12:42:50 EDT
echo "$TERM"
dumb

export TERM=xterm

command temporarily solved my problem. Thank you! :)
Comment 5 Kevin Fenzi 2010-10-01 14:57:25 EDT
Looks like a vte commit broke all vte using terminals except for gnome-terminal. ;) 

See upstream gnome bug https://bugzilla.gnome.org/show_bug.cgi?id=630861
Comment 6 Adam Williamson 2010-10-01 17:26:23 EDT
This was discussed at the 2010-10-01 blocker / nth review meeting. Since GNOME and KDE terminals are not affected we decided this was not a blocker, but definitely a nice-to-have and we would very much want it to be fixed for the release.
Comment 7 Kevin Fenzi 2010-10-09 23:36:46 EDT
http://git.gnome.org/browse/vte/patch/?id=c5d31b87d7a377f5e6fe93fc1efb061f5c7e9db7

is a possible fix from upstream (already commited). 

Can folks try this scratch build: 
http://koji.fedoraproject.org/koji/taskinfo?taskID=2525453

diff --git a/vte.spec b/vte.spec
index 169d285..2269d29 100644
--- a/vte.spec
+++ b/vte.spec
@@ -4,12 +4,13 @@
 
 Name: vte
 Version: 0.26.0
-Release: 1%{?dist}
+Release: 3%{?dist}
 Summary: A terminal emulator
 License: LGPLv2+
 Group: User Interface/X
 #VCS: git:git://git.gnome.org/vte
 Source: http://download.gnome.org/sources/vte/0.26/%{name}-%{version}.tar.bz2
+Patch1: vte-0.26.0-term-fix.patch
 
 BuildRequires: gtk2-devel >= %{gtk2_version}
 BuildRequires: pango-devel >= %{pango_version}
@@ -43,6 +44,7 @@ vte.
 
 %prep
 %setup -q
+%patch1 -p1
 
 %build
 PYTHON=%{_bindir}/python`%{__python} -c "import sys ; print sys.version[:3]"`
@@ -100,6 +102,9 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/*.a
 %doc %{_datadir}/gtk-doc/html/vte-0.0
 
 %changelog
+* Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.26.0-2
+- Add patch for term issue. 
+
 * Wed Sep 29 2010 Matthias Clasen <mclasen@redhat.com> 0.26.0-1
 - Update to 0.26
Comment 8 Nathan Thomas 2010-10-11 05:11:43 EDT
I was also experiencing this problem. Kevin's fix worked for me - everything works properly in Terminal now. Also fixes lilyterm and tilda. Thanks Kevin!

Nathan
Comment 9 rvcsaba 2010-10-11 05:31:51 EDT
vte-0.26.0-3.fc14.x86_64 solved this bug, it's work for me! Thanks! :)
Comment 10 Thomas Spura 2010-10-13 03:51:04 EDT
yeha, vim works again with the vte version from kevin...

Thanks Kevin!
Comment 11 hannes 2010-10-13 04:32:02 EDT
Yes, also worked for me! Thanks very much as f14 is much better now ;)
Comment 12 Colin Walters 2010-10-13 11:35:01 EDT
Don't forget to add an upstream bug link as a comment above the patch:

https://fedoraproject.org/wiki/Packaging:Guidelines#All_patches_should_have_an_upstream_bug_link_or_comment
Comment 13 Behdad Esfahbod 2010-10-13 11:46:29 EDT
Released upstream vte 0.26.1 that fixes this.
Comment 14 Kevin Fenzi 2010-10-13 14:58:39 EDT
*** Bug 638423 has been marked as a duplicate of this bug. ***
Comment 15 Kevin Fenzi 2010-10-13 14:58:59 EDT
*** Bug 642004 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2010-10-13 15:01:06 EDT
vte-0.26.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/vte-0.26.1-1.fc14
Comment 17 Kevin Fenzi 2010-10-13 15:02:41 EDT
If everyone could please test the above update and up karma it so we could get it in for f14, that would be great. ;)
Comment 18 Simon Schampijer 2010-10-13 15:58:56 EDT
(In reply to comment #17)
> If everyone could please test the above update and up karma it so we could get
> it in for f14, that would be great. ;)

Thanks for pulling in the new upstream update so quickly! Does work great for me with sugar-terminal - /me has given his karma.
Comment 19 rvcsaba 2010-10-13 16:04:43 EDT
I tested it - vte-0.26.1-1.fc14 - with Xfce Terminal, work correctly. :)
Comment 20 Fedora Update System 2010-10-13 17:22:43 EDT
vte-0.26.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vte'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/vte-0.26.1-1.fc14
Comment 21 Fedora Update System 2010-10-14 10:10:38 EDT
vte-0.26.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.