This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 665061

Summary: add support for the postlogin PAM stack to gdm
Product: [Fedora] Fedora Reporter: Paolo Bonzini <pbonzini>
Component: gdmAssignee: jmccann
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: ascii79, cschalle, dwmw2, jmccann, mhlavink, pbonzini, piergiorgio.sartor, pmrpla, psplicha, rstrode, tmraz
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gdm-2.91.6-8.fc15 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 486152 Environment:
Last Closed: 2011-03-02 22:31:43 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 665059    
Bug Blocks: 486152, 617282    
Attachments:
Description Flags
patch to the package pbonzini: review?

Description Paolo Bonzini 2010-12-22 10:46:08 EST
In order to use the automount feature of ecryptfs, for the ~/Private folder, some modifications to /etc/pam.d/system-auth are required.  In order to integrate pam_ecryptfs.so awareness into authconfig, we decided to create a new PAM stack.  This is because of the wide usage of "sufficient" modules for the primary authentication modules (pam_unix, pam_krb5, pam_sss, pam_ldap) in the configurations generated by authconfig.
Comment 1 Paolo Bonzini 2010-12-22 10:55:03 EST
Created attachment 470225 [details]
patch to the package
Comment 2 Paolo Bonzini 2011-02-01 11:13:30 EST
Comment on attachment 470225 [details]
patch to the package

Patch used to build http://koji.fedoraproject.org//koji/taskinfo?taskID=2754227 -- please review and apply.
Comment 3 Ray Strode [halfline] 2011-02-14 13:38:21 EST
Building now, will request it get pulled in shortly.
Comment 4 Fedora Update System 2011-02-14 13:58:09 EST
gdm-2.91.6-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gdm-2.91.6-8.fc15
Comment 5 Fedora Update System 2011-02-15 12:29:02 EST
gdm-2.91.6-8.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdm'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gdm-2.91.6-8.fc15
Comment 6 Fedora Update System 2011-03-02 22:31:15 EST
gdm-2.91.6-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.