Bug 665059 - include a postlogin stack
include a postlogin stack
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 486152 665060 665061 665062 665063
  Show dependency treegraph
 
Reported: 2010-12-22 10:45 EST by Paolo Bonzini
Modified: 2010-12-22 12:34 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 486152
Environment:
Last Closed: 2010-12-22 12:34:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to the package (1.13 KB, patch)
2010-12-22 10:53 EST, Paolo Bonzini
no flags Details | Diff

  None (edit)
Description Paolo Bonzini 2010-12-22 10:45:40 EST
In order to use the automount feature of ecryptfs, for the ~/Private folder, some modifications to /etc/pam.d/system-auth are required.  In order to integrate pam_ecryptfs.so awareness into authconfig, we decided to create a new PAM stack.  This is because of the wide usage of "sufficient" modules for the primary authentication modules (pam_unix, pam_krb5, pam_sss, pam_ldap) in the configurations generated by authconfig.
Comment 1 Paolo Bonzini 2010-12-22 10:53:21 EST
Created attachment 470223 [details]
patch to the package
Comment 2 Tomas Mraz 2010-12-22 12:34:05 EST
I've also added a simple manual page for the postlogin config file.

Note You need to log in before you can comment on or make changes to this bug.