Bug 670493

Summary: Broken link: file /usr/share/doc/python-docs-2.7/html/modindex.html is missing
Product: [Fedora] Fedora Reporter: Tadej Janež <tadej.j>
Component: python-docsAssignee: Dave Malcolm <dmalcolm>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: alberth289346, dmalcolm, ivazqueznet, kkbbf81jd6, rrakus, stefanrin
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-docs-2.7.2-2.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 771218 (view as bug list) Environment:
Last Closed: 2011-08-11 18:43:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 771218    

Description Tadej Janež 2011-01-18 13:40:45 UTC
Description of problem:
A modindex.html file is missing from the python-docs package.


Version-Release number of selected component (if applicable):
python-docs-2.7-1.fc14.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Open browser at file:///usr/share/doc/python-docs-2.7/html/index.html
2. Click on Global Module Index
3. Site is not found.

Additional info:
Opening the same link on Python's online documentation works ok.

Comment 1 Steve 2011-06-17 11:52:28 UTC
The problem exists on Fedora 15 too.
A workaround:
$ cd /usr/share/doc/python-docs-2.7.1/html
$ cp py-modindex.html modindex.html

Comment 2 Stefan Ring 2011-08-11 14:14:24 UTC
It's not only this file that's missing, but the entire C-API documentation is utterly broken. See <file:///usr/share/doc/python-docs-2.7/html/c-api/int.html>, for example.

When I still had Python 2.6 on my Fedora machine (I think it was F13), the local API doc did work. It seems that something bad happened with the transition to Python 2.7.

Comment 3 Dave Malcolm 2011-08-11 18:33:58 UTC
Thanks for filing this bug; sorry about the belated response.

I'm seeing comment 0 on Fedora 15 with
  python-docs-2.7.1-2.fc15.noarch
where:
  /usr/share/doc/python-docs-2.7.1/html/index.html
has two links to "py-modindex.html" (which works) but also a link to "modindex.html" (which doesn't)

As per comment #2: this works for me, albeit 2.7.1:
  file:///usr/share/doc/python-docs-2.7.1/html/c-api/int.html

This seems to come from sphinx; in domains/python.py I see:
class PythonModuleIndex(Index):
    """
    Index subclass to provide the Python module index.
    """

    name = 'modindex'

whereas:
domainds/std.py has:
            'modindex': ('py-modindex', '', l_('Module Index')),

(this is within python-sphinx-1.0.7-2.fc15.noarch)

Workaround committed to git as:
  http://pkgs.fedoraproject.org/gitweb/?p=python-docs.git;a=commitdiff;h=d465f3652c286afaeaeca012426b85729f84796d

This also adds a %check that runs linkchecker over the local links, to verify
that they all work.

Building python-docs-2.7.2-2.fc17 for dist-rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=3266543

Comment 4 Stefan Ring 2011-08-12 08:56:50 UTC
> As per comment #2: this works for me, albeit 2.7.1:
>   file:///usr/share/doc/python-docs-2.7.1/html/c-api/int.html

True, this is only broken in F14, not in F15.

Comment 5 Dave Malcolm 2011-08-20 14:47:30 UTC
*** Bug 732190 has been marked as a duplicate of this bug. ***

Comment 6 Steve 2011-12-22 00:38:12 UTC
The problem still exists in Fedora 16 with python-docs 2.7.2 1.fc16

Steps to Reproduce:
1. Open browser at file:///usr/share/doc/python-docs-2.7.2/html/index.html
2. Click on Global Module Index
3. File not found
    Firefox can't find the file at /usr/share/doc/python-docs-2.7.2/html/modindex.html.

I see the status as "closed", "Fixed In Version: 	python-docs-2.7.2-2.fc17"
So the solution, applied in Aug-2011, fixed the next but one release (Fedora 17), but did not fix the upcoming (and now current) release Fedora 16?

Comment 7 Tadej Janež 2011-12-23 10:23:05 UTC
(In reply to comment #6)
> The problem still exists in Fedora 16 with python-docs 2.7.2 1.fc16

The fixed python-docs just has to be rebuilt on F16 and pushed as an update.
Maybe Dave or some other python-docs maintainer could do that?