Bug 771218 - Broken link: file /usr/share/doc/python-docs-2.7/html/modindex.html is missing
Summary: Broken link: file /usr/share/doc/python-docs-2.7/html/modindex.html is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-docs
Version: 16
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 670493
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-02 15:06 UTC by Roman Rakus
Modified: 2014-01-13 00:14 UTC (History)
8 users (show)

Fixed In Version: python-docs-2.7.2-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of: 670493
Environment:
Last Closed: 2012-01-19 01:28:50 UTC


Attachments (Terms of Use)

Description Roman Rakus 2012-01-02 15:06:57 UTC
+++ This bug was initially created as a clone of Bug #670493 +++

Description of problem:
A modindex.html file is missing from the python-docs package.


Version-Release number of selected component (if applicable):
python-docs-2.7-1.fc14.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Open browser at file:///usr/share/doc/python-docs-2.7/html/index.html
2. Click on Global Module Index
3. Site is not found.

Additional info:
Opening the same link on Python's online documentation works ok.

--- Additional comment from kkbbf81jd6@ipharzle.e4ward.com on 2011-06-17 07:52:28 EDT ---

The problem exists on Fedora 15 too.
A workaround:
$ cd /usr/share/doc/python-docs-2.7.1/html
$ cp py-modindex.html modindex.html

--- Additional comment from s.r@visotech.at on 2011-08-11 10:14:24 EDT ---

It's not only this file that's missing, but the entire C-API documentation is utterly broken. See <file:///usr/share/doc/python-docs-2.7/html/c-api/int.html>, for example.

When I still had Python 2.6 on my Fedora machine (I think it was F13), the local API doc did work. It seems that something bad happened with the transition to Python 2.7.

--- Additional comment from dmalcolm@redhat.com on 2011-08-11 14:33:58 EDT ---

Thanks for filing this bug; sorry about the belated response.

I'm seeing comment 0 on Fedora 15 with
  python-docs-2.7.1-2.fc15.noarch
where:
  /usr/share/doc/python-docs-2.7.1/html/index.html
has two links to "py-modindex.html" (which works) but also a link to "modindex.html" (which doesn't)

As per comment #2: this works for me, albeit 2.7.1:
  file:///usr/share/doc/python-docs-2.7.1/html/c-api/int.html

This seems to come from sphinx; in domains/python.py I see:
class PythonModuleIndex(Index):
    """
    Index subclass to provide the Python module index.
    """

    name = 'modindex'

whereas:
domainds/std.py has:
            'modindex': ('py-modindex', '', l_('Module Index')),

(this is within python-sphinx-1.0.7-2.fc15.noarch)

Workaround committed to git as:
  http://pkgs.fedoraproject.org/gitweb/?p=python-docs.git;a=commitdiff;h=d465f3652c286afaeaeca012426b85729f84796d

This also adds a %check that runs linkchecker over the local links, to verify
that they all work.

Building python-docs-2.7.2-2.fc17 for dist-rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=3266543

--- Additional comment from s.r@visotech.at on 2011-08-12 04:56:50 EDT ---

> As per comment #2: this works for me, albeit 2.7.1:
>   file:///usr/share/doc/python-docs-2.7.1/html/c-api/int.html

True, this is only broken in F14, not in F15.

--- Additional comment from dmalcolm@redhat.com on 2011-08-20 10:47:30 EDT ---

*** Bug 732190 has been marked as a duplicate of this bug. ***

--- Additional comment from kkbbf81jd6@ipharzle.e4ward.com on 2011-12-21 19:38:12 EST ---

The problem still exists in Fedora 16 with python-docs 2.7.2 1.fc16

Steps to Reproduce:
1. Open browser at file:///usr/share/doc/python-docs-2.7.2/html/index.html
2. Click on Global Module Index
3. File not found
    Firefox can't find the file at /usr/share/doc/python-docs-2.7.2/html/modindex.html.

I see the status as "closed", "Fixed In Version: 	python-docs-2.7.2-2.fc17"
So the solution, applied in Aug-2011, fixed the next but one release (Fedora 17), but did not fix the upcoming (and now current) release Fedora 16?

--- Additional comment from tadej.janez@tadej.hicsalta.si on 2011-12-23 05:23:05 EST ---

(In reply to comment #6)
> The problem still exists in Fedora 16 with python-docs 2.7.2 1.fc16

The fixed python-docs just has to be rebuilt on F16 and pushed as an update.
Maybe Dave or some other python-docs maintainer could do that?

Comment 1 Fedora Update System 2012-01-02 15:41:13 UTC
python-docs-2.7.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-docs-2.7.2-2.fc16

Comment 2 Fedora Update System 2012-01-02 21:54:16 UTC
Package python-docs-2.7.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-docs-2.7.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0030/python-docs-2.7.2-2.fc16
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2012-01-19 01:28:50 UTC
python-docs-2.7.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.