Bug 672282

Summary: /etc/resolv.conf is not updated with nameserver during ipv6-only static network configuration in anaconda
Product: [Fedora] Fedora Reporter: Radek Vykydal <rvykydal>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: aj.werkman, anaconda-maint-list, dcbw, jcm, jklimes, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: NetworkManager-0.8.3.996-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-01 20:50:11 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 657619    

Description Radek Vykydal 2011-01-24 12:30:57 EST
Description of problem:

Installation using ipv6-only network fails due to name resolution.

Version-Release number of selected component (if applicable):

anaconda: 15.13
NetworkManager: 0.8.2-3.git20101117.fc15

How reproducible:

always

Steps to Reproduce:
1. Start installation, in loader UI (can be invoked by using asknetwork boot parameter or repo=http//... boot parameter) disable ipv4, configure ipv6 to manual, setting working dns server.
2. See empty /etc/resolv.conf in tty2.
  
Actual results:
Empty /etc/resolv.conf => name resolution failing.

Expected results:
Working ipv6 name resolution.

Additional info:

ifcfg file:

DEVICE=pci3#1
ONBOOT=yes
IPV6INIT=yes
IPV6_AUTOCONF=no
IPV6ADDR=2001:aaaa::3/64
IPV6_DEFAULTGW=2001:aaaa::1
DNS1=2001:aaaa::4
TYPE=Ethernet
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
NAME="System pci3#1"
UUID=91c55fcb-2f5d-098e-a56d-932d59f90e17
HWADDR=00:0C:29:09:85:FA
LAST_CONNECT=1295876472

I am attaching log with NetworkManager messages.

My VM configuration has also one more NIC (pci4#2) having dhcp4 server on link (used to get images via PXE), but it is not activated at all (NM_CONTROLLED=no, ONBOOT=no) so it shouldn't matter.

The bug is related to https://fedoraproject.org/wiki/Anaconda/Features/Ipv6OnlyInstallation F15 feature.
Comment 1 Radek Vykydal 2011-01-24 12:33:51 EST
Reassigning to NM as NetworkManager updates /etc/resolv.conf for anaconda.
Comment 2 Radek Vykydal 2011-02-18 05:00:07 EST
*** Bug 678423 has been marked as a duplicate of this bug. ***
Comment 3 Jirka Klimes 2011-02-23 04:52:45 EST
Fixed upstream:
5444a3569352312118e3ad0b37f61afc5842b190 (master)
0d157c412776877a3cc76b845910036d29ca2f0a (NM_0_8)
Comment 4 Jirka Klimes 2011-02-23 05:00:18 EST
Rawhide build with the patch:
http://koji.fedoraproject.org/koji/buildinfo?buildID=230299
Comment 5 Fedora Update System 2011-02-24 01:05:35 EST
NetworkManager-0.8.3.995-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14
Comment 6 Fedora Update System 2011-02-24 01:09:02 EST
NetworkManager-0.8.3.995-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc13
Comment 7 Fedora Update System 2011-02-24 15:56:49 EST
NetworkManager-0.8.3.995-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14
Comment 8 Fedora Update System 2011-02-25 18:42:26 EST
Package NetworkManager-0.8.3.996-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc14
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-02-25 18:45:24 EST
Package NetworkManager-0.8.3.996-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc13
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-03-01 20:48:44 EST
NetworkManager-0.8.3.996-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-03-03 04:46:49 EST
Package NetworkManager-0.8.3.997-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.997-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.997-1.fc13
then log in and leave karma (feedback).
Comment 12 Radek Vykydal 2011-03-06 12:42:44 EST
Can we get this into F15 for anaconda? Proposing as NiceToHave.
Comment 13 Fedora Update System 2011-03-24 23:29:41 EDT
NetworkManager-0.8.3.998-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.998-2.fc13
Comment 14 Fedora Update System 2011-04-12 17:27:35 EDT
NetworkManager-0.8.3.998-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.