Bug 67722

Summary: gnome-terminal does not render line drawing characters as expected
Product: [Retired] Red Hat Linux Reporter: Michael Wardle <michael.wardle>
Component: gnome-coreAssignee: Havoc Pennington <hp>
Status: CLOSED CURRENTRELEASE QA Contact: Aaron Brown <abrown>
Severity: medium Docs Contact:
Priority: low    
Version: 7.3CC: nalin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-12-14 02:37:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michael Wardle 2002-07-01 02:10:29 UTC
Description of problem:
When using GNOME Terminal to access a remote FreeBSD host and run
the system installation and configuration utility /stand/sysinstall),
line drawing characters are rendered incorrectly.  Where a box was
expected, letters appear in place, similar to:

 x     x
 x     x

I have tried setting the terminal type to vt100, vt102, xterm, and
xterm-color using the TERM environment variable.  I have tried
various fixed and proportional fonts.  I have tried disabling any
GUI-configurable internationalization options.

The box is rendered as expected when I use the versions of xterm
and rxvt that ship with the system, as it is with other vt100/xterm
terminal emulation programs such as PuTTY on Windows 2000.

I don't think the remote host has a custom termcap/terminfo entry
for gnome-terminal, but one should not be necessary.

How reproducible:

Steps to Reproduce:
1.log into a Red Hat system :-)
2.run GNOME Terminal from the panel
3.connect to a host running FreeBSD using ssh
4.execute /stand/sysinstall

Actual Results:  Dialogs appear using letters as the box borders.

Expected Results:  Dialogs appear using line drawing characters as the box 

Additional info:

Red Hat Linux 7.3/x86
rxvt 2.7.6-4
XFree86 4.2.0-8

FreeBSD 4.5-RELEASE/i386

Excerpt from sysinstall manual page:
sysinstall currently uses the dialog(3) library to do user interaction
with simple ANSI line graphics, color support for which is enabled by
either running on a syscons VTY or some other color-capable terminal
emulator (newer versions of xterm will support color when using the
``xterm-color'' termcap entry).

FreeBSD manual pages are available at

Comment 1 Michael Wardle 2002-07-01 02:31:20 UTC
Probably a duplicate of bug 29312.

A few threads on mailing lists suggest that an "ANSI" font is necessary, but
there does not seem to be any ANSI fonts available on Red Hat 7.3.

Perhaps Red Hat could include an ANSI character set typeface in a future
release if this fixes the problem.

Comment 2 Havoc Pennington 2002-07-02 02:48:51 UTC
This is most likely addressed in Rawhide.

Comment 3 Havoc Pennington 2002-12-14 02:37:09 UTC
8.0 should have resolved this issue. If not rawhide almost certainly has.
Give it a try. (Totally different terminal codebase.)

Comment 4 Michael Wardle 2002-12-15 22:00:37 UTC
I now see the expected behavior using Red Hat Linux 8.0.
Tested using Courier, Luxi Mono, and Andale Mono fonts.