Bug 682480

Summary: SPDIF out not working with kernel > (Intel HDA / ALC889)
Product: [Fedora] Fedora Reporter: Ronny Buchmann <ronny-rhbugzilla>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 14CC: ciekawy, gansalmon, itamar, jonathan, kernel-maint, kmcmartin, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-05 13:41:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
alsa-info ouput
alsa-info ouput none

Description Ronny Buchmann 2011-03-05 18:12:41 EST
External amp shows signal, but there is no sound.

F13 with latest kernel and F14 with is working.

It looks like the problem is caused by the fix in #657388 respectivly commit bc23f2c11af8b5d32724fe3e226e3edb0fdf6fb2 (this seems to be the only change which could affect ALC 889).

Analog output is working in but not in (it's working in F13 with 2.6.34.x). So I can confirm that #657388 is fixed (for analog output).
Comment 1 Ronny Buchmann 2011-03-05 18:14:31 EST
Created attachment 482478 [details]
Comment 2 Ronny Buchmann 2011-03-05 18:15:13 EST
Created attachment 482479 [details]
alsa-info ouput
Comment 3 Ronny Buchmann 2011-03-05 18:16:48 EST
see also #649613 reported by other users
Comment 4 Ronny Buchmann 2011-03-05 18:31:47 EST
Created attachment 482480 [details]
Comment 5 Ronny Buchmann 2011-03-05 18:32:29 EST
Created attachment 482481 [details]
alsa-info ouput
Comment 6 Szymon Stasik 2011-03-15 19:06:23 EDT
problem still exists with kernel-2.6.38-1.fc15.x86_64
Comment 7 Szymon Stasik 2011-03-21 19:54:03 EDT
since there is a patch in https://bugzilla.kernel.org/show_bug.cgi?id=24342#c13 and seems to work fine - what are next steps to revert this in fedora kernel packages?
Comment 8 Ronny Buchmann 2011-03-22 17:16:24 EDT
a simple revert would break it for other people, see bug 657388

adding kyle to cc, maybe he has an idea
Comment 9 Szymon Stasik 2011-03-22 19:49:12 EDT
I can confirm that https://bugzilla.kernel.org/show_bug.cgi?id=24342#c13 solves my problem at least so I guess it will work for most of other people on CC here and there ;)
Comment 10 Ronny Buchmann 2011-04-01 02:46:41 EDT
fix is in
Comment 11 Ronny Buchmann 2011-04-05 13:41:29 EDT is available in updates-testing