Bug 682480 - SPDIF out not working with kernel > 2.6.35.6-48 (Intel HDA / ALC889)
SPDIF out not working with kernel > 2.6.35.6-48 (Intel HDA / ALC889)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-05 18:12 EST by Ronny Buchmann
Modified: 2011-04-05 13:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-05 13:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg 2.6.35.6-48 (55.48 KB, text/plain)
2011-03-05 18:14 EST, Ronny Buchmann
no flags Details
alsa-info ouput 2.6.35.6-48 (40.97 KB, text/plain)
2011-03-05 18:15 EST, Ronny Buchmann
no flags Details
dmesg 2.6.35.11-83 (60.69 KB, text/plain)
2011-03-05 18:31 EST, Ronny Buchmann
no flags Details
alsa-info ouput 2.6.35.11-83 (40.86 KB, text/plain)
2011-03-05 18:32 EST, Ronny Buchmann
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 24342 None None None Never

  None (edit)
Description Ronny Buchmann 2011-03-05 18:12:41 EST
External amp shows signal, but there is no sound.

F13 with latest kernel and F14 with 2.6.35.6-48 is working.

It looks like the problem is caused by the fix in #657388 respectivly commit bc23f2c11af8b5d32724fe3e226e3edb0fdf6fb2 (this seems to be the only change which could affect ALC 889).

Analog output is working in 2.6.35.11 but not in 2.6.35.6-48 (it's working in F13 with 2.6.34.x). So I can confirm that #657388 is fixed (for analog output).
Comment 1 Ronny Buchmann 2011-03-05 18:14:31 EST
Created attachment 482478 [details]
dmesg 2.6.35.6-48
Comment 2 Ronny Buchmann 2011-03-05 18:15:13 EST
Created attachment 482479 [details]
alsa-info ouput 2.6.35.6-48
Comment 3 Ronny Buchmann 2011-03-05 18:16:48 EST
see also #649613 reported by other users
Comment 4 Ronny Buchmann 2011-03-05 18:31:47 EST
Created attachment 482480 [details]
dmesg 2.6.35.11-83
Comment 5 Ronny Buchmann 2011-03-05 18:32:29 EST
Created attachment 482481 [details]
alsa-info ouput 2.6.35.11-83
Comment 6 Szymon Stasik 2011-03-15 19:06:23 EDT
problem still exists with kernel-2.6.38-1.fc15.x86_64
Comment 7 Szymon Stasik 2011-03-21 19:54:03 EDT
since there is a patch in https://bugzilla.kernel.org/show_bug.cgi?id=24342#c13 and seems to work fine - what are next steps to revert this in fedora kernel packages?
Comment 8 Ronny Buchmann 2011-03-22 17:16:24 EDT
a simple revert would break it for other people, see bug 657388

adding kyle to cc, maybe he has an idea
Comment 9 Szymon Stasik 2011-03-22 19:49:12 EDT
I can confirm that https://bugzilla.kernel.org/show_bug.cgi?id=24342#c13 solves my problem at least so I guess it will work for most of other people on CC here and there ;)
Comment 10 Ronny Buchmann 2011-04-01 02:46:41 EDT
fix is in 2.6.35.12
Comment 11 Ronny Buchmann 2011-04-05 13:41:29 EDT
2.6.35.12-88.fc14 is available in updates-testing

Note You need to log in before you can comment on or make changes to this bug.