Bug 696218

Summary: Unable to create cgroup: No such file or directory
Product: [Fedora] Fedora Reporter: Martin Kho <lists.kho>
Component: virt-managerAssignee: Cole Robinson <crobinso>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: amcnabb, berrange, crobinso, darrellpf, ehabkost, hbrock, hpetty, ipilcher, jforbes, jnevill, niki.guldbrand, plambri, virt-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-13 11:13:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Martin Kho 2011-04-13 11:20:15 EDT
Description of problem:

Unable to complete install: 'Unable to create cgroup for Fedora_15_1204: No such file or directory'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1643, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1187, in start_install
    start_xml, final_xml, is_initial)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1246, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 1446, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: Unable to create cgroup for Fedora_15_1204: No such file or directory

Version-Release number of selected component (if applicable):

How reproducible:
Every time a new vm is created

Steps to Reproduce:
1. Start Virtual Machine Manager
2. Choose "Create a new virtual machine" and follow al steps
3. At step 5 press button "Finish" -> the above error appears
Actual results:
New vm is not created

Expected results:
New vm is created

Additional info:
Comment 1 Martin Kho 2011-04-13 11:24:00 EDT

Just tried to start an existing vm. Got the same error message.

Martin Kho
Comment 2 Martin Kho 2011-04-13 11:30:03 EDT

Not sure if it's relevant but cgroup.service failed at boot time:

[martin@ps-1866 ~]$ systemctl status cgconfig.service
cgconfig.service - LSB: start and stop the WLM configuration
          Loaded: loaded (/etc/rc.d/init.d/cgconfig)
          Active: failed since Wed, 13 Apr 2011 13:36:03 +0200; 3h 51min ago
          CGroup: name=systemd:/system/cgconfig.service

Martin Kho
Comment 3 Martin Kho 2011-04-18 07:50:40 EDT

An update (libguestfs?) solved this issue. Please close this report.


Martin Kho
Comment 4 Cole Robinson 2011-04-20 10:08:41 EDT
Closing per comment #4
Comment 5 Pierguido Lambri 2011-05-19 08:52:00 EDT

I'm getting again the error:

libvirtError: Unable to create cgroup for $VIRTIMAGE: No such file or

Checking the logs I see:

May 19 13:38:30 piernb libvirtd: 13:38:30.440: 1643: error : qemuSetupCgroup:199 : Unable to create cgroup for $VIRTIMAGE: No such file or directory
May 19 13:38:30 piernb libvirtd: 13:38:30.452: 1643: error : qemuRemoveCgroup:350 : internal error Unable to find cgroup for $VIRTIMAGE
May 19 13:38:30 piernb libvirtd: 13:38:30.452: 1643: warning : qemudShutdownVMDaemon:3115 : Failed to remove cgroup for $VIRTIMAGE

I was able to solve it by modifying the configuration in the file /etc/libvirt/qemu.conf:

 cgroup_controllers = [ ]

I'm using the latest F15, with the testing repo enabled.
Comment 6 Andrew McNabb 2011-05-25 15:00:59 EDT
I am also experiencing this error in a fresh install of Fedora 15.
Comment 7 darrell pfeifer 2011-05-25 19:02:46 EDT
Same "unable to create cgroup" problem for me. Using updated rawhide.
Comment 8 Heath Petty 2011-05-26 14:08:46 EDT
I hit this on Fedora 15 GA. I (re)started cgconfig, then restarted libvirtd and I was able to start my VMs again. It looks like cgconfig is crashing. I didn't see an abrt alert, so I didn't catch the crash.

Comment 9 darrell pfeifer 2011-05-26 22:39:22 EDT
The works with the latest rawhide (so with systemd 28-1)
Comment 10 Justin I. Nevill 2011-05-27 14:10:07 EDT
This would seem to be a dupe of 666130. - Justin
Comment 11 Niki Guldbrand 2011-05-30 18:40:48 EDT
*** Bug 709164 has been marked as a duplicate of this bug. ***
Comment 12 Niki Guldbrand 2011-05-30 18:43:39 EDT
Restarting cgconfig fixes it here too, it was also in a failed state here.
Comment 13 Ian Pilcher 2011-06-11 16:07:51 EDT
Does anyone know what is actually causing these errors?  Perhaps more
importantly, does anyone care?

Restarting libvirtd is a fairly painful workaround, particularly when one
hits the error while creating a new VM (since everything has to be
Comment 14 Cole Robinson 2011-06-13 11:13:20 EDT
This is a systemd bug already being tracked. Closing as DUPLICATE

*** This bug has been marked as a duplicate of bug 678555 ***