Bug 696218 - Unable to create cgroup: No such file or directory
Summary: Unable to create cgroup: No such file or directory
Status: CLOSED DUPLICATE of bug 678555
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 709164 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-13 15:20 UTC by Martin Kho
Modified: 2011-06-13 15:13 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-06-13 15:13:20 UTC


Attachments (Terms of Use)

Description Martin Kho 2011-04-13 15:20:15 UTC
Description of problem:

Unable to complete install: 'Unable to create cgroup for Fedora_15_1204: No such file or directory'
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1643, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1187, in start_install
    start_xml, final_xml, is_initial)
  File "/usr/lib/python2.7/site-packages/virtinst/Guest.py", line 1246, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 1446, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: Unable to create cgroup for Fedora_15_1204: No such file or directory

Version-Release number of selected component (if applicable):
virt-manager-0.8.7-3.fc16.noarch

How reproducible:
Every time a new vm is created

Steps to Reproduce:
1. Start Virtual Machine Manager
2. Choose "Create a new virtual machine" and follow al steps
3. At step 5 press button "Finish" -> the above error appears
  
Actual results:
New vm is not created

Expected results:
New vm is created

Additional info:

Comment 1 Martin Kho 2011-04-13 15:24:00 UTC
Hi,

Just tried to start an existing vm. Got the same error message.

Martin Kho

Comment 2 Martin Kho 2011-04-13 15:30:03 UTC
Hi,

Not sure if it's relevant but cgroup.service failed at boot time:

[martin@ps-1866 ~]$ systemctl status cgconfig.service
cgconfig.service - LSB: start and stop the WLM configuration
          Loaded: loaded (/etc/rc.d/init.d/cgconfig)
          Active: failed since Wed, 13 Apr 2011 13:36:03 +0200; 3h 51min ago
          CGroup: name=systemd:/system/cgconfig.service


Martin Kho

Comment 3 Martin Kho 2011-04-18 11:50:40 UTC
Hi,

An update (libguestfs?) solved this issue. Please close this report.

Thanks,


Martin Kho

Comment 4 Cole Robinson 2011-04-20 14:08:41 UTC
Closing per comment #4

Comment 5 Pierguido Lambri 2011-05-19 12:52:00 UTC
Hi,

I'm getting again the error:

libvirtError: Unable to create cgroup for $VIRTIMAGE: No such file or
directory

Checking the logs I see:


May 19 13:38:30 piernb libvirtd: 13:38:30.440: 1643: error : qemuSetupCgroup:199 : Unable to create cgroup for $VIRTIMAGE: No such file or directory
May 19 13:38:30 piernb libvirtd: 13:38:30.452: 1643: error : qemuRemoveCgroup:350 : internal error Unable to find cgroup for $VIRTIMAGE
May 19 13:38:30 piernb libvirtd: 13:38:30.452: 1643: warning : qemudShutdownVMDaemon:3115 : Failed to remove cgroup for $VIRTIMAGE

I was able to solve it by modifying the configuration in the file /etc/libvirt/qemu.conf:

 cgroup_controllers = [ ]

I'm using the latest F15, with the testing repo enabled.

Comment 6 Andrew McNabb 2011-05-25 19:00:59 UTC
I am also experiencing this error in a fresh install of Fedora 15.

Comment 7 darrell pfeifer 2011-05-25 23:02:46 UTC
Same "unable to create cgroup" problem for me. Using updated rawhide.

Comment 8 Heath Petty 2011-05-26 18:08:46 UTC
I hit this on Fedora 15 GA. I (re)started cgconfig, then restarted libvirtd and I was able to start my VMs again. It looks like cgconfig is crashing. I didn't see an abrt alert, so I didn't catch the crash.

-Heath

Comment 9 darrell pfeifer 2011-05-27 02:39:22 UTC
The works with the latest rawhide (so with systemd 28-1)

Comment 10 Justin I. Nevill 2011-05-27 18:10:07 UTC
This would seem to be a dupe of 666130. - Justin

Comment 11 Niki Guldbrand 2011-05-30 22:40:48 UTC
*** Bug 709164 has been marked as a duplicate of this bug. ***

Comment 12 Niki Guldbrand 2011-05-30 22:43:39 UTC
Restarting cgconfig fixes it here too, it was also in a failed state here.

Comment 13 Ian Pilcher 2011-06-11 20:07:51 UTC
Does anyone know what is actually causing these errors?  Perhaps more
importantly, does anyone care?

Restarting libvirtd is a fairly painful workaround, particularly when one
hits the error while creating a new VM (since everything has to be
re-entered).

Comment 14 Cole Robinson 2011-06-13 15:13:20 UTC
This is a systemd bug already being tracked. Closing as DUPLICATE

*** This bug has been marked as a duplicate of bug 678555 ***


Note You need to log in before you can comment on or make changes to this bug.