Bug 714710

Summary: Provide native systemd unit file
Product: [Fedora] Fedora Reporter: Jóhann B. Guðmundsson <johannbg>
Component: openvpnAssignee: Steven Pritchard <steve>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: hhorak, h.reindl, huzaifas, steve
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openvpn-2.2.1-2.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-30 15:43:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 713562    
Attachments:
Description Flags
Native systemd service template for openvpn
none
Conf file to statically load the tun module at boot
none
tmpfile for openvpn
none
Spec file patch for openvpn none

Description Jóhann B. Guðmundsson 2011-06-20 09:42:46 EDT
Description of problem:

https://fedoraproject.org/wiki/Features/SysVtoSystemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-07-18 05:53:59 EDT
What's the current status of this?

Openvpn is part of the default live cd not having native systemd unit file for it will end up blocking the alpha release. 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 2 Jóhann B. Guðmundsson 2011-07-18 06:02:38 EDT
Note there is some discussion happening upstream so Dan you might want to chime into that.. 

http://lists.freedesktop.org/archives/systemd-devel/2011-July/002896.html
Comment 3 Jóhann B. Guðmundsson 2011-07-18 13:12:07 EDT
Uhum that link is meant for bug 661230
Comment 4 Jóhann B. Guðmundsson 2011-07-26 12:30:52 EDT
Created attachment 515315 [details]
Native systemd service template for openvpn
Comment 5 Jóhann B. Guðmundsson 2011-07-26 12:32:51 EDT
Created attachment 515320 [details]
Conf file to statically load the tun module at boot

Should be placed in /etc/modules-load.d see man modules-load.d for details
Comment 6 Jóhann B. Guðmundsson 2011-07-26 12:45:59 EDT
To test this copy the template file into /lib/systemd/system 

first create the server config file in /etc/openvpn/ directory for this example let's use hypothetical already created server1.conf and server2.conf ( as an example to run more then one instance of openvpn )


Then do for instance one 

# ln -s /lib/systemd/system/openvpn\@.service /etc/systemd/system/openvpn@server1.service

for instance two

# ln -s /lib/systemd/system/openvpn\@.service /etc/systemd/system/openvpn@server2.service

systemctl daemon-reload 

systemctl start/status/restart/stop openvpn@server1.service 
systemctl start/status/restart/stop opencpn@server2.service

etc... 

To test this on a already running instance then ust replace server1 with whatever your config file is called ( - .conf ) in /etc/openvpn/ directory 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d

Note this needs to be package and shipped preferable before thursday
Comment 7 Jóhann B. Guðmundsson 2011-07-26 16:53:56 EDT
Created attachment 515369 [details]
tmpfile for openvpn

Introducing tmpfile for openvpn dropping loading of tun altogether since it's autoloaded just fine
Comment 8 Jóhann B. Guðmundsson 2011-07-26 17:06:32 EDT
Created attachment 515371 [details]
Spec file patch for openvpn
Comment 9 Marcela Mašláňová 2011-08-02 03:43:14 EDT
*** Bug 714438 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2011-09-09 14:44:32 EDT
openvpn-2.2.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/openvpn-2.2.1-2.fc16
Comment 11 Fedora Update System 2011-09-10 14:59:42 EDT
Package openvpn-2.2.1-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openvpn-2.2.1-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openvpn-2.2.1-2.fc16
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2011-09-30 15:42:57 EDT
openvpn-2.2.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.