Bug 7154

Summary: BUG IN DYNAMIC LINKER ld.so: dl-runtime.c: 67
Product: [Retired] Red Hat Linux Reporter: cbenson
Component: glibcAssignee: Cristian Gafton <gafton>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-05 00:06:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description cbenson 1999-11-19 20:49:34 UTC
Fresh install of RH v6.1 on Dell OptiPlex GXMT 5133 (1 x 133 MHz Pentium).
External 4.3 GB Fujitsu SCSI disk, NT on internal IDE disk.

Tried various installs (Gnome workstation, variations of Custom) that work
to different degrees, but all report

BUG IN DYNAMIC LINKER ld.so: dl-runtime.c: 67: fixup: Assertion
'((reloc->r_info) & 0xff) ==7' failed!

This message repeats *a lot*. Custom install with most everything selected
results in being unable to login as root in terminal session *at all*.

"Gnome workstation" install resulted in fewest errors, but Gnome itself was
missing most of the fonts. Installing 100dpi fonts (for 21" high-res)
helped not at all. "BUG IN DYNAMIC LINKER" error still occurs.

Tried different SCSI disk, with same results, so it's not a disk error.

Can boot "linux single" successfully, and look at log files.

Comment 1 Cristian Gafton 2000-01-05 00:05:59 UTC
Can you find out what binary is producing that message? Is it the X server or
something else? Can you boot in runlevel 3 by default?

Comment 2 Cristian Gafton 2000-01-05 00:06:59 UTC
*** This bug has been marked as a duplicate of 6685 ***