Bug 6685 - BUG IN DYNAMIC LINKER ld.so: dynamic_link.h:57
BUG IN DYNAMIC LINKER ld.so: dynamic_link.h:57
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
: 6654 7154 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-03 12:04 EST by trieu.nguyen
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 00:45:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description trieu.nguyen 1999-11-03 12:04:30 EST
system is Pentium, video card is S3 86C765
Frequency: 100% reproducible
Install linux 6.1
run X windows using "startX"
the following error occurs
BUG IN DYNAMIC LINKER ld:so: dynamic_link.h:57
elf_get_dynamic_info: Assertion '! "bad dynamic tag"' failed

Tried different configurations using 'xf86config', problem
still occurred.

Also Tried a second pentium machine with video card S3
ViRGE.  The problem still showed.

This is a serious bug which I think may relate to other
ld.so bugs.  This will prevent users from running X and X
application.
Comment 1 Bill Nottingham 1999-11-03 12:10:59 EST
*** This bug has been marked as a duplicate of 6667 ***
Comment 2 Bill Nottingham 1999-11-03 12:13:59 EST
What does:
rpm -V glibc
rpm -V XFree86
say?

Also, is this a new install or an upgrade, and what does
/etc/ld.so.conf say?
Comment 3 Bill Nottingham 1999-11-03 12:15:59 EST
*** Bug 6654 has been marked as a duplicate of this bug. ***

Install 6.1 fresh on HP Vectra XU 5/90.
1 Pentium 90 CPU, 64 MB Ram, 4.3 GB IDE, 16 MB /boot,
3900 MB / and 208 MB swap.

Selected everything to install.
After installation completed on reboot I get lot of
messages:
BUG IN DYNAMIC LINKER ld.so: dynamic_link.h 57: elf_dynamic
info assertion '! "bad dynamic tag" failed.

After login in as root tried to run 'ps' command and got
 the same error (and no output from ps command).

BUG IN DYNAMIC LINKER ld.so: dynamic_link.h 57: elf_dynamic
info assertion '! "bad dynamic tag" failed.

Tried different partioning of hard disk but still have same
problem.
Also applied all available updates (downloaded rpms), but
problem persists.


------- Additional Comments From   11/06/99 00:59 -------
1. I do not have any problem with X programs so I do not think 6654
   is duplicate to this.
2. I did ldconfig -n, even then got the same problem with "ps"
   suggesting it is not a problem related to /etc/ld.so.conf.
   I think the problem is how "ps" is compiled/linked.
   ldd wont run on /bin/ps so I did 'string /bin/ps | grep lib'
   here is what I got:

      /lib/ld-linux.so.2
      libproc.so.2.0.0
      libc.so.6
      Compiled with: libc %d, internal version %d.%d
vm_libpid,tname,majflt,minflt,m_trs,m_drs,m_size,m_swap,rss,m_share,vm
_lib,m_dt,args

   /bin/ls work file so I did same on it an got

     /lib/ld-linux.so.2
     libc.so.6
    __libc_start_main


Ajay
Comment 4 trieu.nguyen 1999-11-08 12:15:59 EST
I also tried on the Pentium Pro 166MHz system with video card: ATI
Mach64 3D RAGE II (4MEG).  It still exhibits the same problem.  I
think this is a bug in the  dynamic linker, ld.so not in Xfree86,
since 3 systems with 3 different videos cards (S3 86C765, S3 ViRGE,
ATI Mach64 3D RAGE II) already been tried.
Comment 5 Bill Nottingham 1999-12-17 17:30:59 EST
*** Bug 6654 has been marked as a duplicate of this bug. ***
Comment 6 Cristian Gafton 2000-01-04 17:09:59 EST
Are there any packages non-standard installed on the system? I can not reporduce
this bug here.
Comment 7 Cristian Gafton 2000-01-04 19:06:59 EST
*** Bug 7154 has been marked as a duplicate of this bug. ***
Comment 8 Cristian Gafton 2000-02-05 00:45:59 EST
closed due to lack of feedback.

Note You need to log in before you can comment on or make changes to this bug.