Bug 7154 - BUG IN DYNAMIC LINKER ld.so: dl-runtime.c: 67
BUG IN DYNAMIC LINKER ld.so: dl-runtime.c: 67
Status: CLOSED DUPLICATE of bug 6685
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-19 15:49 EST by cbenson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-04 19:06:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description cbenson 1999-11-19 15:49:34 EST
Fresh install of RH v6.1 on Dell OptiPlex GXMT 5133 (1 x 133 MHz Pentium).
External 4.3 GB Fujitsu SCSI disk, NT on internal IDE disk.

Tried various installs (Gnome workstation, variations of Custom) that work
to different degrees, but all report

BUG IN DYNAMIC LINKER ld.so: dl-runtime.c: 67: fixup: Assertion
'((reloc->r_info) & 0xff) ==7' failed!

This message repeats *a lot*. Custom install with most everything selected
results in being unable to login as root in terminal session *at all*.

"Gnome workstation" install resulted in fewest errors, but Gnome itself was
missing most of the fonts. Installing 100dpi fonts (for 21" high-res)
helped not at all. "BUG IN DYNAMIC LINKER" error still occurs.

Tried different SCSI disk, with same results, so it's not a disk error.

Can boot "linux single" successfully, and look at log files.
Comment 1 Cristian Gafton 2000-01-04 19:05:59 EST
Can you find out what binary is producing that message? Is it the X server or
something else? Can you boot in runlevel 3 by default?
Comment 2 Cristian Gafton 2000-01-04 19:06:59 EST
*** This bug has been marked as a duplicate of 6685 ***

Note You need to log in before you can comment on or make changes to this bug.