Bug 715943

Summary: FTBFS gnome-pilot-conduits-2.32.1-2.fc15
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: gnome-pilot-conduitsAssignee: Matthew Barnes <mbarnes>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: gilboad, mbarnes, omerta13, Per.t.Sjoholm, vezza
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-30 15:22:27 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 713919    
Attachments:
Description Flags
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2011-06-23 11:42:34 EDT
gnome-pilot-conduits-2.32.1-2.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:42:37 EDT
Created attachment 507994 [details]
mock.log


mock.log for i386
Comment 2 FTBFS 2011-06-23 11:42:40 EDT
Created attachment 507995 [details]
root.log


root.log for x86_64
Comment 3 FTBFS 2011-06-23 11:42:42 EDT
Created attachment 507996 [details]
build.log


build.log for x86_64
Comment 4 FTBFS 2011-06-23 11:42:43 EDT
Created attachment 507997 [details]
mock.log


mock.log for x86_64
Comment 5 Matthew Barnes 2011-06-24 09:50:49 EDT
I emailed the upstream author asking for a new release that uses gtk3 instead of gtk2.  Nothing I can do until then.
Comment 6 Matthew Barnes 2011-07-10 10:26:43 EDT
*** Bug 720160 has been marked as a duplicate of this bug. ***
Comment 7 Matthew Barnes 2011-07-18 21:43:03 EDT
*** Bug 722990 has been marked as a duplicate of this bug. ***
Comment 8 Gilboa Davara 2011-07-24 10:18:36 EDT
According to this bz [1] gnome-pilot should no longer use deprecated gnome APIs. (Or am I wrong?).
Assuming that I read it correctly, is the main issue here that gnome-pilot will pull gtk2 compat is will is simply refuse to work?

- Gilboa
[1] https://bugzilla.gnome.org/show_bug.cgi?id=590215
Comment 9 Matthew Barnes 2011-07-24 10:55:23 EDT
The problem is gnome-pilot 2.91 now uses gtk3, but there was no corresponding gnome-pilot-conduits release for gtk3.  gnome-pilot-conduits 2.32 uses gtk2 and can't be mixed with gnome-pilot 2.91.  The upstream author assured me he's working on it but I've not seen a release yet.
Comment 10 Per Sjoholm 2011-11-18 10:32:45 EST
As of 14 sep 2011
http://mail.gnome.org/archives/gnome-announce-list/2011-September/msg00042.html
I'm pleased to announce the release of gnome-pilot and
gnome-pilot-conduits 2.91.93.

This is a maintenance release to bring gnome-pilot-conduits up to gtk3,
and also to fix a few bugs, the most prominent of which was an incorrect
directory path for the evolution calendar conduit.
Comment 11 Matthew Barnes 2011-11-30 15:22:27 EST
Closing this since 2.91.93 exists in Rawhide.